Jitsi Meet android SDK build

Hello. everybody.
I hope that you are doing well.
Recently, I tried to build Jitsi android SDK on windows.
But, I failed with it and I googled many times.
Eventually, the Jitsi community says that they support Mac and Linux.
So, I tried on Ubuntu 20.04.

What went wrong:
Execution failed for task ‘:app:runDebugReactPackager’.

A problem occurred starting process ‘command ‘scripts/run-packager.sh’’

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 1m 1s

I got the fail message as above.
Though I tried to find a solution, I couldn’t find a solution.
So, I post this topic.
I tried also with Mac.
But, I got the same error.
If someone else can help me, I am very happy about it.
I expect to hear from you soon.
Thanks.

Please paste the full output.

Thanks for your fast reply.

BUILD FAILED in 6s
error Failed to install the app. Make sure you have the Android development environment set up: Setting up the development environment · React Native.
Error: Command failed: ./gradlew app:installDebug -PreactNativeDevServerPort=8081
Warning: Mapping new ns http://schemas.android.com/repository/android/common/02 to old ns http://schemas.android.com/repository/android/common/01
Warning: Mapping new ns http://schemas.android.com/repository/android/generic/02 to old ns http://schemas.android.com/repository/android/generic/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/addon2/02 to old ns http://schemas.android.com/sdk/android/repo/addon2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/addon2/03 to old ns http://schemas.android.com/sdk/android/repo/addon2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/repository2/02 to old ns http://schemas.android.com/sdk/android/repo/repository2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/repository2/03 to old ns http://schemas.android.com/sdk/android/repo/repository2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/sys-img2/03 to old ns http://schemas.android.com/sdk/android/repo/sys-img2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/sys-img2/02 to old ns http://schemas.android.com/sdk/android/repo/sys-img2/01
Warning: Mapping new ns http://schemas.android.com/repository/android/common/02 to old ns http://schemas.android.com/repository/android/common/01
Warning: Mapping new ns http://schemas.android.com/repository/android/generic/02 to old ns http://schemas.android.com/repository/android/generic/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/addon2/02 to old ns http://schemas.android.com/sdk/android/repo/addon2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/addon2/03 to old ns http://schemas.android.com/sdk/android/repo/addon2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/repository2/02 to old ns http://schemas.android.com/sdk/android/repo/repository2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/repository2/03 to old ns http://schemas.android.com/sdk/android/repo/repository2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/sys-img2/03 to old ns http://schemas.android.com/sdk/android/repo/sys-img2/01
Warning: Mapping new ns http://schemas.android.com/sdk/android/repo/sys-img2/02 to old ns http://schemas.android.com/sdk/android/repo/sys-img2/01
Warning: unexpected element (uri:"", local:“base-extension”). Expected elements are <{}codename>,<{}layoutlib>,<{}api-level>

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:runDebugReactPackager’.

A problem occurred starting process ‘command ‘scripts/run-packager.sh’’

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 6s

at makeError (/home/brianlever/Documents/jitsi-meet-android-sdk-5.0.2/node_modules/execa/index.js:174:9)
at /home/brianlever/Documents/jitsi-meet-android-sdk-5.0.2/node_modules/execa/index.js:278:16
at processTicksAndRejections (node:internal/process/task_queues:96:5)
at async runOnAllDevices (/home/brianlever/Documents/jitsi-meet-android-sdk-5.0.2/node_modules/@react-native-community/cli-platform-android/build/commands/runAndroid/runOnAllDevices.js:109:5)
at async Command.handleAction (/home/brianlever/Documents/jitsi-meet-android-sdk-5.0.2/node_modules/@react-native-community/cli/build/index.js:192:9)

That’s odd. Did you install all the dependencies?

yes.
I installed all dependencies with “npm install”.
Many people posted this issue like me.
But, there is no correct solution.
I saw all replies about this issue.
I didn’t see some correct answers.
I expect a solution from you.
Thanks.

Well, I’d give you a solution, if I had one. I don’t, yet.

What node / npm version are you using?

I have used Java 11 because it uses gradle 6.9.
maybe, what is wrong with this?
Thanks.

Node version is 16.15.0
NPM version is 8.5.5.
Thanks.

I solved this problem.
So, I ran correctly on Ubuntu 20.04
Thanks.

So, how did you solve it? What did you change?

It was a permission problem.
A problem occurred starting process ‘command ‘scripts/run-packager.sh’’
Permission for this file was not set.
So, I set permission and I solved it.
Thanks.

1 Like

Hello. Saghul.
How are you?
I need one help from you.
I built Jitsi Sdk successfully and I am using it now.
So, When I created a meeting, it shows a " you are a moderator" notification on top of the screen.
and when someone joined, it shows " xxx joined the meeting, when someone left, it shows “xxx left the meeting”.
I can control this notification?
If so, where? SDK or something else?
I expect a reply from you.
Thanks.

You can configure notifications like so: jitsi-meet/config.js at 36578696bb1e162ef6b61fb5a2b53e414bf24865 · jitsi/jitsi-meet · GitHub

Hello.
Thanks for your help.
In many fields, I got your help and it is very valuable.
Now, I want to understand one problem.
My goal is to customize Jitsi Android SDK.
I cloned it with Git and I opened it.
There, I see the react-native folder structure, android, and IOS.
By your suggestion, I ran the release-SDK.sh script and I made the custom build about SDK.
In some directory, I got built *.aar file.
By the way, in the android directory, I see the SDK directory and it has Java source code.
What is this SDK Java directory?
I must modify Java files in this SDK directory? or I must modify the react-native code?
I expect a reply about this.
Thanks.

While the UI is written with React Native, it then gets exported as a native view, which is wired to an Activity. That’s what you see there.

Usually no.

If you want to customize the UI, then you need to modify the React Native part.

Hello.
Saghul.
I got a clear understanding of it.
Basically, I am not going to change UI.
I want to change some logic.
For example, when we start a meeting with onlyAudio, in fact, it must only ask microphone permission.
But, it is asking simultaneously video permission.
I want to remove video permission when it is onlyAudio.
Do you have some idea?
I expect a reply from you.
Thanks.

and once more.
If we must add onlyVideo function, where I must modify the code?
In back-end server or react-native or SDK?

You can just start the meeting with video muted. Where is no need to modify the SDK for that, you can set the startWithVideoMuted config override to true.

Hello.
I think that this option is working for only local users.
I want to have this feature on the remote too.
Is there some solution for it?

Do you mean to have an audio-only call? You can accomplish that by setting startAudioOnly to true. Even if other participants have video you won’t receive it.