Jitsi Meet Android building

Hi community,

My team and I have tried to run the Jitsi-Meet project for Android cloning the repository.

We set the React Native dependencies using this part: https://github.com/jitsi/jitsi-meet/blob/master/doc/mobile.md , but now we have this issue.

What could be the cause and the solution? This error happens in master, but I could run it with tag jitsi-meet_4101.

I wait for your comments.

That’s really weird, I haven’t seen that one before. Does it work if you try it on a physical device?

Hi saghul! This error happens in a physical device. However, it’s happing only in master, I tried in tag jitsi-meet_4101 and it worked! We followed this article when we had the index.android.bundle error -> https://medium.com/@adityasingh_32512/solved-unable-to-load-script-from-assets-index-android-bundle-bdc5e3a3d5ff

Are you using Windows by any chance?

We are using MacOS Mojave and Android 8.1 for the device.

You shouldn’t need to do anything that article says, because the packager is started by Android Studio.

Can you try to build it using Android Studio instead of the RN cli?

We are going to try it.

Hi again!

We build it this time with Android Studio, but the error persists. However, the log its different this time ->

Oh, wait. I think I know, thanks for the heads up! Please use the mobile-19.5 branch for now. master is a bit unstable right now.

Thank you for your answer Saúl! We’re gonna to move on to this branch.

FWIW I fixed it yesterday, so master should be healthy again.

1 Like