Jitsi Meet and Jigasi - outbound number format


#1

Hi guys,
since I updated to the latest stable meet version the call a number dialog changed again. It is always requesting to enter the number with a country code.
Is there a possibility to deactivate this and just dial the number as entered?
Best regards
Timmi


#2

This is fixed in unstable.


#3

Hi,
I can confirm that the unstable does not have this issue but now I receive “Failed to add members” if I add the number an press invite.
Jigasi is registered but is not sending anything.
Best regards
Timmi


#4

Have you configured any of these:
dialInNumbersUrl, dialInConfCodeUrl, dialOutCodesUrl, dialOutAuthUrl, peopleSearchUrl, inviteServiceUrl?
Looking at the error message seems it is not sending anything to jigasi, but is trying do the people invite …
Can you share your config so we can test this usecase, thanks.


#5

is there any document for this parameters?
can I fill these parameters with static json string?


#6

There is no documentation for those. I will try extracting and creating something these days.


#7

find this link for sample


#8

So there are some descriptions here: https://github.com/jitsi/jitsi-meet/blob/master/doc/cloud-api.swagger
So dialInNumbersUrl is described as phoneNumberList and dialInConfCodeUrl is conferenceMapper.

dialOutCodesUrl is removed from the code, it just stays in meet.jit.si/config.js file and confuses me :slight_smile:

For dialOutAuthUrl it checks whether certain number can be dialed out in this case on meet.jit.si, here is an example:
https://jitsi-api.jitsi.net/authorizephone?phone=151and the response is:
{"message":"Access allowed","phone":"+151","country":"1","allow":true}

Where the response of https://jitsi-api.jitsi.net/authorizephone?phone=+35988 is
{"message":"Neither whitelisted or blacklist phone number!","phone":"+ 35988","country":false,"allow":false}

The other two are peopleSearchUrl and inviteServiceUrl, those are for directory search and invite.
https://jitsi-api.jitsi.net/directorySearch?query=dam&queryTypes=["user"%2C"conferenceRooms"]&jwt=

           [
                ...
                {
                    "avatar": "https://somavatar.url/blabla",
                    "id": "some_user_id",
                    "name": "Damyan Minkov",
                    "type": "user"
                },
                ....
            ]

How to call to person (number) by Jitsi Meet API (JavaScript in web browser)
#9

Hi,

sorry for the late reply.
No I have not configured any of these config parameters.
I control the possible numbers with the Asterisk.

Is any one of the parameters mandatory?

I also tried to call my meet.
This is the jigasi.log

2018-08-16 08:45:57.137 INFO: [69] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /172.28.52.11:5060
2018-08-16 08:45:57.141 INFO: [69] org.jitsi.jigasi.SipGateway.incomingCallReceived().144 Incoming call received...
2018-08-16 08:45:58.142 INFO: [70] org.jitsi.jigasi.SipGatewaySession.run().892 Using default JVB room name property siptest
2018-08-16 08:45:58.143 SEVERE: [70] util.UtilActivator.uncaughtException().122 An uncaught exception occurred in thread=Thread[Thread-54,10,main] and message was: null
java.lang.NullPointerException
at org.jitsi.jigasi.JvbConference.getResourceIdentifier(JvbConference.java:360)
at org.jitsi.jigasi.JvbConference.start(JvbConference.java:410)
at org.jitsi.jigasi.SipGatewaySession.joinJvbConference(SipGatewaySession.java:309)
at org.jitsi.jigasi.SipGatewaySession.access$800(SipGatewaySession.java:41)
at org.jitsi.jigasi.SipGatewaySession$WaitForJvbRoomNameThread.run(SipGatewaySession.java:898)
2018-08-16 08:46:02.913 INFO: [72] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /172.28.52.11:5060
2018-08-16 08:46:08.895 INFO: [73] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /172.28.52.11:5060
2018-08-16 08:46:08.898 INFO: [73] org.jitsi.jigasi.SipGatewaySession.handleCallState().751 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Incoming Call newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=Timmi <41@172.28.52.11>;status=Disconnected
2018-08-16 08:46:08.898 INFO: [73] org.jitsi.jigasi.SipGatewaySession.sipCallEnded().501 Sip call ended: Call: id=1534401957139553509971 peers=0
2018-08-16 08:46:08.902 SEVERE: [73] org.jitsi.jigasi.JvbConference.stop().468 Already stopped !
2018-08-16 08:46:08.902 INFO: [73] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().813 null SIP peer state: Disconnected
2018-08-16 08:46:08.904 INFO: [74] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /172.28.52.11:5060

Best regards
Timmi


#10

Can you update jigasi and test again, if problem persists paste again the error you see in jigasi log.


#11

Hi,

yes the issue was gone after the last update.

Best regards
Timmi