Jitsi Meet Active Directory authentication

Hello,

I setup jitsi meet server on a ubuntu server. I enabled authentication on the jitsi server with local users. All running as expexted. Now I tried to activate the active directory authentication. I followed the steps explained and discussed in this thread: jitsi-meet-ldap-active-directory-authentication-how-to-get-log-info

But when I try to authenticate with a AD user on the jitsi web there is only the message: connection will be established.

here are the config files of the jitsi server:

/etc/prosody/conf.avail/ldap.cfg.lua

https://modules.prosody.im/mod_lib_ldap.html
https://modules.prosody.im/mod_auth_ldap2.html
authentication = ‘ldap2’;
–storage = “ldap2”;

ldap = {
hostname = ‘domain-controller_IP’,
bind_dn = ‘cd=bind_user,cd=Users,dc=roth,dc=ads’,
bind_password = ‘password’,
user = {
usernamefield = ‘sAMAccountname’,
basedn = ‘cd=Users,dc=roth,dc=ads’,
filter = ‘(&(objectClass=User)(AccountActive=TRUE))’,
–admin?
namefield = ‘cn’,
},
}

/etc/prosody/conf.avail/jitsi.cfg.lua

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “jitsi”;

turncredentials_secret = “xxxxxxxxxxxxxx”;

turncredentials = {
{ type = “stun”, host = “jitsi”, port = “4446” },
{ type = “turn”, host = “jitsi”, port = “4446”, transport = “udp” },
{ type = “turns”, host = “jitsi”, port = “443”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
– https_ports = { }; – Remove this line to prevent listening on port 5284

VirtualHost “jitsi”
– enabled = false – Remove this line to enable this host
authentication = “ldap2”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/jitsi.key”;
certificate = “/etc/prosody/certs/jitsi.crt”;
}
speakerstats_component = “speakerstats.jitsi”
conference_duration_component = “conferenceduration.jitsi”
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
}
c2s_require_encryption = false

Component “conference.jitsi” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
}
admins = { “focus@auth.jitsi” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.jitsi” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.jitsi”, “jvb@auth.jitsi” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.jitsi”
ssl = {
key = “/etc/prosody/certs/auth.jitsi.key”;
certificate = “/etc/prosody/certs/auth.jitsi.crt”;
}
authentication = "internal_plain"Component “focus.jitsi”
component_secret = “dMNqgdRe”

Component “speakerstats.jitsi” “speakerstats_component”
muc_component = “conference.jitsi”

Component “conferenceduration.jitsi” “conference_duration_component”
muc_component = “conference.jitsi”

VirtualHost “guest.jitsi”
authentication = “anonymous”

c2s_require_encryption = false

Does anyone has an active directory authentication running with jitsi. Is there any failure in my configuration ?

Thanks for any hint!!