Jitsi Meet 2.0.8044 update dependency issues?

Hi Community,

I have the following issue on my Ubuntu 20.04.5 LTS installation while updating to the latest jitsi-meet release.

The following packages were automatically installed and are no longer required:
  ca-certificates-java coturn fonts-lato java-common javascript-common jicofo jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2 jq libevent-core-2.1-7 libevent-extra-2.1-7
  libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libgd3 libgraphite2-3 libharfbuzz0b libhiredis0.14 libjq1 libjs-jquery libmysqlclient21 libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream
  libonig5 libpcsclite1 libpq5 libruby2.7 libxpm4 lua-basexx lua-bitop lua-cjson lua-event lua-expat lua-filesystem lua-inspect lua-luaossl lua-sec lua-socket lua5.2 mysql-common nginx nginx-common nginx-core openjdk-16-jre-headless
  prosody rake ruby ruby-hocon ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby-xmlrpc ruby2.7 rubygems-integration sqlite3 unzip zip
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  jitsi-meet
The following packages will be upgraded:
  jicofo jitsi-meet-turnserver jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
5 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/74.4 MB of archives.
After this operation, 1244 kB disk space will be freed.

As you can see it looks like jitsi-meet package is getting removed and due to that all the required dependencies are not needed any more.

Is there are problem with the release or I’m doing something wrong here.

Best regards
Christoph

Same here Debian 11 … all jitsi files are deleted

Also Ubuntu 20 Server:

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.6776-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.6776-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1 Like

Which prosody version do you have?

None, installation quits (I started testing with a fresh installed server).

apt update -y &&
apt install apt-transport-https -y &&
apt update -y &&
curl https://download.jitsi.org/jitsi-key.gpg.key | sh -c 'gpg --dearmor > /usr/share/keyrings/jitsi-keyring.gpg' &&
echo 'deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/' |  tee /etc/apt/sources.list.d/jitsi-stable.list > /dev/null &&
apt update -y &&
apt install jitsi-meet -y 

On running servers it is Prosody 0.11.4

Debian 11 Bullseye shouldn’t be affected because there is a supported version of prosody in its official repo.

Prosody should be newer than 0.11.7

apt show jitsi-meet-prosody
...
Depends: openssl, prosody (>= 0.11.7)...

Add the prosody repo as described in the quick install guide.

Thank you this is solving the issue.

Hi to all.

For me add the prosody repo as described in the quick install guide not solve the problem on my Ubuntu 20.04.5 LTS installation.
This is the result when I try to update to the latest release

The following packages were automatically installed and are no longer required:
  coturn jitsi-meet-turnserver libevent-core-2.1-7 libevent-extra-2.1-7
  libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libhiredis0.14 libpq5
  linux-headers-5.4.0-131 linux-headers-5.4.0-131-generic
  linux-image-5.4.0-131-generic linux-modules-5.4.0-131-generic
  linux-modules-extra-5.4.0-131-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  cpp cpp-9 gcc-9-base libisl22 libmpc3 linux-headers-5.15.0-53-generic
  linux-headers-5.4.0-132 linux-headers-5.4.0-132-generic
  linux-hwe-5.15-headers-5.15.0-53 linux-image-5.15.0-53-generic
  linux-image-5.4.0-132-generic linux-modules-5.15.0-53-generic
  linux-modules-5.4.0-132-generic linux-modules-extra-5.15.0-53-generic
  linux-modules-extra-5.4.0-132-generic
The following packages have been kept back:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config
  jitsi-videobridge2 prosody
The following packages will be upgraded:
  jitsi-meet-turnserver libnginx-mod-http-image-filter
  libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream
  linux-generic linux-generic-hwe-20.04 linux-headers-generic
  linux-headers-generic-hwe-20.04 linux-image-generic
  linux-image-generic-hwe-20.04 nginx nginx-common nginx-core
14 upgraded, 15 newly installed, 0 to remove and 7 not upgraded.
7 standard LTS security updates

About the packages kept back. it’s safe to force the installation?
The installed Prosody version is 0.11.4-1 and the output of apt-mark showhold is empty.

Best regards
Raffaele

What is the output for

apt-cache policy prosody
prosody:
  Installed: 0.11.4-1
  Candidate: 0.12.1-1~focal1
  Version table:
     0.12.1-1~focal1 500
        500 http://packages.prosody.im/debian focal/main amd64 Packages
 *** 0.11.4-1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/status

@raffaelone
I was upgrading to Ubuntu 22 LTs as I was not able to find the lua-unbound package.

So I did disable prosody and jitis repo. Did the upgrade to LTS 22.
Updated the prosody to 0.12.
After that I have updated Jitsi without issues.

Output?

apt-cache policy jitsi-meet | head
jitsi-meet:
  Installed: 2.0.7882-1
  Candidate: 2.0.8044-1
  Version table:
     2.0.8044-1 500
        500 https://download.jitsi.org stable/ Packages
 *** 2.0.7882-1 500
        500 https://download.jitsi.org stable/ Packages
        100 /var/lib/dpkg/status
     2.0.7830-1 500

Did you run “apt-get upgrade” or “apt-get dist-upgrade”?

I think this is because coturn is missing in 22.04 …

Although I see it in some jammy-updates repo
https://packages.ubuntu.com/search?keywords=coturn&searchon=names&suite=all&section=all

1 Like

Looks like been added a month ago …

I run "apt-get update"
With “apt-get dist-upgrade” this is the output and the problem is solved.

The following packages were automatically installed and are no longer required:
  linux-headers-5.4.0-131 linux-headers-5.4.0-131-generic
  linux-image-5.4.0-131-generic linux-modules-5.4.0-131-generic
  linux-modules-extra-5.4.0-131-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  autoconf automake autotools-dev cpp cpp-9 gcc gcc-9 gcc-9-base libasan5
  libatomic1 libc-dev-bin libc6-dev libcc1-0 libcrypt-dev libdpkg-perl
  libfile-fcntllock-perl libgcc-9-dev libisl22 libitm1 liblsan0 libltdl-dev
  liblua5.1-0 liblua5.1-0-dev libmpc3 libncurses-dev libquadmath0
  libreadline-dev libtool libtool-bin libtsan0 libubsan1
  linux-headers-5.15.0-53-generic linux-headers-5.4.0-132
  linux-headers-5.4.0-132-generic linux-hwe-5.15-headers-5.15.0-53
  linux-image-5.15.0-53-generic linux-image-5.4.0-132-generic linux-libc-dev
  linux-modules-5.15.0-53-generic linux-modules-5.4.0-132-generic
  linux-modules-extra-5.15.0-53-generic linux-modules-extra-5.4.0-132-generic
  lua-any luarocks m4 manpages-dev pkg-config
The following packages will be upgraded:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web
  jitsi-meet-web-config jitsi-videobridge2 libnginx-mod-http-image-filter
  libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream
  linux-generic linux-generic-hwe-20.04 linux-headers-generic
  linux-headers-generic-hwe-20.04 linux-image-generic
  linux-image-generic-hwe-20.04 nginx nginx-common nginx-core prosody
21 upgraded, 47 newly installed, 0 to remove and 0 not upgraded.