Jitsi Local recording not working

When I run startRecord command it shows this error in console log
[modules/API/API.js] <start-recording>: Failed starting recording: local recording is either disabled or not supported

I’m using startRecord command to record locally like this documentation. → Commands | Jitsi Meet.

this.meetAPI.executeCommand("startRecording", {
        mode: `local`, //recording mode, either `local`, `file` or `stream`.
        // dropboxToken: string, //dropbox oauth2 token.
        onlySelf: true, 
        shouldShare: false,
        // rtmpStreamKey: string, //the RTMP stream key.
        // rtmpBroadcastID: string, //the RTMP broadcast ID.
        // youtubeStreamKey: string, //the youtube stream key.
        // youtubeBroadcastID: string //the youtube broacast ID.
      });

I enabled recording services in /etc/jitsi/meet/mydomain-config.js like this.

recordingService: {
         enabled: true,
         sharingEnabled: true,
         hideStorageWarning: false,
     },

    // DEPRECATED. Use recordingService.enabled instead.
    // fileRecordingsServiceEnabled: true,

    // DEPRECATED. Use recordingService.sharingEnabled instead.
    // fileRecordingsServiceSharingEnabled: false,

    // Local recording configuration.
     localRecording: {
         disable: false,
         notifyAllParticipants: false,
         disableSelfRecording: true,
     },

In toolbar there is a recording button and when I click it, shows like this. There is no any save to local option.
image

Furthermore, I have installed latest jitsi version. Highly appreciate your guidance guys.

What browser are you using?

1 Like

I’m using firefox browser

Hi @saghul sorry to bother you. I checked the meeting in Chrome browser. And it shows local recording and worked perfectly. Do you have any idea why it not works in firefox browser?
Thanks again for your valuable time.
image

Firefox does not support local recordings.

1 Like