Jitsi keep crashing as soon as second person arrives

Hi Sanvila

Many thanks for the reply. I have a VPS with a fixed IP. My provider claims that it it not behind a NAT and I certainly don’t have a private IP address. I tried getting Nginx to listen on port 443 rather than 4444, but the browser couldn’t then reach the server.

On this last installation I installed Debian 10, made no adjustments whatsoever, then immediately installed jitsi-meet. It worked in the sense that I could reach the server and start a session, but the problem of crashing described above was there from the first session.

I have since set the hostname to the subdomain name. I have pinged this hostname and it works. I have set all the ports as requested. ufw status reports as below and I’ve tested the ports with nc and nmap and they both report the ports to be working with the exception on 4443 where I get a closed error although a test with netstat suggests that the problem is that nothing is listening on the port.

I hope that you’ll be able to carry on helping (and help me solve the problem). As mentioned I’ve been working on this for weeks.

As mentioned I have installed various Debian/Ubuntu/Nginx versions configurations and I always have the same problem.

To Action From

22/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
10000/udp ALLOW Anywhere
4443/tcp ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
22/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
10000/udp (v6) ALLOW Anywhere (v6)
4443/tcp (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)

did you test the 10000 port using the following procedure:
on the server:
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u

on the computer accessing the server:
echo “123” | nc -u 10000

you should see displayed the string ‘123’ on the server console where you have running nc -l 10000 -u

Having some sofware displaying the word ‘open’ is sometimes not enough, you have to test that data can actually go through the ‘opened’ port.

Oh, and before running the command to stop the videobridge, you could also verify that it is actually running and listening on port 10000:

sudo ss -tapnu | grep 10000

Try to stop jvb and jicofo.

Then start jvb. Wait some seconds. Start jicofo.

See if this solves the problem.

Can you elaborate on that? When installing from the Debian packages, there is no need to change the nginx configuration (other than replacing the self-signed certificate of nginx by a proper one). By default nginx is configured to listen on 80 and 443, which is ok.

In my experience, there is no need to do that (the names of my machines are mostly random). When installing the Debian packages you are asked for a “domain”, that’s the same name you put in DNS and also the one nginx is told to serve in the configuration.

I see that your configuration differs from the default in this line:

useStunTurn: true,

I have such lines commented out and tell the server explicitly which is the private and the public IP in the way I explained in my previous message (I’m using GCE here).

Thanks for taking the time to respond. My machine gave an error or UDP listen needs -p arg. It seemed to work with nc -lup 10000 but I opened another Putty window and using the echo command gave a no port[s] to connect to error. I also tried connecting via the browser with :10000 added to the URL but that didn’t work either. This does look like a better test and I suspect I’m doing something wrong, but I don’t know how to get the test to work

Hi. Thanks for replying. I’m afraid that this made no difference :frowning:

oh bummer, I have messed again with this cursed forum software: I have forgotten to type the magical ``` and Discourse has eaten part of the command I typed in.
You should have read

echo "123" | nc -u <your public address> 10000

I strongly recommend that you follow the Installation guide below without skipping any steps and you should have your Jitsi Meet Server up and running in under 20 minutes

I’ve intalled at least five times always on clean installs of various versions of Debian or Ubuntu (I don’t count the installs on Centos or where I’ve had Plesk installed), but there are (to my surprise) a couple of extra bits that look promising, so many thanks for the tip. I’ll give it a go tomorrow and report back. :slight_smile:

Hope everything goes well. In case you have any difficulties, the community is there to help you. Don’t give up. Cheers

Hi. Many thanks for taking the time to reply.

In the directory /etc/nginx/sites-available/ is the .conf file for the subdomain I’m using for jitsi. In the file there are two servers defined both with the name of the subdomain. The first listens on port 80, the second which seems to be to do with SSL/TLS listens on port 4444 listen 4444 ssl http2; I replaced this line with listen 443 ssl http2;, after which the browser couldn’t connect. According to ufw 443/tcp is open.
I have installed both with and without setting the hostname. Could you kindly tell me which file contains the line useStunTurn: true, I can’t find it.

On the issue of setting the internal and external IP addresses, my ISP assures me that the server (a VPS) is not behaind a NAT. I am accessing it from behind a LAN, but I would not have thought that this would effect the way the server behaves. As the server has only one (fixed) IP address, I didn’t think it appropriate to add the lines you suggested. If you think these changes should apply even though there’s no NAT involved, then of course I’m happy to give it a go.

I hope you won’t mind continuing to respond.

It should be here:


I don’t have the setting useStunTurn: true (which is why I said that your config differs from the “default”).

This could be because I didn’t install the jitsi-meet-turnserver package (it’s in the Recommends field for jitsi-meet), or maybe there is another reason. Sorry, I don’t really know.

Where does this 4444 come from? My nginx file is similar to this one:


and such template does not have 4444 anywhere. Are you using the latest “stable” packages in the jitsi repositories?

Edit: Maybe when you install the coturn package the automatically created configuration is slightly different. Therefore please take everything I say here with a grain of salt. Apparently, I have never needed coturn for jitsi to work for me.

This comes from the turn config package … The port is chamged in debian postinst

Great test! Worked like a dream. Many thanks for the suggestion. I’m sure I’ll be using this a lot. This does show that the port is open though, so that’s not the problem.

right, good thing to be sure of that.
Now from your log it seems clear that the problem comes from the videobridge and since it’s not the the #1 usual problem - the port 10000 being not accessible - it must be something else.
How about sharing


and maybe a bit of the /var/log/jitsi/jvb.log (since it’s often huge, only the part after the date you started your last failed conference test)

Didn’t see this mentioned… apologies if this is a repeat.


The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties :


And comment the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES .

Hi all,

I am facing same issue, The first user can log on, but when the second user logs on , About 10 seconds later the whole session closes down with ‘unfortunately something went wrong. and again reload page. Please help.

Did you look at my post about private and public IP addresses?

Thanks for reply,
I have added but does not work.