Jitsi + Jigasi, one way audio

Hello,

I discovered Jitsi and was pretty impressed, so I am testing it and would like to use my asterisk server with Jitsi.

I read the manual install guide, and proceeded with the install, everything went smoothly, no errors or issues.

Jitsi meet is working as expected, from 1 to N people inside a room.

Now, things get a little bit harder since I was not able to have 1 attendee using webrtc with 1 attendee on the phone through my asterisk server.

The Jigasi installation was fine, but since Jitsi + Jigasi are on a different VM than my asterisk box, i had to edit the file /etc/jitsi/jigasi/sip-communicator.properties and put my IPBX IP address.

After restarting Jigasi, it registers to my ipbx without issue.

Now, for the issues:

  • I can’t see the little “+” icon on jitsi meet.
  • The IPBX is able to join the meeting, it is showing up as “connected”, but I have only audio from Asterisk to the meeting (the PC can hear asterisk), but Asterisk is not getting audio from the meeting (Phone cannot hear what’s inside the meeting).

I attached the configuration file of Jigasi, and the logs (they start only when I dial the meeting with my phone, the PC was already connected to the meeting).

=> Logs are here, sorry can’t upload

https://we.tl/t-dNk8vnn5lJ

Any clues on what’s going on?

I tried searching for help on this very community board, and the Jigasi git, found some related issues, tried to solve it by myself, but still no luck :slightly_frowning_face:

Upon reviewing the logs the only thing that was catching my eye was those lines inside the Jigasi log:

2020-05-29 16:52:35.160 INFO: [118] org.jitsi.jigasi.JvbConference.callStateChanged().1182 [ctx=15907711526001571954100] JVB conference call IN_PROGRESS.
2020-05-29 16:52:35.192 INFO: [2670] service.protocol.media.TransportManager.sendHolePunchPacket().552 Send NAT hole punch packets
2020-05-29 16:52:35.205 SEVERE: [2736] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2020-05-29 16:52:35.205 SEVERE: [2736] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@6be63a79
2020-05-29 16:52:35.207 SEVERE: [2733] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@6be63a79

But I really have no clue if this is really that, or the result of another issue.

Any help would be appreciated :slight_smile:

Regards

Hello,

I’m still stuck with this issue, ideas?