Jitsi + Jibri on AWS

I am using AWS ubuntu 18.04 and have installed jitsi following this

I have 2 further requirements:

  1. Record call logs - call timer starts when actually atleast 2 participants are in the call, and is termed disconnected when less then 2 participants are in the call.
  2. Record video calls - i tried installing jibri but it fails at “modprobe snd-aloop” also seems aws doesnt has any sound card available

any help will be really appreciated

You’d have to build this yourself, Jitsi doesn’t have this funcctionality.

snd-aloop is a virtual card, the lack of hardware doesn’t matter. Try installing the non aws version of the kernel, it should contain this module.

Got to know about Colibri can it be of any use for first scenario?

Not really. You’d need to do something similar to our current conference timer I think, but then somehow force a termination. See: https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_conference_duration_component.lua

@saghul what about jicofo.log it seems to have everything… but not sure who and how generates it… i tried to put log monitor on conference id(to me the the url after slash(/)) and found it useful? can it be enhanced?

Jiccofo is the conference focus, the entity which actually gets the meeting started. Modifying it, however, is a larger enddeavor.

People have achieved what you seek by using their own backend and then just programatically hanging up, for example (on the client side).

While spinning up docker with jibri i am getting following error:

ERROR: for dockerjitsimeet_jibri_1 Cannot start service jibri: linux runtime spec devices: error gathering device information while adding custom device "/dev/snd-aloop":Creating dockerjitsimeet_jvb_1 ... done

ERROR: for jibri Cannot start service jibri: linux runtime spec devices: error gathering device information while adding custom device "/dev/snd-aloop": no such file or directory

NOTE: I changed my kernel to general from aws Linux ip 4.15.0-91-generic #92-Ubuntu SMP Fri Feb 28 11:09:48 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux and have executed the mentioned commands too

Did you follow the instructions about creating the ALSA loopback device?

yes

previously it was not giving anything here… once i changed to generic it moved ahead…

I’ve never seen this error myself, not sure how you’re getting into that problem…

Can you please tag someone who can help…

Do you mind sharing how did you managed to change to generic?
I can’t seem to be able to do it :smile:

Update: Seems that only was needed to install a higher version of the kernel.

you can follow this link

@saghul can it be because i am using ubuntu 18.04?

I would say that docker container isn’t loading the module.

Also I tried several approaches to loading custom kernel on AWS, none worked, among those the link you sent me
Only by installing a linux-image-generic-hwe kernel (which is a higher version of default kernel) I was able to load the snd-aloop.

Maybe that’s the underlying issue you’re facing.

I am following docker jitsi for setup, and snd loop now seems to work after installing linux-image-generic-hwe kernel but jibri is still not working…

have kept the default .env is something extra to be done so as to start automatic recording.