Jitsi is Auto-Muting Screenshare

I am using lib-jitsi-meet and I am having an issue where regular video works, but when I try to Screenshare, the video is being muted for all participants. I looked at my MediaStream object and its being muted:

I have the same issue as described here: Screen Sharing Issue · Issue #1821 · jitsi/lib-jitsi-meet · GitHub . I’ve tried to do things like unmute in Javascript

$(#${id})[0].unmute();

or

track.enabled = true;
track.muted = false;

and umute in the html

<video autoplay="1" id="someid" muted="false" playsinline="" webkit-playsinline=""></video>

It still does not unmute. Any ideas of why Jitsi is muting the desktop sharing track and how to unmute?