Jitsi installing

Hello I am trying to install JITSI On Centos 7
after installing it I got this error on I am trying to join the meeting
you have been disconnected you may want to check your connection

this is the error log:
IntensiveSummersCrackFinely:34 (TIME) index.html loaded: 296.6500000329688
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:23:51.143Z [modules/browser/BrowserCapabilities.js] : This appears to be chrome, ver: 87.0.4280.141
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.264Z [modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for undefined
o @ app.bundle.min.js?v=4466:sourcemap:110
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.270Z [features/base/config] Extending config with: {“startWithAudioMuted”:true,“startWithVideoMuted”:true}
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.273Z [modules/RTC/RTCUtils.js] <Y.init>: Disable AP: false
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.274Z [modules/RTC/ScreenObtainer.js] <Object._createObtainStreamMethod>: Screen sharing not supported on chrome
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.274Z [modules/RTC/ScreenObtainer.js] <Object.init>: Desktop sharing disabled
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.275Z [modules/statistics/AnalyticsAdapter.js] <Object.dispose>: Disposing of analytics adapter.
o @ lib-jitsi-meet.min.js?v=4466:sourcemap:10
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.275Z [features/analytics] Initialized 0 analytics handlers
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.276Z [features/base/media] Start muted: audio, video
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.277Z [features/base/media] Start audio only set to false
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.316Z [index.web] <HTMLDocument.>: (TIME) document ready: 22902.40999998059
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.357Z [modules/RTC/RTCUtils.js] Audio output device set to default
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.366Z [modules/xmpp/xmpp.js] <A._initStrophePlugins>: P2P STUN servers: Array(1)
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.371Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe connecting: 22957.459999946877
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.372Z [modules/RTC/RTCUtils.js] <Y.newObtainAudioAndVideoPermissions>: Using the new gUM flow
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:05.372Z [modules/RTC/RTCUtils.js] <Y.>: Got media constraints: Object
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:05.373Z [features/base/tracks] Failed to create local tracks Array(1) TypeError: Cannot read property ‘getUserMedia’ of undefined
at lib-jitsi-meet.min.js?v=4466:sourcemap:1
at new Promise ()
at Y._newGetUserMediaWithConstraints (lib-jitsi-meet.min.js?v=4466:sourcemap:1)
at Y. (lib-jitsi-meet.min.js?v=4466:sourcemap:1)
o @ app.bundle.min.js?v=4466:sourcemap:110
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:07.260Z [features/base/redux] <Object.persistState>: redux state persisted. b25501a9bd7f23b7c900bd20582163e5 -> 4a1b629c873bc10be3e189bb3b7f8790
lib-jitsi-meet.min.js?v=4466:sourcemap:1 WebSocket connection to ‘wss://localhost:8443/xmpp-websocket?room=intensivesummerscrackfinely’ failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED
_connect @ lib-jitsi-meet.min.js?v=4466:sourcemap:1
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:07.728Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: Websocket error [object Event]
at Object.r.Strophe.log (lib-jitsi-meet.min.js?v=4466:sourcemap:17)
at Object.error (lib-jitsi-meet.min.js?v=4466:sourcemap:1)
at N.Websocket._onError (lib-jitsi-meet.min.js?v=4466:sourcemap:1)
o @ lib-jitsi-meet.min.js?v=4466:sourcemap:10
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:07.728Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Websocket error [object Event]
o @ lib-jitsi-meet.min.js?v=4466:sourcemap:10
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:07.728Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe connfail[The WebSocket connection could not be established or was disconnected.]: 25314.529999974184
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:07.728Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe disconnected: 25314.814999932423
lib-jitsi-meet.min.js?v=4466:sourcemap:10 2021-01-21T07:24:07.729Z [modules/statistics/statistics.js] <Function.b.sendAnalyticsAndLog>: {“type”:“operational”,“action”:“connection.failed”,“attributes”:{“error_type”:“connection.otherError”,“error_message”:“The WebSocket connection could not be established or was disconnected.”,“suspend_time”:0,“time_since_last_success”:null}}
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:07.729Z [connection.js] <a.d>: CONNECTION FAILED: connection.otherError
o @ app.bundle.min.js?v=4466:sourcemap:110
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:07.732Z [features/overlay] <Object.componentDidMount>: The conference will be reloaded after 23 seconds.
app.bundle.min.js?v=4466:sourcemap:110 2021-01-21T07:24:07.733Z [features/base/connection] connection.otherError
o @ app.bundle.min.js?v=4466:sourcemap:110

I didnt change any thing in the .env file I just generated passwords using * ./gen-passwords.sh
should I change any thing else in the .env??

You have to check in the config.js file for the following things

hosts: {
// XMPP domain.
//domain: ‘jitsi-meet.example.com’,
domain: ‘xxxx.xxxxxxxxxx.com’,

    // When using authentication, domain for guest users.
    // anonymousdomain: 'guest.example.com',

    // Domain for authenticated users. Defaults to <domain>.
     //authdomain: 'jitsi-meet.example.com',

    // Focus component domain. Defaults to focus.<domain>.
     focus: 'focus.xxx.xxxxxxx.com',

    // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
    muc: 'conference.xxx.xxxxxxxxx.com'
    
},
useNicks: false,
// BOSH URL. FIXME: use XEP-0156 to discover it.
//bosh: '//xxxx.xxxxx.com/http-bind',

Replace your hosted domain in xxxx.xxxxx.com

Refer the following link

Thank you so much for your reply
But Where can I find the config.js file

Thank you so much for your reply
But Where can I find the config.js file
I installed it from this link :slight_smile: GitHub - jitsi/docker-jitsi-meet: Jitsi Meet on Docker

For developer instalation got your installed directory /jitsi-meet/config.js

If you installed as a service check /usr/share/jitsi/yourdomain.config.js

Best of luck

I created RPM packages for CentOS 7. Maybe they are useful for you:
http://www.tuxad.com/blog/archives/2021/01/24/jitsi_meet_rpm_packages_for_rhelcentosoel_7/index.html

Thank You so much
I tried to install the RPM packages but unfortunately, I got this error

Problem binding to port 80: Could not bind to IPv4 or IPv6.

I tried to stop nginx and apache but I got the error again

The only step where this can happen is when calling jitsi-meet-install.sh which itself calls certbot which tries to get the Let’s Encrypt certificate and opens the port 80 (temporarily).
Is this the case? Did it happen on calling jitsi-meet-install.sh?

If yes then there are a couple of reasons (3 coming immediately to my mind):

  • there’s still something listening on port 80 (try “ss -lnetp” to check)
  • you are missing the bind capability / you are not running script as root
  • SELinux issue? If SELinux is enabled please disable it. Currently my RPM packages don’t support SELinux contexts. It’s my first try of creating those! Anyway SELinux support is on my TODO list. But currently you’ll have to disable it.

BTW - thanks for testing and giving feedback!