Jitsi installation in WSL ubuntu

Hi there,
I am want to install jitsi meet into my WSL ubuntu. Does anybody has any idea how should I do this? From past 2 days I am trying to search and achieve this.

Thanks in advance.

Sayali1, Apologies but I have no experience with WSL, I have used Hyper-V for running a VM.

I am not sure how complete a Linux environment WSL is, which is likely to be the issue.

I am curious, how will you get an Internet domain name pointing to your WSL Ubuntu jitsi instance’s IP address? This is will be necessary as far as I know.

Have you tried following the instructions on the following pages:

This page was helpful for me:

And the above page reverenced:

Please let me know if you work it out, and have any success.

@sayali1 try docker-jitsi-meet.

FWIW I’ve installed jitsi on VPS hosts, LAN nodes and locally on WSL2. There’s no special trick to LAN or WSL installation, just following the standard procedure worked as expected.

One factor is important—whether the LAN or WSL server is accessible from the internet. In my case they were not and I had to use self-signed certificates vs. Let’s Encrypt. Be aware that using self-signed certs limits access to desktop/laptop computers because mobile devices typically refuse to connect to insecure servers.

There may be ways to work around the certificate issue, so far I’ve only superficially looked into it and don’t have a solution.

Great to hear your installation worked !

In my first installation I used self signed certificates (wild card) which I made when I had first set up my web server a few years ago. After my first experiences, I used LetsEncrypt.

I don’t use mobile devices, so while I know how the install the self signed certificate into Windows, Linux, Edge, Chromium, Firefox so that they don’t complain, I have not as yet tried this on Android or iPhone like devices.

  1. Do you have a registered Internet domain/subdomain you can use, and purchase a registered ssl certificate? It would be great if you could.
    or
  2. Are you able to get Let’s Encrypt certificates working? What stops you? (e.g. not having a registered Internet domain/subdomain?)

If you succeed in installing yourself signed certificates to the required devices, please let me know. I guess it could give you another level of security, as long as you don’t need people out side your control to join in meetings. Most likely too much hassle though.

Thanks for the article re: installing self-signed certs on Android. That sounds like it might be a useful option for testing on local jitsi installations.

Several months ago I’d set up test jitsi servers on my personal LAN. Back when my business was running full steam I maintained a public-facing host machine on a static IP. Nodes on the business LAN could have been accessed from the internet but my personal LAN doesn’t offer that feature.

Of course to get Let’s Encrypt certs servers must be accessible from the internet. For that reason I also have a VPS for running jitsi and website servers. The VPS jitsi server certainly has a Let’s Encrypt certificate. OTOH my local LAN servers don’t need to have “real” certs since they’re used only for testing.

I’ll look into self-signed certs for Android out of curiosity if nothing else. And who knows it just might come in handy in the future…:grinning: