Jitsi Installation Error

I am trying to install Jitsi onto a Raspberry Pi which has Debian as our operating system. I have Java version 11.0.4 installed and Nginx as the web server. When I go to the main Jitsi download page with the instructions, https://jitsi.org/downloads/ubuntu-debian-installations-instructions/, I don’t get an error until the last instruction which is sudo apt-get -y install jitsi-meet. The error message that I receive is
“The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-videobridge (=1126-1) but is not installable
Depends: jicofo (=1.0-508-1) but it is not installable”

If anyone has any suggestions please let me know.

We support now only amd64 packages.