Jitsi install/config on openshift

hi,
I’m new here and i have a question/problem. I want to try to push jitsi on openshift 3.11.
can any one provide mi some info is this is possible or not ? I think about download a source fro git hub and build my own docker file and after that push to to Openshift but i dont know how to do this.

@sapkra is working on a pull request so that Jitsi runs as an unprivileged container! You can find the install guide here: https://github.com/sapkra/docker-jitsi-meet/blob/openshift-template/examples/openshift/README.md

The link that you provided does not contain working code, I did everything according to the documentation, but it did not work for me from the very beginning. Errors below

git clone https://github.com/sapkra/docker-jitsi-meet.git 
cd docker-jitsi-meet/ && git checkout opeshift-template && git pull origin openshift-template 
cd examples/openshift &&  make build

docker-jitsi-meet/examples/openshift/jibri/deployment.yaml]: yaml: [while scanning for the next token] found character that cannot start any token at line 27, column 20

value: :0
I tried to fix the error
value: 0
After that build was done correctly, but I get new errors with deploy when run command:

oc process -f jitsi.yaml --ignore-unknown-parameters --param-file …/…/.env | oc apply -f - openshift-template ✱
panic: runtime error: index out of range [0] with length 0

goroutine 1 [running]:
[github.com/openshift/oc/pkg/cli/process.(*ProcessOptions](http://github.com/openshift/oc/pkg/cli/process.(*ProcessOptions)).RunProcess(0xc000cb9560, 0x0, 0x3a20868)
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/pkg/cli/process/process.go:374 +0x15ee
[github.com/openshift/oc/pkg/cli/process.NewCmdProcess.func1](http://github.com/openshift/oc/pkg/cli/process.NewCmdProcess.func1)(0xc001074840, 0xc0002f3360, 0x0, 0x5)
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/pkg/cli/process/process.go:132 +0xdb
[github.com/spf13/cobra.(*Command](http://github.com/spf13/cobra.(*Command)).execute(0xc001074840, 0xc0002f3310, 0x5, 0x5, 0xc001074840, 0xc0002f3310)
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/vendor/github.com/spf13/cobra/command.go:844 +0x2c2
[github.com/spf13/cobra.(*Command](http://github.com/spf13/cobra.(*Command)).ExecuteC(0xc0000f4000, 0x2, 0xc0000f4000, 0x2)
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/vendor/github.com/spf13/cobra/command.go:945 +0x336
[github.com/spf13/cobra.(*Command](http://github.com/spf13/cobra.(*Command)).Execute(…)
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/vendor/github.com/spf13/cobra/command.go:885
main.main()
/private/tmp/openshift-cli-20201028-97955-1wz7sug/src/github.com/openshift/oc/cmd/oc/oc.go:110 +0x885
error: no objects passed to apply

Can you fix the problems and give a working code, or can you advise me on what I’m doing wrong?

I tried it on an openshift cluster but it does not seem to work…

It requires the use of HostPath and this is not recommended by Redhat… Maybe it worked if the container was privileged but that would also be risky (and it is not allowed by default).