Jitsi in Windows - record OK / Jitsi in Iframe - record not started

Jitsi - in docker (this version: GitHub - jitsi/docker-jitsi-meet: Jitsi Meet on Docker ) on Host1
Jibri - in docker (same URL) on Host2, 5 instances.

All works fine. Almost.

Open new window, create new meet, meet started, I start recording as moderator - in meet get sound “Recording started”, in jibri creates new directory for record and file in this directory. All fine.

I have site, where I create new meet (on same Host1) via External API. meet started and works fine.
If I start record as moderator (or via API - no difference) - I have notify “Prepare recording”, no sound “Recording started” and now red notify on top (Recording). Jibri creates new directory, but no files in this directory and no records in logs.

API options:

      const options = {
        roomName: confName.value, // defined
        width: '100%',
        height: '100%',
        parentNode: document.querySelector('#meetJitsi'),
        userInfo: {
          email: user.value.personal.email, // defined
          displayName: userNick.value // defined
        },
        password: meetPass.value,
        configOverwrite: {
          disableDeepLinking: true,
          prejoinPageEnabled: false,
          hideConferenceSubject: true,
          localRecording: {
            enabled: true,
            format: 'flac'
          }
        },
        interfaceConfigOverwrite: {
          HIDE_INVITE_MORE_HEADER: true,
          SHOW_CHROME_EXTENSION_BANNER: false,
          SETTINGS_SECTIONS: ['devices', 'moderator'],
          MOBILE_APP_PROMO: false,
          LANG_DETECTION: true
        },

API start:

const apiMeet = new API('my.domain.com', options)

What wrong in API-init?

Your local recording config seems to be the old one we just replaced with actual local recordings. What type of recording are you trying to perform?

I try record to jibri server and stream via jibri server.

Stream not start.
Recording on jibri creates new folder in recordings folder, but folder stay empty. :frowning:

I think i found problem :slight_smile:

On API starts - script set password for room.
If I remove password via security settings - everything work fine (record and stream).
If I set password again - recording not start again.

Recording for rooms with password unavailable?

You need to enable this module:

And add configuration muc_password_whitelist with the jibri jid in it.

How do this in docker-based install?
And how add more than one jibri hosts?