Jitsi Hangs when entering an invalid LDAP user

Hi there,

we are working with a locally installed Jitsi Meet instance for quite some time now.
We now found out that prosody hangs when trying to authenticate with a non-existent Active Directory (LDAP) user name.
If the user name is entered correctly, but the password has a typo, a correct error message is shown.
But when the user name was misspelled (or the user is not in the filtered LDAP query), prosody does not respond anymore.
I guess that there’s some timeout value which is either not set at all or to a too high value - but I am not sure.
Does anyone else have this issue?
Is there a solution?

Here’s the contents of my ldap.cfg.lua, maybe I’m missing some important setting?

mod_lib_ldap - Prosody Community Modules
mod_auth_ldap2 - Prosody Community Modules
authentication = ‘ldap2’

ldap = {
hostname = ‘ldap01.example.com’,
bind_dn = ‘CN=ldapuser,OU=sample,OU=othersample,DC=test,DC=example,DC=com’,
bind_password = ‘verystrongpas$word’,
use_tls = false,
user = {
usernamefield = ‘sAMAccountname’,
– usernamefield = ‘uid’,
basedn = ‘DC=test,DC=example,DC=com’,
filter = ‘(&(objectClass=person)(objectClass=user)(!(objectClass=computer))(sn=)(givenname=)(!(userAccountControl:1.2.840.113556.1.4.804:=2))(memberOf=CN=Jitsi-Users,OU=Groups,DC=test,DC=example,DC=com))’,
– admin?
namefield = ‘cn’,
},
}

As already mentioned: A correct username/password pair works like a charm, a wrong password produces an error message, which is perfectly fine.
But a wrong unser name forces my system to hang…

Any ideas on this?

Best regards,
Tom