Jitsi Google Calendar Plugin, change default domain to internal domain

Hello, is it possible to change the settings of the Jitsi integration plugin for Google Calendar so that it can search for a server Local Jitsi rather than the default (meet.jit.si)?

Internet will soon be blocked by our proxy for all employees and an internal chat solution with Jitsi is already deployed within the company.

We want to allow Google Calendar only to allow them to track meeting organization and allow them to use Jitsi meeting integration plugin through Google Calendar.

Main problem, they can’t create meeting directly from Google Calendar for internal server because only meet.jit.si is offered.

You can create your own addon and publish it to the store with addons.

I already tried with the chrome extension project but this lack many features requested by users in Issue page of the project. It is also not updated since more than 2 years. I’m not a developper and will not try to modify the javascript file.

This Jitsi Calendar add-on developped by the Jitsi Team is directly integrated in Google Calendar and you can choose directly a between Google Meet or Jitsi Meet.

The Google Calendar add on was developped to replace the Chrome Extension right ?

It would be awesome to just add one option that is missing in my opinion:

  • choosing a custom meeting server

Below an example, in red the add-on where we can change between Google Meet or Jitsi Meet.
And in blue, the chrome extension that add only the meeting link in the description

I found out with specific key words now it was already search by other users 2 years ago, but still no update on this…

I will try create my own addon for Google Calendar, I hope it is not too complicated :slight_smile: as it will be my first addon.

I managed to create our own Jitsi addon for Google Calendar which allows to choose our internal Jitsi server.

It works perfectly !

Google Calendar AddOn Project

I did some change:

In the appscript.json manifest, I needed to add urlFetchWhitelist:

"urlFetchWhitelist": ["https://api.jitsi.net/"]

Otherwise, google was not letting me Deploy it.

1 Like