Jitsi failing when second user joins (tried all the fix mentioned in other posts)

I know others have faced similar issue in the past. I have gone through those posts and tried to follow the same to fix the issue. However nothing seems to work.

Here are the logs
LINK

I have tried on a fresh ubuntu-bionic-18.04-amd64-server-20200611 in AWS EC2
When it did not work the first time (failed when second user joined), I tried to uninstall and then do a fresh install (which also did not work).

Everytime, I get the error LINK

jitsi-meet 2.0.4627-1
jitsi-meet-prosody 1.0.4127-1
jitsi-meet-turnserver 1.0.4127-1
jitsi-meet-web 1.0.4127-1
jitsi-meet-web-config 1.0.4127-1
jitsi-videobridge2 2.1-202-g5f9377b9-1

Looking for urgent help. Please respond.

yes and did you the basic connectivity test for port 10000 ?

(server)
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u

(workstation)
echo "123" | nc -u (your public address) 10000

if this does not work, check your network configuration. Some cheesy hosters are firewalling the servers they are providing and you have to setup them for external access.

Thanks. That was helpful. Even though I had “All Traffic” earlier, it was failing. Now I have opened specific ports on the security group. And it works :slightly_smiling_face: