Jitsi error in jvb.log

@akalana i want to setup octo like you; but i don’t understand what Local IP of my machine to bind to.
I have a setup of three machines
Server A (jitsi frontend, meet, jicofo and prosody)
Server B (only videobridge2)
Server C (only videobridge2)
in Server A i have configured jicofo, sip-comunicator.properties and meet files following instructions of the wiki

in Server B only sip-communicator.properties
in Server C only sip-communicator.properties
what Local IP to use in three machines?
and Public IP?
could you please share your settings?

@malviven7
The two local IPs and the two public IPs means your JVB’S local and public IPS.
That are the things that you should apply for the bind address and for the public address. Did you check whether the JVB is working properly before you do the octo setup?

Thanks @akalana for your reply; before setup of octo all works without issues. I made some step further configuring octo, (i attach my three machines config) but when i enter my webpage i receive a black screen when before i receive the welcome page where i can create rooms.

#jicofo OCTO CONFIG Malv 08-05-2020
#org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=RegionBasedBridgeSelectionStrategy
org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=SplitBridgeSelectionStrategy

# videobridge OCTO CONFIG Davide 08-05-2020
org.jitsi.videobridge.octo.BIND_ADDRESS=192.10.XXX.XXX
# the address to bind to locally
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=21X.YYY.YYY.YYY
# the address to advertise (in case BIND_ADDRESS is not accessible)
org.jitsi.videobridge.octo.BIND_PORT=4096
# the port to bind to
org.jitsi.videobridge.REGION=region1
# the region that the jitsi-videobridge instance is in

...
       // meet OCTO CONFIG Malv08-05-2020
        octo: {
            probability: 1
        }
....

In others machines change only region (region 2, region 3)

But when i enter my webpage i receive only a black screen.

@malviven7 Please let me know did you enable the firewall. Please show me your firewall rules.

Here you are @akalana
root@meet:~# ufw status
Status: active

To                         Action      From
--                         ------      ----
22/tcp                     ALLOW       Anywhere
80/tcp                     ALLOW       Anywhere
443/tcp                    ALLOW       Anywhere
5222/tcp                   ALLOW       Anywhere
5347/tcp                   ALLOW       Anywhere
10000/udp                  ALLOW       Anywhere
4096/tcp                   ALLOW       Anywhere
4096/udp                   ALLOW       Anywhere
22/tcp (v6)                ALLOW       Anywhere (v6)
80/tcp (v6)                ALLOW       Anywhere (v6)
443/tcp (v6)               ALLOW       Anywhere (v6)
5222/tcp (v6)              ALLOW       Anywhere (v6)
5347/tcp (v6)              ALLOW       Anywhere (v6)
10000/udp (v6)             ALLOW       Anywhere (v6)
4096/tcp (v6)              ALLOW       Anywhere (v6)
4096/udp (v6)              ALLOW       Anywhere (v6)

Also @akalana in my chrome console i can see this image
image

@malviven7
Can you please show me your config file.

Which configs? jicofo,meet or sip?

@malviven7
No Jitsi meet config.

@akalana if you mean meet here you aremeet.cgilfe.it-config.js.txt (18.3 KB) and thanks for your help!

@malviven7
Please replace this into the current one
meet.cgilfe.it-config.js.txt (18.3 KB)

@akalana G R E A T!!! you save my life… it’s work now!!! i see in your returned file that i have lost a char ah ah ah in my config (,)

1 Like

@malviven7 Sound good