Jitsi Electron npm install error

Hi all,

Need your support.
When i run the npm install on the jitsi desktop electron, get the following error.

15969 verbose stack Error: spawn git ENOENT
15969 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:267:19)
15969 verbose stack at onErrorNT (internal/child_process.js:469:16)
15969 verbose stack at processTicksAndRejections (internal/process/task_queues.js:84:21)
15970 verbose cwd D:\Jitsi\jitsi-meet-electron-master
15971 verbose Windows_NT 10.0.18363
15972 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install”
15973 verbose node v12.18.1
15974 verbose npm v6.14.5
15975 error code ENOENT
15976 error syscall spawn git
15977 error path git
15978 error errno ENOENT
15979 error enoent Error while executing:
15979 error enoent undefined ls-remote -h -t ssh://git@github.com/jitsi/js-utils.git
15979 error enoent
15979 error enoent
15979 error enoent spawn git ENOENT
15980 error enoent This is related to npm not being able to find a file.
15981 verbose exit [ 1, true ]

on npm run dist
0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘run’,
1 verbose cli ‘dist’
1 verbose cli ]
2 info using npm@6.14.5
3 info using node@v12.18.1
4 verbose run-script [ ‘predist’, ‘dist’, ‘postdist’ ]
5 info lifecycle jitsi-meet-electron@2.3.0~predist: jitsi-meet-electron@2.3.0
6 info lifecycle jitsi-meet-electron@2.3.0~dist: jitsi-meet-electron@2.3.0
7 verbose lifecycle jitsi-meet-electron@2.3.0~dist: unsafe-perm in lifecycle true
8 verbose lifecycle jitsi-meet-electron@2.3.0~dist: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;D:\Jitsi\jitsi-meet-electron-master\node_modules.bin;C:\Python38\Scripts;C:\Python38;C:\Program Files (x86)\Common Files\Intel\Shared Libraries\redist\intel64\compiler;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files\PuTTY;C:\Program Files\nodejs;C:\ProgramData\chocolatey\bin;C:\Users\Nirav\AppData\Local\Microsoft\WindowsApps;C:\Users\Nirav\AppData\Roaming\npm;C:\Users\Nirav\AppData\Roaming\npm
9 verbose lifecycle jitsi-meet-electron@2.3.0~dist: CWD: D:\Jitsi\jitsi-meet-electron-master
10 silly lifecycle jitsi-meet-electron@2.3.0~dist: Args: [ ‘/d /s /c’, ‘npm run build && electron-builder’ ]
11 silly lifecycle jitsi-meet-electron@2.3.0~dist: Returned: code: 1 signal: null
12 info lifecycle jitsi-meet-electron@2.3.0~dist: Failed to exec dist script
13 verbose stack Error: jitsi-meet-electron@2.3.0 dist: npm run build && electron-builder
13 verbose stack Exit status 1
13 verbose stack at EventEmitter. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
13 verbose stack at EventEmitter.emit (events.js:315:20)
13 verbose stack at ChildProcess. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:315:20)
13 verbose stack at maybeClose (internal/child_process.js:1021:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
14 verbose pkgid jitsi-meet-electron@2.3.0
15 verbose cwd D:\Jitsi\jitsi-meet-electron-master
16 verbose Windows_NT 10.0.18363
17 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “run” “dist”
18 verbose node v12.18.1
19 verbose npm v6.14.5
20 error code ELIFECYCLE
21 error errno 1
22 error jitsi-meet-electron@2.3.0 dist: npm run build && electron-builder
22 error Exit status 1
23 error Failed at the jitsi-meet-electron@2.3.0 dist script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

Would appreciate any help extended to compile the Desktop app.

if you are typing ‘git’ and enter in the command line, does it work or do you get command not found ?

@gpatel-fr

Yes, I figured that out, I was running it outside of the gitbash, when I ran it within the bash, was able to compile, Now trying to figure how to generate Linux and Mac distributions, As npm run dist only gives Windows distributions.