JITSI Electron latest app 2.4.2 is not working

Hello,

I’m on mac Mojave 10.14.4.
node is 12.18.3 and
npm 6.14.3

When I try to do npm install, I get the below error.

Upon checking I found that there no such file exist on Github for v85 (version 85) for jitsi-meet-electron-utils-v2.0.12-electron-v85-darwin-x64.tar.gz.

The maximum version is 73. check the below image.

What is the way out to ensure that it’s built properly? Can someone help.

That’s just a warning, because there is no prebuilt image, it will be built from source.

Hi @saghul,

I’m not sure. But when I run this electron build on my end, it doesn’t fetch the open windows on the MAC. and gives this issue.

Do you think that it’s relevant?

NOTE: When I run the same on meet.jit.si, the same works fine. So, I believe that there is something that we need to fix on the server side or client side. Can you guide me in the right direction ?

Paste the full console output. Some error must have caused the source picker not to work.

Dear @saghul,

Kindly see the attached logs in pastebin. The logs are collected and the screenshot from where the logs are captured is also attached.

I’m currently running the electron app by the command : npm run start

Mojave 10.14.4.
node is 12.18.3 and
npm 6.14.3

I can’t see my voice and video going on the other side.

I’ve just pulled the code and changed the few UI elements and this is what is happening. Kindly guide me in the right direction.

These are the captured logs

Did you make any changes to it or are you just cloning it and running npm start ? I cannot reproduce it here. Do you see any difference if you join a meeting in meet.jit.si ?

Hi @saghul,

So I only changed the files which shouldn’t impact the build. These are just replacing the branding of JITSI.

here is the screenshot.

& the answer to your questions :

  1. Yes, this is just npm install and then npm start.
  2. Yes, the same utility works, if I start join any meeting with meet.jit.si.

Screenshot 2020-12-04 at 7.13.59 PM

Try deleting node_modules and package-lock.json, then try building again.

Hi @Freddie,

I’ve done it already multiple times.
I’ve given my node and npm details in the origional thread.

You’ve done what multiple times - deleted the nodue_modules directory and the package-lock.json file then tried rebuilding?

Yes, @Freddie.

I Originally thought that I might have messed with the installation, hence I

  1. Took the clean pull
  2. Did npm install
  3. Did npm start

and this(in my above posts) is what the error I get for my installed JITSI Setup when I try to use SHARE DESKTOP utility. But the same works on the meet.jit.si

Can you just do a fresh install WITHOUT any customizations (UI changes)? Or you did that and had the same error? Because if not, then you can narrow the issue down to the customizations you made.

1 Like

Hi @Freddie,

I just did the same again, after your comment. It didn’t work.

I removed the node_modules/ and package-lock.json.

This is the top most error in the console -

2020-12-04T17:22:58.825Z [features/desktop-picker] Called JitsiMeetElectron.obtainDesktopStreams but it is not defined

These are the screenshots

.

Pardon me for being pedantic, but just so we’re clear, this is what you’re saying:

  1. You simply cloned the repo and then did an install (did you try check screensharing in this debug mode)?
  2. You did NOT make ANY customizations to the UI
  3. You ran “npm start” and generated a build
  4. The generated app connects to meet.jit.si and screensharing works without problems
  5. The generated app connects to your custom jitsi install but screensharing errors

Am I correct?

Hi @Freddie,

Don’t sweat! I’m okay being precise.

Yes, is my answer to each of your question.

Here are two screenshots.

  1. Connecting Electron app On my setup : With a clean pull and zero changes in the code. Screen share, audio and video didn’t work
  2. Connecting Electron app On meet.jit.si : Screenshare worked. Audio and Video didn’t work.

I forgot to let you know that the Audio and video is also not working from the start on the electron app.

Okay, good. So this is not an Electron app issue then. We can rule that bit out.

Are you able to connect to your Jitsi using Chrome browser? Are you able to host a meeting with 3 participants all using browsers?

Yes. Chrome Browser is all good. I daily do meetings on my deployed setup for hours and hours. A/V, sharing, recording, they all works great

Then I just thought of distributing the desktop app, and then I started facing this issue.

Just to check, can you try a previous version of Electron? Try version 2.4.0, for instance.

Let me do that as well.

and paste the progress.

Hi,

I checked out 2.4.0 . did npm start but still failing to get the access to the camera, audio and screen sharing