Jitsi-electron installation error while use "npm install"

hi,
jitsi team .
I am getting some error while installing jitsi electron on ubuntu 18.04.

here is the steps i follow

  1. I cloned the jitsi electron from git hub using this link “https://github.com/jitsi/jitsi-meet-electron”.

  2. installed required modules for electron using this command “sudo npm install -g node-gyp ; sudo apt install build-essential libx11-dev libxtst-dev”.

  3. then " npm install"

but i am getting error regarding node-gyp and one permission denied message for robotjs.

please help me to build jitsi-electron successfully.

Thanks in advance.