Jitsi does not ask for authentication


#1

Hi,
I’m just starting with docker-jitsi-meet and wanted to enforce authentication both for creating and joining to rooms. I’ve followed the steps described in https://github.com/jitsi/docker-jitsi-meet and set
ENABLE_AUTH=1
ENABLE_GUESTS=0
in my .env file
Both variables are also mentioned in “environment” section of docker-compose file.
Still when I run “docker-compose up” I can create rooms freely without being prompted to log in.

Also when I tried to create user accounts by calling:
docker-compose exec prosody /bin/bash
prosodyctl --config /config/prosody.cfg.lua register user meet.jitsi password
I got an error message: Error: Account creation/modification not supported.

.env (1.6 KB)
docker-compose.yml (2.7 KB)

Do you have an idea where can be the problem?
Thanks.


#2

Comment out ENABLE_GUESTS, there is a bug which will treat 0 as true.


#3

Thank you for your quick reply, Saghul, I tried commenting out ("#ENABLE_GUESTS=0") or setting empty value (“ENABLE_GUESTS=”) but it did not help.


#4

I’ll take a look, thanks for the report!


#5

Hi Saghul,

I hope you had great Christmas holidays.

I’ve just read in the jitsi/docker readme file that “if you make any changes to your .env file, make sure you remove the configuration directory before starting your containers again.”. Do you know what does it mean to “remove the configuration directory”? Should I delete something inside one of the containers?

Thank you and kind regards.


#6

Hi,

It means you need to delete the directory with the configuration files in the host system. It’s the directory pointed at by the CONFIG option in the .enc fils. All config will be regenerated in that case.