Jitsi Docker recording failing

Hi, can someone please help with this issue. Jitsi docker is running with Jibri but the recording option keeps failing.

(Session info: chrome=90.0.4430.212)
(Driver info: chromedriver=90.0.4430.24 (4c6d850f087da467d926e8eddb76550aed655991-refs/branch-heads/4430@{#429}),platform=Linux 5.8.0-63-generic x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘e707f8584f38’, ip: ‘172.18.0.3’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘5.8.0-63-generic’, java.version: ‘1.8.0_292’
Driver info: org.openqa.selenium.chrome.ChromeDriver
Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 90.0.4430.24 (4c6d850f087da…, userDataDir: /tmp/.com.google.Chrome.yfI32A}, cssSelectorsEnabled: true, databaseEnabled: false, goog:chromeOptions: {debuggerAddress: localhost:40161}, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), rotatable: false, setWindowRect: true, strictFileInteractability: false, takesHeapSnapshot: true, takesScreenshot: true, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unexpectedAlertBehaviour: ignore, unhandledPromptBehavior: ignore, version: 90.0.4430.212, webStorageEnabled: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true}
Session ID: 4f9f8d38119eb8ca27963798e99b6a41
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)

2021-08-17 08:01:23.216 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Transitioning from state Starting up to Error: FailedToJoinCall SESSION Failed to join the call
2021-08-17 08:01:23.216 INFO: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() File recording service transitioning from state Starting up to Error: FailedToJoinCall SESSION Failed to join the call
2021-08-17 08:01:23.217 INFO: [113] org.jitsi.jibri.api.xmpp.XmppApi.log() Current service had an error Error: FailedToJoinCall SESSION Failed to join the call, sending error iq
2021-08-17 08:01:23.217 FINE: [113] org.jitsi.jibri.statsd.JibriStatsDClient.log() Incrementing statsd counter: stop:recording
2021-08-17 08:01:23.218 INFO: [113] org.jitsi.jibri.JibriManager.log() Stopping the current service
2021-08-17 08:01:23.218 INFO: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Stopping capturer
2021-08-17 08:01:23.218 INFO: [113] org.jitsi.jibri.util.JibriSubprocess.log() Stopping ffmpeg process
2021-08-17 08:01:23.218 INFO: [113] org.jitsi.jibri.util.JibriSubprocess.log() ffmpeg exited with value null
2021-08-17 08:01:23.219 INFO: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Quitting selenium
2021-08-17 08:01:44.989 FINE: [16] org.jitsi.jibri.webhooks.v1.WebhookClient.log() Updating 0 subscribers of status
2021-08-17 08:01:52.776 INFO: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Participants in this recording:
2021-08-17 08:01:53.412 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Leaving call and quitting browser
2021-08-17 08:01:53.480 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Recurring call status checks cancelled
2021-08-17 08:01:56.875 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Got 0 log entries for type browser
2021-08-17 08:02:01.335 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Got 87 log entries for type driver
2021-08-17 08:02:01.517 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Got 0 log entries for type client
2021-08-17 08:02:01.518 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Leaving web call
2021-08-17 08:02:29.300 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Quitting chrome driver
2021-08-17 08:02:32.643 INFO: [113] org.jitsi.jibri.selenium.JibriSelenium.log() Chrome driver quit
2021-08-17 08:02:32.645 INFO: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Finalizing the recording
2021-08-17 08:02:32.656 SEVERE: [113] org.jitsi.jibri.service.impl.FileRecordingJibriService.log() Failed to run finalize script
java.io.IOException: Cannot run program “/path/to/finalize”: error=2, No such file or directory
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)

Do you have valid certificate?
Or self-signed…?

it is a self signed certificate

Then you need “--ignore-certificate-errors” in your jibri.conf

This is my conf in /etc/jitsi/jibri/jibri.conf in the Jibri container

jibri {
chrome {
flags = [
“–ignore-certificate-errors”
]
}
}

But you have acceptInsecureCerts: false in your log.

yes , thats why i’m confused about the issue. I have restarted the instance multiple times after adding this flag

are there any other flags i can try to add to resolve the issue?

You can check this template

thank you! i copied the entire template and made the required changes and the recording is working now. it starts and stops but cannot find the recorded file. i have set the recordings-directory = “/tmp/” and finalize-script = “” .

Should I set something in the finalize-script path ? do you know why the recordings are not saved or where they would be saved in?

I don’t know how it works on Docker setup but it should be in the /tmp folder of the container. Did you check the container folder or the host folder?

nope

yes i checked both but did not find it.

strange… maybe you can find something related in the logs

please share the jibri logs. Also, try to map different directory(it might be a directory permission issue).

check this out. you can try this example. but before spinning it up, change the meet.example.com to your_domain or whatever default config you are using. Also, please double-check the networking part.