Jitsi docker fresh install not working

Hi,
I have a Jitsi docker install that works fine (JVB 2.1-197).
I want to install a new Jitsi docker platform (JVB 2.1-607), so I followed the handbook (Self-Hosting Guide - Docker · Jitsi Meet Handbook)
When I try to connect to a room it doesn’t work :

  • with Firefox, I got errors in the console and it keeps saying “you have been disconnected”
    Firefox can’t establish a connection to the server at wss://jitsi.test.lan/xmpp-websocket?room=test.
    and
2022-01-24T14:27:55.939Z [JitsiMeetJS.js] <getGlobalOnErrorHandler>:  UnhandledError: Strophe: Websocket error [object Event] Script: null Line: null Column: null StackTrace:  7273/Ur/rt.Strophe.log@https://jitsi.test.lan:8443/libs/lib-jitsi-meet.min.js?v=5764:2:474645
error@https://jitsi.test.lan:8443/libs/lib-jitsi-meet.min.js?v=5764:2:172977
_onError@https://jitsi.test.lan:8443/libs/lib-jitsi-meet.min.js?v=5764:2:212450
Logger.js:154:22
    r Logger.js:154
    getGlobalOnErrorHandler JitsiMeetJS.js:530
    onerror middleware.js:108
    callErrorHandler GlobalOnErrorHandler.js:61
    log strophe.util.js:88
    error strophe.umd.js:1392
    _onError strophe.umd.js:5730
  • with Chrome nothing happens when I click on Join meeting. In the console, I have the error
    An SSL certificate error occurred when fetching the script.

I see no errors in containers logs.

In the ENV file, I just set PUBLIC_URL and DOCKER_HOST_ADDRESS.
For now, I use the autogenerated certificate.

What am I missing ?
Thanks

Try to disable XMPP websockets, I don’t think that will work without a valid certificate.

Hi,
Thanks for your answer. I set up in the web container a certificate (and its CA chain) issued by a CA that I imported in Firefox. I have no certificate error when I browse the page, but the behavior I described in my first post is still the same.
Have I to import the CA also in another jitsi container ?
To test your answer, how could I disable XMPP websockets ?
Thanks

Check the env example, it contains the env var to disable WS.