[jitsi-dev] Xcap uses only the user part of URI to authenticate against to SIP server


#1

Hello all,
I am currently testing Jitsi with Kamailio SIP/SIMPLE server with XCAP
enabled with multi-domains option.
We create a user as bob@domain1.local in the server. The Jitsi client is
configured as following:

- Registrar: kamailio.local

- Authorization name: bob@domain1.local

- Proxy: kamailio.local (proxy, registrar and presence share the same server
in kamailio.local)

- XCAP Options:

       - Enable XCAP store contacts: selected

       - Server URI: http://kamailio.local:5060/xcap-root

       - Use SIP credintials: selected

I'm asking your help because:

When we tried to signin with the above SIP account to kamailio.local, the
user is signed-on in the SIP server and become online. But it fails to
authenticate on the kamailio integrated XCAP server and non XCAP operations
can be performed. From the trace in the kamailio, I see the Jitsi always use
bob (the user part of URI) as Digest Username instead of
bob@domain1.localwith realm=xcap and it failed. In the SIP parte, it
use bob@domain1.localas Digest Username in the Register request and it
successfully registered in
kamailio sip server. Then I deselected "Use SIP credentials" and put the
user as bob@domain1.local and the password in the password field. the result
was the same and I see the trace the Jitsi always send Digest Username=bob
non matter the XCAP User is bob@domain1.local.

I guess that it's a bug of the xcap client in Jitsi. Can you fix it?

Best Regards,

laura


#2

Hey Laura

When we tried to signin with the above SIP account to kamailio.local, the
user is signed-on in the SIP server and become online. But it fails to
authenticate on the kamailio integrated XCAP server and non XCAP
operations can be performed. From the trace in the kamailio, I see the
Jitsi always use bob (the user part of URI) as Digest Username instead of
bob@domain1.local with realm=xcap and it failed. In the SIP parte, it use
bob@domain1.local as Digest Username in the Register request and it
successfully registered in kamailio sip server. Then I deselected "Use SIP
credentials" and put the user as bob@domain1.local and the password in the
password field. the result was the same and I see the trace the Jitsi
always send Digest Username=bob non matter the XCAP User is
bob@domain1.local.

I guess that it's a bug of the xcap client in Jitsi. Can you fix it?

I already had a patch ready but didn't have the time yet to commit it. I'll probably come back to this sometime next week.
If you need it urgently, you might build Jitsi on your own and apply the patch from http://markmail.org/message/saaecx23ihbcn6tc. It's against an older version, so I'm not sure if it still works.

Regards,
Ingo


#3

Hey

The newest build 3467 now contains the patch. Could you check if it works for you?
Note: When "Use SIP credentials" is selected, the domain-name is still stripped. If you enter the username manually, it is used "as is" without any modifications.

Regards,
Ingo

···

-----Original Message-----
From: laura testi [mailto:lau.testi@gmail.com]
Sent: Mittwoch, 4. Mai 2011 15:44
To: dev@jitsi.java.net
Subject: [jitsi-dev] Xcap uses only the user part of URI to authenticate
against to SIP server

Hello all,

I am currently testing Jitsi with Kamailio SIP/SIMPLE server with XCAP
enabled with multi-domains option.
We create a user as bob@domain1.local in the server. The Jitsi client is
configured as following:

- Registrar: kamailio.local

- Authorization name: bob@domain1.local

- Proxy: kamailio.local (proxy, registrar and presence share the same
server in kamailio.local)

- XCAP Options:

       - Enable XCAP store contacts: selected

       - Server URI: http://kamailio.local:5060/xcap-root

       - Use SIP credintials: selected

I'm asking your help because:

When we tried to signin with the above SIP account to kamailio.local, the
user is signed-on in the SIP server and become online. But it fails to
authenticate on the kamailio integrated XCAP server and non XCAP
operations can be performed. From the trace in the kamailio, I see the
Jitsi always use bob (the user part of URI) as Digest Username instead of
bob@domain1.local with realm=xcap and it failed. In the SIP parte, it use
bob@domain1.local as Digest Username in the Register request and it
successfully registered in kamailio sip server. Then I deselected "Use SIP
credentials" and put the user as bob@domain1.local and the password in the
password field. the result was the same and I see the trace the Jitsi
always send Digest Username=bob non matter the XCAP User is
bob@domain1.local.

I guess that it's a bug of the xcap client in Jitsi. Can you fix it?

Best Regards,

laura


#4

thanks Ingo,
I'm going to download it and I'll inform you about the result of the test.

thanks and king regards,
laura

···

On Wed, May 11, 2011 at 9:50 PM, Bauersachs Ingo <ingo.bauersachs@fhnw.ch>wrote:

Hey

The newest build 3467 now contains the patch. Could you check if it works
for you?
Note: When "Use SIP credentials" is selected, the domain-name is still
stripped. If you enter the username manually, it is used "as is" without any
modifications.

Regards,
Ingo

> -----Original Message-----
> From: laura testi [mailto:lau.testi@gmail.com]
> Sent: Mittwoch, 4. Mai 2011 15:44
> To: dev@jitsi.java.net
> Subject: [jitsi-dev] Xcap uses only the user part of URI to authenticate
> against to SIP server
>
> Hello all,
>
> I am currently testing Jitsi with Kamailio SIP/SIMPLE server with XCAP
> enabled with multi-domains option.
> We create a user as bob@domain1.local in the server. The Jitsi client is
> configured as following:
>
> - Registrar: kamailio.local
>
> - Authorization name: bob@domain1.local
>
> - Proxy: kamailio.local (proxy, registrar and presence share the same
> server in kamailio.local)
>
> - XCAP Options:
>
> - Enable XCAP store contacts: selected
>
> - Server URI: http://kamailio.local:5060/xcap-root
>
> - Use SIP credintials: selected
>
>
>
> I'm asking your help because:
>
> When we tried to signin with the above SIP account to kamailio.local,
the
> user is signed-on in the SIP server and become online. But it fails to
> authenticate on the kamailio integrated XCAP server and non XCAP
> operations can be performed. From the trace in the kamailio, I see the
> Jitsi always use bob (the user part of URI) as Digest Username instead of
> bob@domain1.local with realm=xcap and it failed. In the SIP parte, it
use
> bob@domain1.local as Digest Username in the Register request and it
> successfully registered in kamailio sip server. Then I deselected "Use
SIP
> credentials" and put the user as bob@domain1.local and the password in
the
> password field. the result was the same and I see the trace the Jitsi
> always send Digest Username=bob non matter the XCAP User is
> bob@domain1.local.
>
>
>
> I guess that it's a bug of the xcap client in Jitsi. Can you fix it?
>
>
>
> Best Regards,
>
> laura


#5

Hey Ingo,

It appears that this patch attaches to the https URL the SIP URI of the
current account rather than the user specified user name.

Is this intentional?

Emil

На 11.05.11 21:50, Bauersachs Ingo написа:

···

Hey

The newest build 3467 now contains the patch. Could you check if it works for you?
Note: When "Use SIP credentials" is selected, the domain-name is still stripped. If you enter the username manually, it is used "as is" without any modifications.

Regards,
Ingo

-----Original Message-----
From: laura testi [mailto:lau.testi@gmail.com]
Sent: Mittwoch, 4. Mai 2011 15:44
To: dev@jitsi.java.net
Subject: [jitsi-dev] Xcap uses only the user part of URI to authenticate
against to SIP server

Hello all,

I am currently testing Jitsi with Kamailio SIP/SIMPLE server with XCAP
enabled with multi-domains option.
We create a user as bob@domain1.local in the server. The Jitsi client is
configured as following:

- Registrar: kamailio.local

- Authorization name: bob@domain1.local

- Proxy: kamailio.local (proxy, registrar and presence share the same
server in kamailio.local)

- XCAP Options:

       - Enable XCAP store contacts: selected

       - Server URI: http://kamailio.local:5060/xcap-root

       - Use SIP credintials: selected

I'm asking your help because:

When we tried to signin with the above SIP account to kamailio.local, the
user is signed-on in the SIP server and become online. But it fails to
authenticate on the kamailio integrated XCAP server and non XCAP
operations can be performed. From the trace in the kamailio, I see the
Jitsi always use bob (the user part of URI) as Digest Username instead of
bob@domain1.local with realm=xcap and it failed. In the SIP parte, it use
bob@domain1.local as Digest Username in the Register request and it
successfully registered in kamailio sip server. Then I deselected "Use SIP
credentials" and put the user as bob@domain1.local and the password in the
password field. the result was the same and I see the trace the Jitsi
always send Digest Username=bob non matter the XCAP User is
bob@domain1.local.

I guess that it's a bug of the xcap client in Jitsi. Can you fix it?

Best Regards,

laura

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31