[jitsi-dev] XCAP: Use username as entered when not using SIP Credentials


#1

Moin

When the XCAP service should NOT use the SIP credentials and the supplied XCAP username contained a domain name, only the local part was retained. The attached patch modifies the behavior so that the username is used as entered when not using SIP Credentials.

Or more simply:
Old:
- use SIP creds: john@example.com -> username is john
- use different login: john@example.com -> username is john

New:
- use SIP creds: john@example.com -> username is john
- use different login: john@example.com -> username is john@example.com

This change is required when kamailio is being used as the registrar, proxy and xcap-server with the Domain-Option enabled.

Regards,
Ingo

xcap_separate_requesturi_from_username2.patch (7.17 KB)


#2

Hi Ingo,

have you tried testing this changes with logging to different xcap
servers. When xcap functionality was added tests were done with both
sip2sip.info service and openxcap server.

Regards
damencho

ยทยทยท

On Sat, Feb 12, 2011 at 3:43 AM, Bauersachs Ingo <ingo.bauersachs@fhnw.ch> wrote:

Moin

When the XCAP service should NOT use the SIP credentials and the supplied XCAP username contained a domain name, only the local part was retained. The attached patch modifies the behavior so that the username is used as entered when not using SIP Credentials.

Or more simply:
Old:
- use SIP creds: john@example.com -> username is john
- use different login: john@example.com -> username is john

New:
- use SIP creds: john@example.com -> username is john
- use different login: john@example.com -> username is john@example.com

This change is required when kamailio is being used as the registrar, proxy and xcap-server with the Domain-Option enabled.

Regards,
Ingo


#3

Moin

have you tried testing this changes with logging to different xcap
servers. When xcap functionality was added tests were done with both
sip2sip.info service and openxcap server.

No, I just made these modifications to be able to logon to Kamailios built-in XCAP server according to this tutorial: http://kb.asipto.com/kamailio:presence:k31-made-simple
The difference to the tutorial is that I use the WITH_DOMAIN option of Kamailio.

Do you have some sample configurations for openxcap so I could set one up easily? I'll test with sip2sip later today.

Regards,
Ingo


#4

Moin

have you tried testing this changes with logging to different xcap
servers. When xcap functionality was added tests were done with both
sip2sip.info service and openxcap server.

I tested now with two sip2sip accounts: Presence worked OK when either "Use SIP Credentials" was checked or when using only the numbered username. Entering 123456789@sip2sip.info as username caused a 401 error, but this was to be expected when the xcap-server doesn't require the domainname.

Regards,
Ingo