[jitsi-dev] Without video when accessing from the Internet


#1

Hi all!

I am testing in a virtual machine the version of jitsi-meet that I
installed using packages built by me based on the indications that you
gave me in a previous thread.

Locally, everything seems to work without problems. But when I try to
access from Internet, after giving access permissions to the camera and
microphone, the camera turns on but I don't see the image in the browser
(the screen continues displaying the "Jitsi Meet needs to use your
microphone and camera" message).

I have already checked on the proxy server that is all redirected to the
virtual machine and I also made sure to make a DNAT to the virtual
machine of ports 10000-20000 udp. So I tend to think that it is some
configuration issue (or some other kind of issue) in the virtual machine.

What I have observed is that jicofo does not write additional entries in
the log when accessing from Internet and giving access to the
camera/microphone, which does happen when accessing locally.

Am I missing something here?

Thanks in advance.

Kind regards,
Daniel


#2

Hi, again.

I am testing in a virtual machine the version of jitsi-meet that I
installed using packages built by me based on the indications that you
gave me in a previous thread.

Locally, everything seems to work without problems. But when I try to
access from Internet, after giving access permissions to the camera and
microphone, the camera turns on but I don't see the image in the browser
(the screen continues displaying the "Jitsi Meet needs to use your
microphone and camera" message).

I have already checked on the proxy server that is all redirected to the
virtual machine and I also made sure to make a DNAT to the virtual
machine of ports 10000-20000 udp. So I tend to think that it is some
configuration issue (or some other kind of issue) in the virtual machine.

What I have observed is that jicofo does not write additional entries in
the log when accessing from Internet and giving access to the
camera/microphone, which does happen when accessing locally.

Am I missing something here?

I forgot to say that I also have configured the variables
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS and
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS
in /etc/jitsi/videobridge/sip-communicator.properties

Thanks in advance.

Kind regards,
Daniel

···

On 02/07/17 16:01, Daniel Bareiro wrote:


#3

Hi,

Did you check javascript console for errors?

Regards
damencho

···

On Sun, Jul 2, 2017 at 2:06 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, again.

On 02/07/17 16:01, Daniel Bareiro wrote:

I am testing in a virtual machine the version of jitsi-meet that I
installed using packages built by me based on the indications that you
gave me in a previous thread.

Locally, everything seems to work without problems. But when I try to
access from Internet, after giving access permissions to the camera and
microphone, the camera turns on but I don't see the image in the browser
(the screen continues displaying the "Jitsi Meet needs to use your
microphone and camera" message).

I have already checked on the proxy server that is all redirected to the
virtual machine and I also made sure to make a DNAT to the virtual
machine of ports 10000-20000 udp. So I tend to think that it is some
configuration issue (or some other kind of issue) in the virtual machine.

What I have observed is that jicofo does not write additional entries in
the log when accessing from Internet and giving access to the
camera/microphone, which does happen when accessing locally.

Am I missing something here?

I forgot to say that I also have configured the variables
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS and
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS
in /etc/jitsi/videobridge/sip-communicator.properties

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi,

Hi, Damian.

Did you check javascript console for errors?

Thanks for the suggestion. I had not checked this. I copy the observed
errors:

https://ibin.co/3SEI6iVkqJcg.jpg
https://ibin.co/3SEIUl2Y7DA2.jpg
https://ibin.co/3SEIhYhMVJZz.jpg

There seems to be a resolution issue. But I'm not sure why it happens,
since I added "testmeet.freesoftware" on my local DNS server and I can
confirm that locally I can access by that name.

Basically I changed the proxy server settings so instead of pointing to
the virtual machine I installed using the packages from the Jitsi
repositories, it points to the virtual machine where I installed using
the jitsi-meet packages I built myself. So I would say that the
configuration in the edge proxy is the same with the difference of
having just changed the name of the virtual machine of the internal network.

Any thoughts?

Thanks for your time.

Kind regards,
Daniel

···

On 04/07/17 12:20, Damian Minkov wrote:


#5

Hi,

not sure what is the problem, you need to check it locally. Seems a
dns resolution problem.
You need to make sure the http-bind address works. The output should
be like the output of https://meet.jit.si/http-bind

Regards
damencho

···

On Tue, Jul 4, 2017 at 11:52 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 04/07/17 12:20, Damian Minkov wrote:

Hi,

Hi, Damian.

Did you check javascript console for errors?

Thanks for the suggestion. I had not checked this. I copy the observed
errors:

https://ibin.co/3SEI6iVkqJcg.jpg
https://ibin.co/3SEIUl2Y7DA2.jpg
https://ibin.co/3SEIhYhMVJZz.jpg

There seems to be a resolution issue. But I'm not sure why it happens,
since I added "testmeet.freesoftware" on my local DNS server and I can
confirm that locally I can access by that name.

Basically I changed the proxy server settings so instead of pointing to
the virtual machine I installed using the packages from the Jitsi
repositories, it points to the virtual machine where I installed using
the jitsi-meet packages I built myself. So I would say that the
configuration in the edge proxy is the same with the difference of
having just changed the name of the virtual machine of the internal network.

Any thoughts?

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi,

Hi, Damian.

not sure what is the problem, you need to check it locally. Seems a
dns resolution problem.
You need to make sure the http-bind address works. The output should
be like the output of https://meet.jit.si/http-bind

It's very weird. Checking the proxy settings (Apache), I had made this
change:

···

On 04/07/17 15:45, Damian Minkov wrote:

---------------------------------------------------------------------
        <Location /http-bind>
        Order allow,deny
                Allow from all
        </Location>
        #RewriteRule ^/http-bind$
http://conference.freesoftware:5280/http-bind [P,L]
        RewriteRule ^/http-bind$
http://testmeet.freesoftware:5280/http-bind [P,L]
---------------------------------------------------------------------

But for some reason Apache seems to be giving a 404:

---------------------------------------------------------------------
167.114.118.4 - - [04/Jul/2017:16:23:56 -0300] "GET /http-bind HTTP/1.1"
404 820 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101
Firefox/52.0"
---------------------------------------------------------------------

And Firefox shows:

---------------------------------------------------------------------
404 Not Found

Whatever you were looking for is not here. It's behind you.

Unknown host: conf.opcion-libre.com.ar
---------------------------------------------------------------------

It's weird because with "conference" it works without problem. Indeed if
in the shell of OS running the Apache proxy I execute the following, it
returns an "It works! Now point your BOSH client..."

links2 http://testmeet.freesoftware:5280/http-bind

I will continue thinking, although I am running out of ideas... :frowning:

Thanks for your time.

Kind regards,
Daniel


#7

Hi again, Damian.

···

On 04/07/17 16:48, Daniel Bareiro wrote:

---------------------------------------------------------------------
404 Not Found

Whatever you were looking for is not here. It's behind you.

Unknown host: conf.opcion-libre.com.ar
---------------------------------------------------------------------

Is this a response that is returning BOSH to the Apache in the front?

Kind regards,
Daniel


#8

This is coming from prosody. Seems there is no such host configured,
as the one you are trying to access using bosh.

···

On Tue, Jul 4, 2017 at 3:10 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi again, Damian.

On 04/07/17 16:48, Daniel Bareiro wrote:

---------------------------------------------------------------------
404 Not Found

Whatever you were looking for is not here. It's behind you.

Unknown host: conf.opcion-libre.com.ar
---------------------------------------------------------------------

Is this a response that is returning BOSH to the Apache in the front?

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi, Damian.

···

On 04/07/17 17:54, Damian Minkov wrote:

--------------------------------------------------------------------
404 Not Found

Whatever you were looking for is not here. It's behind you.

Unknown host: conf.opcion-libre.com.ar
--------------------------------------------------------------------

Is this a response that is returning BOSH to the Apache in the front?

This is coming from prosody. Seems there is no such host configured,
as the one you are trying to access using bosh.

I have done a reinstallation of the packages using as the local domain
the same as the one used to access from the Internet and that way
external access has worked.

Should this always be so? Before doing this change I had configured the
packages with testmeet.freesoftware, which is the one I used in the
Apache proxy. Although it seems that did not work.

--------------------------------------------------------------------
<Location /http-bind>
Order allow,deny
Allow from all
</Location>

RewriteRule ^/http-bind$ http://testmeet.freesoftware:5280/http-bind [P,L]
--------------------------------------------------------------------

Thank you very much for your help. Much appreciated.

Kind regards,
Daniel