[jitsi-dev] Windows 7 multiple NIC issue


#1

This actually works for me as well, just adding the --ipv4 option. I had
to modify the registry with this option in order for it to take effect on
Windows startup. Is there any way this could be a configuration option
within Jitsi to avoid the registry editing?

···

-----Original Message-----
From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of
g.spellauge
Sent: Friday, May 24, 2013 10:38
To: dev@jitsi.java.net
Subject: [jitsi-dev] Re: Windows 7 multiple NIC issue

appending -4 to Jitsi.exe seems to solve this issue. we verified this on two
computers. according to
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6458027 enabeling
ipv6 on the interface should also fix this issue.

Jitsi 2.2.4603.9615
age: jitsi [OPTIONS] [uri-to-call]

-c, --config=DIR use DIR for config files
-d, --debug print debugging messages to stdout
-h, --help display this help message and exit
-m, --multiple do not ensure single instance
-6, --ipv6 prefer IPv6 addresses where possible only
-4, --ipv4 forces use of IPv4 only
-v, --version display the current version and exit

is -4 the option we are looking for i.e. is it equivalent to the jre option
-Djava.net.preferIPv4Stack=true ?

Am 14.05.2013 11:31, schrieb g.spellauge:

one contact succeeded to make a jitsi-audio-call after moving the
active and connected interface to the last place behind the active but
nonconnected wlan-interface.

maybe related: this user reported that jitsi is very memory-hungry
(~700
mb) on his machine. on my machine jitsi currently uses ~174 mb - less
than firefox but more than thunderbird.

Am 13.05.2013 12:40, schrieb g.spellauge:

two of my contacts changed the binding order by pushing the correct
nic to the first palce and i was able to call them/they were able to call

me.

this workaround was not successful (no change) for two other contacts.

Am 11.05.2013 13:30, schrieb Ingo Bauersachs:

Changing the binding order might also help: if the NIC you want to
use is really at index 0, you luckily get the result you want.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#2

This actually works for me as well, just adding the --ipv4 option.

FWIW, ipv4 simply leads to Jitsi setting these two system properties:

  System.setProperty("java.net.preferIPv4Stack", "true");
        System.setProperty("java.net.preferIPv6Addresses", "false");

I had
to modify the registry with this option in order for it to take effect on
Windows startup. Is there any way this could be a configuration option
within Jitsi to avoid the registry editing?

Afraid not. These properties need to be set before we have made any
references to anything that could initialise the network stack. Our
configuration service loads way too late in the bootstrap sequence for
that to happen.

The two possible resolutions here are: waiting for OpenJDK to fix the
issue or extending our native windows network utils to provide Jitsi
implementations for the methods that are being mischievous.

The path we take depends on two things:

1. How soon the problem could get resolved in the JVM
2. What percentage of our users are running Jitsi in environments that
have the problem.

Could someone please act as a liaison with the OpenJDK community and try
to get their view on this? This would give us a better idea of what to do.

Emil

···

On 25.05.13, 23:47, Ken Ayotte wrote:
  

-----Original Message-----
From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of
g.spellauge
Sent: Friday, May 24, 2013 10:38
To: dev@jitsi.java.net
Subject: [jitsi-dev] Re: Windows 7 multiple NIC issue

appending -4 to Jitsi.exe seems to solve this issue. we verified this on two
computers. according to
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6458027 enabeling
ipv6 on the interface should also fix this issue.

Jitsi 2.2.4603.9615
age: jitsi [OPTIONS] [uri-to-call]

-c, --config=DIR use DIR for config files
-d, --debug print debugging messages to stdout
-h, --help display this help message and exit
-m, --multiple do not ensure single instance
-6, --ipv6 prefer IPv6 addresses where possible only
-4, --ipv4 forces use of IPv4 only
-v, --version display the current version and exit

is -4 the option we are looking for i.e. is it equivalent to the jre option
-Djava.net.preferIPv4Stack=true ?

Am 14.05.2013 11:31, schrieb g.spellauge:

one contact succeeded to make a jitsi-audio-call after moving the
active and connected interface to the last place behind the active but
nonconnected wlan-interface.

maybe related: this user reported that jitsi is very memory-hungry
(~700
mb) on his machine. on my machine jitsi currently uses ~174 mb - less
than firefox but more than thunderbird.

Am 13.05.2013 12:40, schrieb g.spellauge:

two of my contacts changed the binding order by pushing the correct
nic to the first palce and i was able to call them/they were able to call

me.

this workaround was not successful (no change) for two other contacts.

Am 11.05.2013 13:30, schrieb Ingo Bauersachs:

Changing the binding order might also help: if the NIC you want to
use is really at index 0, you luckily get the result you want.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org