[jitsi-dev] Voicemail URI not respected


#1

Hi,

There is an option in the SIP account setting called "Voicemail URI".

In all other SIP clients I have used, this field is used to indicate what
extension to dial when the phone wants to access voicemail.

However no matter what I enter in that field, when I click the call
voicemail button under the "Voicemail" section in the interface it instead
calls the user's extension.

E.g.
My extension: 641
Voicemail URI: 4000

Click the voicemail button it dials 641 rather than 4000.

Does this qualify as a bug?

Thanks
Tom Parrott


#2

Hey Tom,

Hi,

There is an option in the SIP account setting called "Voicemail URI".

Yup we use that to tell Jitsi what URI to subscribe to for Voicemail
notifications.

In all other SIP clients I have used, this field is used to indicate what
extension to dial when the phone wants to access voicemail.

However no matter what I enter in that field, when I click the call
voicemail button under the "Voicemail" section in the interface it instead
calls the user's extension.

We call the number that is indicated by the Message-Account: header as
per RFC 3842.

E.g.
My extension: 641
Voicemail URI: 4000

Click the voicemail button it dials 641 rather than 4000.

Does this qualify as a bug?

Your server is probably setting the Message-Account: header to 641 which
it shouldn't do if it doesn't work for voicemail.

Hope this helps,
Emil

···

On 16.07.12 13:46, Tom Parrott wrote:


#3

Hi Emil,

Thanks for your response, I will check that out.

We use Freeswitch, so I'm sure the header can be configured if need be,
was just not something I've come across before as clients like Xlient dial
the voicemail URI also.

Thanks
Tom

···

Hey Tom,

On 16.07.12 13:46, Tom Parrott wrote:

Hi,

There is an option in the SIP account setting called "Voicemail URI".

Yup we use that to tell Jitsi what URI to subscribe to for Voicemail
notifications.

In all other SIP clients I have used, this field is used to indicate
what
extension to dial when the phone wants to access voicemail.

However no matter what I enter in that field, when I click the call
voicemail button under the "Voicemail" section in the interface it
instead
calls the user's extension.

We call the number that is indicated by the Message-Account: header as
per RFC 3842.

E.g.
My extension: 641
Voicemail URI: 4000

Click the voicemail button it dials 641 rather than 4000.

Does this qualify as a bug?

Your server is probably setting the Message-Account: header to 641 which
it shouldn't do if it doesn't work for voicemail.

Hope this helps,
Emil