[jitsi-dev] Videobridge --host not overriding --domain?


#1

Hi all,

I'm trying to configure the videobridge to work with Prosody. Prosody
listens for external components on localhost:5347, and requires a domain to
be configured:

http://prosody.im/doc/components#adding_an_external_component

when I try to run

jvb.sh --secret=xxxxx --port=5347

I get a xmpp unknown host exception

When I try

jvb.sh --secret=xxxxx --host="localhost"
--domain='jitsi-videobridge.example.com' --port=5347

The connection is refused. I think in the second case, the videobridge
is still trying to connect to
jitsi-videobridge.example.com instead of localhost like it says in the help?

--domain=DOMAIN sets the XMPP domain (default: host, if host is set,
none otherwise)


#2

Hello,

Hi all,

I'm trying to configure the videobridge to work with Prosody. Prosody
listens for external components on localhost:5347, and requires a domain
to be configured:

http://prosody.im/doc/components#adding_an_external_component

when I try to run

jvb.sh --secret=xxxxx --port=5347

I get a xmpp unknown host exception

When I try

jvb.sh --secret=xxxxx --host="localhost" --domain='jitsi-videobridge.example.com <http://jitsi-videobridge.example.com>' --port=5347

The connection is refused. I think in the second case, the videobridge is still trying to connect to
jitsi-videobridge.example.com <http://jitsi-videobridge.example.com> instead of localhost like it says in the help?

--domain=DOMAIN sets the XMPP domain (default: host, if host is set, none otherwise)

Which version of the videobridge are you running? The usage instructions
that you cite are indeed incorrect, but they were fixed a couple of
weeks ago. They should say:

--domain=DOMAIN\t sets the XMPP domain (default: none)
--host=HOST\t sets the hostname of the XMPP server (default: domain, if
domain is set, \"localhost\" otherwise)

Still, setting both --domain and --host should have worked. Can you
verify that prosody listens on localhost:5347? For example on linux you
can do it with:
netstat -ln | grep 5347

Another note: you should be using "--domain=example.com" instead of
"--domain=jitsi-videobridge.example.com" (although I'm not absolutely
sure that this will cause problems)

Regards,
Boris

ยทยทยท

On 22/01/14 20:58, Sean Whalen wrote: