[jitsi-dev] Video resolution selection parameters reversed


#1

Hello Jitsi Community,

I was going to report this as a bug on JIRA, but the Jitsi website steered me this direction. I think this is a simple bug. I also searched on JIRA for a similar issue but did not find one.

I am running Jitsi nightly from Feb 1, 2012 (build 3884) on Mac OSX (Snow Leopard). When going to the Jitsi Options, then selecting Video, then "More settings", there is a drop-down box that allows selecting the Video resolution. The default value is "Auto", but there are several other choices. I attempted to run a video call at 1280x720, but the resulting video was stretched to be very tall and narrow. Suspecting that the height and width were reversed, I edited the file $HOME/Library/Application Support/Jitsi/sip-communicator.properties and found these two lines:

net.java.sip.communicator.impl.neomedia.video.height=720
net.java.sip.communicator.impl.neomedia.video.width=1280

Even though those two lines look correct, I tried reversing them so they looked like this:

net.java.sip.communicator.impl.neomedia.video.height=1280
net.java.sip.communicator.impl.neomedia.video.width=720

After restarting Jitsi the video appeared correctly.

/BAK/

···

--
Ben Klang
bklang@mojolingo.com
404.475.4841

Mojo Lingo -- Voice applications that work like magic
http://mojolingo.com
Twitter: @MojoLingo


#2

Thanks Ben,

We'll check it out.

Cheers,
Emil

···

On Thu, Feb 2, 2012 at 4:30 PM, Ben Klang <bklang@mojolingo.com> wrote:

Hello Jitsi Community,

I was going to report this as a bug on JIRA, but the Jitsi website steered
me this direction. I think this is a simple bug. I also searched on JIRA
for a similar issue but did not find one.

I am running Jitsi nightly from Feb 1, 2012 (build 3884) on Mac OSX (Snow
Leopard). When going to the Jitsi Options, then selecting Video, then "More
settings", there is a drop-down box that allows selecting the Video
resolution. The default value is "Auto", but there are several other
choices. I attempted to run a video call at 1280x720, but the resulting
video was stretched to be very tall and narrow. Suspecting that the height
and width were reversed, I edited the file $HOME/Library/Application
Support/Jitsi/sip-communicator.properties and found these two lines:

net.java.sip.communicator.impl.neomedia.video.height=720
net.java.sip.communicator.impl.neomedia.video.width=1280

Even though those two lines look correct, I tried reversing them so they
looked like this:

net.java.sip.communicator.impl.neomedia.video.height=1280
net.java.sip.communicator.impl.neomedia.video.width=720

After restarting Jitsi the video appeared correctly.

/BAK/
--
Ben Klang
bklang@mojolingo.com
404.475.4841

Mojo Lingo -- Voice applications that work like magic
http://mojolingo.com
Twitter: @MojoLingo

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#3

Hi Ben,

I have just done a 1280x720 video call to an echo service with SIP (on Mac OS X Snow Leopard) and all looks normal to me.

BTW I try to reverse height and width value as you suggest but it does not work: I had a video call with 640x480 image and after I go to the "More settings" resolution value was "auto" (probably because 720x1280 is not in the list of standard capture size so it reverts to default).

Can you send us a screenshot of the "resulting video" and also your logs (http://jitsi.org/index.php/Documentation/FAQ#logs) please ?

Regards,

···

--
Seb

Le 02/02/12 16:30, Ben Klang a �crit :

Hello Jitsi Community,

I was going to report this as a bug on JIRA, but the Jitsi website steered me this direction. I think this is a simple bug. I also searched on JIRA for a similar issue but did not find one.

I am running Jitsi nightly from Feb 1, 2012 (build 3884) on Mac OSX (Snow Leopard). When going to the Jitsi Options, then selecting Video, then "More settings", there is a drop-down box that allows selecting the Video resolution. The default value is "Auto", but there are several other choices. I attempted to run a video call at 1280x720, but the resulting video was stretched to be very tall and narrow. Suspecting that the height and width were reversed, I edited the file $HOME/Library/Application Support/Jitsi/sip-communicator.properties and found these two lines:

net.java.sip.communicator.impl.neomedia.video.height=720
net.java.sip.communicator.impl.neomedia.video.width=1280

Even though those two lines look correct, I tried reversing them so they looked like this:

net.java.sip.communicator.impl.neomedia.video.height=1280
net.java.sip.communicator.impl.neomedia.video.width=720

After restarting Jitsi the video appeared correctly.

/BAK/
--
Ben Klang
bklang@mojolingo.com <mailto:bklang@mojolingo.com>
404.475.4841

Mojo Lingo -- /Voice applications that work like magic/
http://mojolingo.com <http://mojolingo.com/>
Twitter: @MojoLingo