[jitsi-dev] /usr/bin/java: symbol lookup error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol: clock_gettime


#1

Hello,

I would like to use Jitsi on my computer, but I have still some
trouble:
Operating System: Ubuntu 8.04
Java version: java-6-sun-1.6.0.24

1.) It is difficult to open Jitsi; I got by command line:

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefine

2.) I got the program started by trying to open it several times.
JavaSound works, but sounds not very well (so I do not want to use it).
PortAudio does not work: usually the computer program crashes down,
sometimes it is possible to built up a call with no voice for a short
time; surprisingly recording works well (no voice during recording, but
voice when opening the mp3 file):

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.
javax.media.ResourceUnavailableException: inputFormat not set
  at
net.java.sip.communicator.impl.neomedia.jmfext.media.renderer.audio.PortAudioRenderer.open(PortAudioRenderer.java:368)
  at
net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread(PortAudioClipImpl.java:283)
  at
net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runInPlayThread(PortAudioClipImpl.java:133)
  at
net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.access
$000(PortAudioClipImpl.java:25)
  at net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl
$1.run(PortAudioClipImpl.java:71)
warning: The VAD has been replaced by a hack pending a complete rewrite
  Unable to handle format: LINEAR, 44100.0 Hz, 16-bit, Mono,
LittleEndian, Signed
Failed to realize: com.sun.media.ProcessEngine@9278d5
Error: Unable to realize com.sun.media.ProcessEngine@9278d5
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime

Sorry, I am not an expert. I hope anyone will understand this and help
me. I do not understand:
- warning: The VAD has been replaced by a hack pending a complete
rewrite
- error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime
- Failed to realize: com.sun.media.ProcessEngine@9278d5
- 11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.

With best wishes, Robert


#2

I got the same issue. Please let me know if you get the solution?

···

On Thu, May 5, 2011 at 2:15 PM, Robert Fischer <fir@goldmail.de> wrote:

Hello,

I would like to use Jitsi on my computer, but I have still some
trouble:
Operating System: Ubuntu 8.04
Java version: java-6-sun-1.6.0.24

1.) It is difficult to open Jitsi; I got by command line:

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefine

2.) I got the program started by trying to open it several times.
JavaSound works, but sounds not very well (so I do not want to use it).
PortAudio does not work: usually the computer program crashes down,
sometimes it is possible to built up a call with no voice for a short
time; surprisingly recording works well (no voice during recording, but
voice when opening the mp3 file):

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.
javax.media.ResourceUnavailableException: inputFormat not set
       at

net.java.sip.communicator.impl.neomedia.jmfext.media.renderer.audio.PortAudioRenderer.open(PortAudioRenderer.java:368)
       at

net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread(PortAudioClipImpl.java:283)
       at

net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runInPlayThread(PortAudioClipImpl.java:133)
       at
net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.access
$000(PortAudioClipImpl.java:25)
       at net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl
$1.run(PortAudioClipImpl.java:71)
warning: The VAD has been replaced by a hack pending a complete rewrite
Unable to handle format: LINEAR, 44100.0 Hz, 16-bit, Mono,
LittleEndian, Signed
Failed to realize: com.sun.media.ProcessEngine@9278d5
Error: Unable to realize com.sun.media.ProcessEngine@9278d5
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime

Sorry, I am not an expert. I hope anyone will understand this and help
me. I do not understand:
- warning: The VAD has been replaced by a hack pending a complete
rewrite
- error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime
- Failed to realize: com.sun.media.ProcessEngine@9278d5
- 11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.

With best wishes, Robert


#3

Good Afternoon,

Is there a solution to this problem?

Leo

···

On Thu, May 5, 2011 at 2:15 PM, Robert Fischer <fir@goldmail.de> wrote:

Hello,

I would like to use Jitsi on my computer, but I have still some
trouble:
Operating System: Ubuntu 8.04
Java version: java-6-sun-1.6.0.24

1.) It is difficult to open Jitsi; I got by command line:

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefine

2.) I got the program started by trying to open it several times.
JavaSound works, but sounds not very well (so I do not want to use it).
PortAudio does not work: usually the computer program crashes down,
sometimes it is possible to built up a call with no voice for a short
time; surprisingly recording works well (no voice during recording, but
voice when opening the mp3 file):

marigold7@Lenovo:~$ jitsi
warning: The VAD has been replaced by a hack pending a complete rewrite
11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.
javax.media.ResourceUnavailableException: inputFormat not set
       at

net.java.sip.communicator.impl.neomedia.jmfext.media.renderer.audio.PortAudioRenderer.open(PortAudioRenderer.java:368)
       at

net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread(PortAudioClipImpl.java:283)
       at

net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.runInPlayThread(PortAudioClipImpl.java:133)
       at
net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl.access
$000(PortAudioClipImpl.java:25)
       at net.java.sip.communicator.impl.neomedia.notify.PortAudioClipImpl
$1.run(PortAudioClipImpl.java:71)
warning: The VAD has been replaced by a hack pending a complete rewrite
Unable to handle format: LINEAR, 44100.0 Hz, 16-bit, Mono,
LittleEndian, Signed
Failed to realize: com.sun.media.ProcessEngine@9278d5
Error: Unable to realize com.sun.media.ProcessEngine@9278d5
/usr/bin/java: symbol lookup
error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime

Sorry, I am not an expert. I hope anyone will understand this and help
me. I do not understand:
- warning: The VAD has been replaced by a hack pending a complete
rewrite
- error: /usr/lib/jitsi/lib/native/libjnportaudio.so: undefined symbol:
clock_gettime
- Failed to realize: com.sun.media.ProcessEngine@9278d5
- 11:48:02.778 SCHWERWIEGEND:
impl.neomedia.notify.PortAudioClipImpl.runOnceInPlayThread().317 Failed
to open PortAudioRenderer.

With best wishes, Robert