[jitsi-dev] using videobridge at separate IP


#1

Hi,

Would anybody help me with correct settings for jitsi-videobridge run setup for the case when it is located at another ip in the same LAN.
Actually I need it for debugging at Eclipse, but the first step is running it in a command line.

My setup : Debian 7 (192.168.100.128), running under VMPlayer at Windows 7 (192.168.200.51)
Jitsi-meet & prosody gotten from install package

Eclipse Luna under Windows.
JDK 7 at both ones.

What I tried :

1) etc/jitsi/meet/192.168.100.128-config.js

Changed bridge ip :

    hosts: {
        domain: '192.168.100.128',
        muc: 'conference.192.168.100.128', // FIXME: use XEP-0030

       // bridge: 'jitsi-videobridge.192.168.100.128', // FIXME: use XEP-0030
      bridge: 'jitsi-videobridge.192.168.200.51', // FIXME: use XEP-0030

        //jirecon: 'jirecon.192.168.100.128',
        //call_control: 'callcontrol.192.168.100.128',
        //focus: 'focus.192.168.100.128' - defaults to 'focus.192.168.100.128'
    },

2) etc/prosody/conf.d/192.168.100.128.cfg.lua

Changed "component jitsi-videobridge" ip :

VirtualHost "192.168.100.128"
        -- enabled = false -- Remove this line to enable this host
        authentication = "anonymous"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/192.168.100.128.key";
                certificate = "/etc/prosody/certs/192.168.100.128.crt";
       }
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
        }

Component "conference.192.168.100.128" "muc"
admins = { "focus@auth.192.168.100.128" }

--Component "jitsi-videobridge.192.168.100.128"
Component "jitsi-videobridge.192.168.200.51"
    component_secret = "1"

VirtualHost "auth.192.168.100.128"
        authentication = "internal_plain"

Component "focus.192.168.100.128"
    component_secret = "xxxxxxxxxx"

From Windows I tried

call jvb.bat --host=localhost --domain=192.168.100.128 --port=5347 --secret=1
call jvb.bat --host=192.168.200.51 --domain=192.168.100.128 --port=5347 --secret=1
call jvb.bat --host=192.168.100.128--domain=192.168.100.128 --port=5347 --secret=1
call jvb.bat --domain=192.168.100.128 --port=5347 --secret=1
call jvb.bat --host=192.168.100.128 --port=5347 --secret=1

using changes above and without them - with the same result :

SEVERE: An uncaught exception occurred in thread=Thread[main,5,main] and message was: java.net.ConnectException: Connection refused: connect
org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused: connect
                at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)
                at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
                at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
                at org.jitsi.videobridge.Main.main(Main.java:275)
Caused by: java.net.ConnectException: Connection refused: connect
                at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
                at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
                at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
                at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
                at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
                at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
                at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
                at java.net.Socket.connect(Socket.java:579)
                at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

I used jitsi-videobridge.jar from the installation and built myself (both are OK being placed in standard Linux environment).

Thanks,
Abagyan


#2

Hey,

I didn't try to use in LAN, but for external IPs, I do as following.

Add prosody.cfg.lua:
component_interface = "192.168.100.128"

For videobridge use
--host=192.168.100.128

Regards,
Zalmoxisus

···

On Wed, Apr 15, 2015 at 1:52 PM, Alexander Abagyan <abagyan@spiritdsp.com> wrote:

Hi,

Would anybody help me with correct settings for jitsi-videobridge run setup
for the case when it is located at another ip in the same LAN.

Actually I need it for debugging at Eclipse, but the first step is running
it in a command line.

My setup : Debian 7 (192.168.100.128), running under VMPlayer at Windows 7
(192.168.200.51)

Jitsi-meet & prosody gotten from install package

Eclipse Luna under Windows.

JDK 7 at both ones.

What I tried :

1) etc/jitsi/meet/192.168.100.128-config.js

Changed bridge ip :

    hosts: {

        domain: '192.168.100.128',

        muc: 'conference.192.168.100.128', // FIXME: use XEP-0030

       // bridge: 'jitsi-videobridge.192.168.100.128', // FIXME: use
XEP-0030

      bridge: 'jitsi-videobridge.192.168.200.51', // FIXME: use XEP-0030

        //jirecon: 'jirecon.192.168.100.128',

        //call_control: 'callcontrol.192.168.100.128',

        //focus: 'focus.192.168.100.128' - defaults to
'focus.192.168.100.128'

    },

2) etc/prosody/conf.d/192.168.100.128.cfg.lua

Changed “component jitsi-videobridge” ip :

VirtualHost "192.168.100.128"

        -- enabled = false -- Remove this line to enable this host

        authentication = "anonymous"

        -- Assign this host a certificate for TLS, otherwise it would use
the one

        -- set in the global section (if any).

        -- Note that old-style SSL on port 5223 only supports one
certificate, and will always

        -- use the global one.

        ssl = {

                key = "/etc/prosody/certs/192.168.100.128.key";

                certificate = "/etc/prosody/certs/192.168.100.128.crt";

       }

        -- we need bosh

        modules_enabled = {

            "bosh";

            "pubsub";

        }

Component "conference.192.168.100.128" "muc"

admins = { "focus@auth.192.168.100.128" }

--Component "jitsi-videobridge.192.168.100.128"

Component "jitsi-videobridge.192.168.200.51"

    component_secret = "1"

VirtualHost "auth.192.168.100.128"

        authentication = "internal_plain"

Component "focus.192.168.100.128"

    component_secret = "xxxxxxxxxx"

From Windows I tried

call jvb.bat --host=localhost --domain=192.168.100.128 --port=5347
--secret=1

call jvb.bat --host=192.168.200.51 --domain=192.168.100.128 --port=5347
--secret=1

call jvb.bat --host=192.168.100.128--domain=192.168.100.128 --port=5347
--secret=1

call jvb.bat --domain=192.168.100.128 --port=5347 --secret=1

call jvb.bat --host=192.168.100.128 --port=5347 --secret=1

using changes above and without them - with the same result :

SEVERE: An uncaught exception occurred in thread=Thread[main,5,main] and
message was: java.net.ConnectException: Connection refused: connect

org.xmpp.component.ComponentException: java.net.ConnectException: Connection
refused: connect

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

                at org.jitsi.videobridge.Main.main(Main.java:275)

Caused by: java.net.ConnectException: Connection refused: connect

                at java.net.DualStackPlainSocketImpl.waitForConnect(Native
Method)

                at
java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)

                at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)

                at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)

                at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)

                at
java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

                at
java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

                at java.net.Socket.connect(Socket.java:579)

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

I used jitsi-videobridge.jar from the installation and built myself (both
are OK being placed in standard Linux environment).

Thanks,

Abagyan

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

You mean you didn't touch the configs at all, just run external jvb pointed to that host ?

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Michael Diordiev
Sent: Wednesday, April 15, 2015 3:01 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] using videobridge at separate IP

Hey,

I didn't try to use in LAN, but for external IPs, I do as following.

Add prosody.cfg.lua:
component_interface = "192.168.100.128"

For videobridge use
--host=192.168.100.128

Regards,
Zalmoxisus

On Wed, Apr 15, 2015 at 1:52 PM, Alexander Abagyan <abagyan@spiritdsp.com> wrote:

Hi,

Would anybody help me with correct settings for jitsi-videobridge run
setup for the case when it is located at another ip in the same LAN.

Actually I need it for debugging at Eclipse, but the first step is
running it in a command line.

My setup : Debian 7 (192.168.100.128), running under VMPlayer at
Windows 7
(192.168.200.51)

Jitsi-meet & prosody gotten from install package

Eclipse Luna under Windows.

JDK 7 at both ones.

What I tried :

1) etc/jitsi/meet/192.168.100.128-config.js

Changed bridge ip :

    hosts: {

        domain: '192.168.100.128',

        muc: 'conference.192.168.100.128', // FIXME: use XEP-0030

       // bridge: 'jitsi-videobridge.192.168.100.128', // FIXME: use
XEP-0030

      bridge: 'jitsi-videobridge.192.168.200.51', // FIXME: use
XEP-0030

        //jirecon: 'jirecon.192.168.100.128',

        //call_control: 'callcontrol.192.168.100.128',

        //focus: 'focus.192.168.100.128' - defaults to
'focus.192.168.100.128'

    },

2) etc/prosody/conf.d/192.168.100.128.cfg.lua

Changed “component jitsi-videobridge” ip :

VirtualHost "192.168.100.128"

        -- enabled = false -- Remove this line to enable this host

        authentication = "anonymous"

        -- Assign this host a certificate for TLS, otherwise it would
use the one

        -- set in the global section (if any).

        -- Note that old-style SSL on port 5223 only supports one
certificate, and will always

        -- use the global one.

        ssl = {

                key = "/etc/prosody/certs/192.168.100.128.key";

                certificate =
"/etc/prosody/certs/192.168.100.128.crt";

       }

        -- we need bosh

        modules_enabled = {

            "bosh";

            "pubsub";

        }

Component "conference.192.168.100.128" "muc"

admins = { "focus@auth.192.168.100.128" }

--Component "jitsi-videobridge.192.168.100.128"

Component "jitsi-videobridge.192.168.200.51"

    component_secret = "1"

VirtualHost "auth.192.168.100.128"

        authentication = "internal_plain"

Component "focus.192.168.100.128"

    component_secret = "xxxxxxxxxx"

From Windows I tried

call jvb.bat --host=localhost --domain=192.168.100.128 --port=5347
--secret=1

call jvb.bat --host=192.168.200.51 --domain=192.168.100.128
--port=5347
--secret=1

call jvb.bat --host=192.168.100.128--domain=192.168.100.128
--port=5347
--secret=1

call jvb.bat --domain=192.168.100.128 --port=5347 --secret=1

call jvb.bat --host=192.168.100.128 --port=5347 --secret=1

using changes above and without them - with the same result :

SEVERE: An uncaught exception occurred in thread=Thread[main,5,main]
and message was: java.net.ConnectException: Connection refused:
connect

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection
refused: connect

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.jav
a:272)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalC
omponentManager.java:221)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalC
omponentManager.java:201)

                at org.jitsi.videobridge.Main.main(Main.java:275)

Caused by: java.net.ConnectException: Connection refused: connect

                at
java.net.DualStackPlainSocketImpl.waitForConnect(Native
Method)

                at
java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketIm
pl.java:85)

                at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.jav
a:339)

                at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketI
mpl.java:200)

                at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:
182)

                at
java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

                at
java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

                at java.net.Socket.connect(Socket.java:579)

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.jav
a:151)

I used jitsi-videobridge.jar from the installation and built myself
(both are OK being placed in standard Linux environment).

Thanks,

Abagyan

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

To get rid of the error you've indicated you have to add to
prosody.cfg.lua component_interface with the external ip you use, by
default it's localhost, and that's why the connection from your bridge
is not permitted. About other settings, I'm not sure as my
configuration is completely different, and I've made it long time ago.

···

On Wed, Apr 15, 2015 at 3:14 PM, Alexander Abagyan <abagyan@spiritdsp.com> wrote:

You mean you didn't touch the configs at all, just run external jvb pointed to that host ?

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Michael Diordiev
Sent: Wednesday, April 15, 2015 3:01 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] using videobridge at separate IP

Hey,

I didn't try to use in LAN, but for external IPs, I do as following.

Add prosody.cfg.lua:
component_interface = "192.168.100.128"

For videobridge use
--host=192.168.100.128

Regards,
Zalmoxisus

On Wed, Apr 15, 2015 at 1:52 PM, Alexander Abagyan <abagyan@spiritdsp.com> wrote:

Hi,

Would anybody help me with correct settings for jitsi-videobridge run
setup for the case when it is located at another ip in the same LAN.

Actually I need it for debugging at Eclipse, but the first step is
running it in a command line.

My setup : Debian 7 (192.168.100.128), running under VMPlayer at
Windows 7
(192.168.200.51)

Jitsi-meet & prosody gotten from install package

Eclipse Luna under Windows.

JDK 7 at both ones.

What I tried :

1) etc/jitsi/meet/192.168.100.128-config.js

Changed bridge ip :

    hosts: {

        domain: '192.168.100.128',

        muc: 'conference.192.168.100.128', // FIXME: use XEP-0030

       // bridge: 'jitsi-videobridge.192.168.100.128', // FIXME: use
XEP-0030

      bridge: 'jitsi-videobridge.192.168.200.51', // FIXME: use
XEP-0030

        //jirecon: 'jirecon.192.168.100.128',

        //call_control: 'callcontrol.192.168.100.128',

        //focus: 'focus.192.168.100.128' - defaults to
'focus.192.168.100.128'

    },

2) etc/prosody/conf.d/192.168.100.128.cfg.lua

Changed “component jitsi-videobridge” ip :

VirtualHost "192.168.100.128"

        -- enabled = false -- Remove this line to enable this host

        authentication = "anonymous"

        -- Assign this host a certificate for TLS, otherwise it would
use the one

        -- set in the global section (if any).

        -- Note that old-style SSL on port 5223 only supports one
certificate, and will always

        -- use the global one.

        ssl = {

                key = "/etc/prosody/certs/192.168.100.128.key";

                certificate =
"/etc/prosody/certs/192.168.100.128.crt";

       }

        -- we need bosh

        modules_enabled = {

            "bosh";

            "pubsub";

        }

Component "conference.192.168.100.128" "muc"

admins = { "focus@auth.192.168.100.128" }

--Component "jitsi-videobridge.192.168.100.128"

Component "jitsi-videobridge.192.168.200.51"

    component_secret = "1"

VirtualHost "auth.192.168.100.128"

        authentication = "internal_plain"

Component "focus.192.168.100.128"

    component_secret = "xxxxxxxxxx"

From Windows I tried

call jvb.bat --host=localhost --domain=192.168.100.128 --port=5347
--secret=1

call jvb.bat --host=192.168.200.51 --domain=192.168.100.128
--port=5347
--secret=1

call jvb.bat --host=192.168.100.128--domain=192.168.100.128
--port=5347
--secret=1

call jvb.bat --domain=192.168.100.128 --port=5347 --secret=1

call jvb.bat --host=192.168.100.128 --port=5347 --secret=1

using changes above and without them - with the same result :

SEVERE: An uncaught exception occurred in thread=Thread[main,5,main]
and message was: java.net.ConnectException: Connection refused:
connect

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection
refused: connect

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.jav
a:272)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalC
omponentManager.java:221)

                at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalC
omponentManager.java:201)

                at org.jitsi.videobridge.Main.main(Main.java:275)

Caused by: java.net.ConnectException: Connection refused: connect

                at
java.net.DualStackPlainSocketImpl.waitForConnect(Native
Method)

                at
java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketIm
pl.java:85)

                at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.jav
a:339)

                at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketI
mpl.java:200)

                at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:
182)

                at
java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

                at
java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

                at java.net.Socket.connect(Socket.java:579)

                at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.jav
a:151)

I used jitsi-videobridge.jar from the installation and built myself
(both are OK being placed in standard Linux environment).

Thanks,

Abagyan

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Just one more thing -- to debug this faster, you can try telnetting to the
prosody components port, it's 5347 by default. If you can't connect from
the other host, that means that the videobridge too won't be able to
connect and register.

There could be other things preventing the connection -- firewalls,
network setup etc. so a quick telnet check is a handy thing.

···

On Wed, Apr 15, 2015 at 4:05 PM, Michael Diordiev <zalmoxisus@gmail.com> wrote:

To get rid of the error you've indicated you have to add
to prosody.cfg.lua component_interface with the external ip you use,
by default it's localhost, and that's why the connection from your
bridge is not permitted. About other settings, I'm not sure as
my configuration is completely different, and I've made it long time ago.

--

Yasen Pramatarov
CEO at Lindeas Ltd. https://lindeas.com
'working on GNU/Linux ideas'