[jitsi-dev] Using Jitsi Meet SDK in Smart Glass App


#1

Hi All,

I am using jitsi meet sdk for android to build an application for a Smart
Glass (Vuzix M300). The app joins a room without any issue when I test it
on a Android Phone. But when I try it on the Smart Glass I get the
following error.

E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to create

local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed to
create new track"

[5:49]
E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to create
local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed to
create new
track"},"constraints":{"audio":false,"video":{"mandatory":{"minWidth":1280,"minHeight":720,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":"user"}],"facingMode":"user","width":{"ideal":1280},"height":{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.android.bundle
:455:24407\nindex.android.bundle:459:35694\nh@index.android.bundle
:459:15179\nindex.android.bundle:459:15428\nindex.android.bundle:448:1233\nvalue@index.android.bundle
:79:3019\nindex.android.bundle:79:1362\nindex.android.bundle:79:106\nvalue@index.android.bundle:79:1332\n[native
code]"}

I suspect that the minimum video resolutions case the problem. Is there any
tips to track down the issue ?

···

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#2

If the camera resolution is the problem, you will need to hack around in react-native-webrtc: https://github.com/oney/react-native-webrtc since we default to 720p.

Cheers,

···

On Oct 30, 2017, at 13:21, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:

Hi All,

I am using jitsi meet sdk for android to build an application for a Smart Glass (Vuzix M300). The app joins a room without any issue when I test it on a Android Phone. But when I try it on the Smart Glass I get the following error.

E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed to create new track"

[5:49]
E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed to create new track"},"constraints":{"audio":false,"video":{"mandatory":{"minWidth":1280,"minHeight":720,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":"user"}],"facingMode":"user","width":{"ideal":1280},"height":{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed to create new track","stack":"r@index.android.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.android.bundle:459:15179\nindex.android.bundle:459:15428\nindex.android.bundle:448:1233\nvalue@index.android.bundle:79:3019\nindex.android.bundle:79:1362\nindex.android.bundle:79:106\nvalue@index.android.bundle:79:1332\n[native code]"}

I suspect that the minimum video resolutions case the problem. Is there any tips to track down the issue ?

--
Saúl


#3

Thanks for the quick reply. I will try and let you know.

···

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio":false,"video":{"mandatory":{"
minWidth":1280,"minHeight":720,"maxWidth":1280,"
maxHeight":720},"optional":[{"facingMode":"user"}],"
facingMode":"user","width":{"ideal":1280},"height":{"ideal"
:720}}},"devices":["video"]},"name":"gum.general","message":"Failed to
create new track","stack":"r@index.android.bundle:455:24407\
nindex.android.bundle:459:35694\nh@index.android.bundle:
459:15179\nindex.android.bundle:459:15428\nindex.android.bundle:448:1233\
nvalue@index.android.bundle:79:3019\nindex.android.bundle:
79:1362\nindex.android.bundle:79:106\nvalue@index.android.bundle:79:1332\n[native
code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is there
any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around in
react-native-webrtc: https://github.com/oney/react-native-webrtc since we
default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#4

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1]
https://github.com/buddhikajay/jitsi-meet/wiki/Android-App-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

···

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode"
:"user"}],"facingMode":"user","width":{"ideal":1280},"
height":{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.android.bundle:455:24407\nindex.
android.bundle:459:35694\nh@index.android.bundle:459:
15179\nindex.android.bundle:459:15428\nindex.android.
bundle:448:1233\nvalue@index.android.bundle:79:3019\nindex.
android.bundle:79:1362\nindex.android.bundle:79:106\nvalue@
index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is there
any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around in
react-native-webrtc: https://github.com/oney/react-native-webrtc since
we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi Nam,

Yes, I had to make some changes in libjitsi meet, then build the Jitsi Meet
SDK with it. Then published it as maven repository. That repo was used to
build custom app to smart glass. It worked for the particular smart glass
that I used. What is the Glass that you are working with ?

···

On Tue, Dec 26, 2017 at 3:46 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1] https://github.com/buddhikajay/jitsi-meet/wiki/
Android-App-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < >> scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >>> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":
"user"}],"facingMode":"user","width":{"ideal":1280},"height"
:{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.androi
d.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.
android.bundle:459:15179\nindex.android.bundle:459:
15428\nindex.android.bundle:448:1233\nvalue@index.android.
bundle:79:3019\nindex.android.bundle:79:1362\nindex.android.
bundle:79:106\nvalue@index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is
there any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around in
react-native-webrtc: https://github.com/oney/react-native-webrtc since
we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#6

Hi Buddhika,

I am working with Vuzix M100, could you please share more information about
your maven repository or your custom app?

Thanks

Nam Vu

···

On Tue, Dec 26, 2017 at 5:37 PM, Buddhika Jayawardhana < buddhika.anushka@gmail.com> wrote:

Hi Nam,

Yes, I had to make some changes in libjitsi meet, then build the Jitsi
Meet SDK with it. Then published it as maven repository. That repo was used
to build custom app to smart glass. It worked for the particular smart
glass that I used. What is the Glass that you are working with ?

On Tue, Dec 26, 2017 at 3:46 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1] https://github.com/buddhikajay/jitsi-meet/wiki/Android-
App-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < >> buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < >>> scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >>>> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":
"user"}],"facingMode":"user","width":{"ideal":1280},"height"
:{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.androi
d.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.
android.bundle:459:15179\nindex.android.bundle:459:15428\
nindex.android.bundle:448:1233\nvalue@index.android.bund
le:79:3019\nindex.android.bundle:79:1362\nindex.android.bund
le:79:106\nvalue@index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is
there any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around
in react-native-webrtc: https://github.com/oney/react-native-webrtc
since we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#7

Hi Nam,

Please use this maven repo on your android application :
https://github.com/meetrix/jitsi-maven-repository/tree/smart-maven. Let me
know if it works. Worked with Vuzix M300.

- BR

···

On Tue, Dec 26, 2017 at 4:13 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika,

I am working with Vuzix M100, could you please share more information
about your maven repository or your custom app?

Thanks

Nam Vu

On Tue, Dec 26, 2017 at 5:37 PM, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:

Hi Nam,

Yes, I had to make some changes in libjitsi meet, then build the Jitsi
Meet SDK with it. Then published it as maven repository. That repo was used
to build custom app to smart glass. It worked for the particular smart
glass that I used. What is the Glass that you are working with ?

On Tue, Dec 26, 2017 at 3:46 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1] https://github.com/buddhikajay/jitsi-meet/wiki/Android-A
pp-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < >>> buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < >>>> scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >>>>> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":
"user"}],"facingMode":"user","width":{"ideal":1280},"height"
:{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.androi
d.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.
android.bundle:459:15179\nindex.android.bundle:459:15428\nin
dex.android.bundle:448:1233\nvalue@index.android.bundle:
79:3019\nindex.android.bundle:79:1362\nindex.android.bundle:
79:106\nvalue@index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is
there any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around
in react-native-webrtc: https://github.com/oney/react-native-webrtc
since we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#8

Hi Buddhika,

Thanks for your repo.

Unfortunately, Jitsi Android SDK requires minSdkVersion 16 [1], but our
Vuzix M100 is Android 4.0, SDK version 15.

[1] https://github.com/jitsi/jitsi-meet/blob/master/android/build.gradle

Best Regards,

Nam Vu

···

On Tue, Dec 26, 2017 at 8:28 PM, Buddhika Jayawardhana < buddhika.anushka@gmail.com> wrote:

Hi Nam,

Please use this maven repo on your android application :
https://github.com/meetrix/jitsi-maven-repository/tree/smart-maven. Let
me know if it works. Worked with Vuzix M300.

- BR

On Tue, Dec 26, 2017 at 4:13 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika,

I am working with Vuzix M100, could you please share more information
about your maven repository or your custom app?

Thanks

Nam Vu

On Tue, Dec 26, 2017 at 5:37 PM, Buddhika Jayawardhana < >> buddhika.anushka@gmail.com> wrote:

Hi Nam,

Yes, I had to make some changes in libjitsi meet, then build the Jitsi
Meet SDK with it. Then published it as maven repository. That repo was used
to build custom app to smart glass. It worked for the particular smart
glass that I used. What is the Glass that you are working with ?

On Tue, Dec 26, 2017 at 3:46 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1] https://github.com/buddhikajay/jitsi-meet/wiki/Android-A
pp-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < >>>> buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < >>>>> scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >>>>>> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for a
Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed to
create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":
"user"}],"facingMode":"user","width":{"ideal":1280},"height"
:{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.androi
d.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.
android.bundle:459:15179\nindex.android.bundle:459:15428\nin
dex.android.bundle:448:1233\nvalue@index.android.bundle:79:
3019\nindex.android.bundle:79:1362\nindex.android.bundle:79:
106\nvalue@index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is
there any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack around
in react-native-webrtc: https://github.com/oney/react-native-webrtc
since we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#9

Okay. Currently I do not have a solution fo rhat

···

On Thu, Dec 28, 2017 at 12:14 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika,

Thanks for your repo.

Unfortunately, Jitsi Android SDK requires minSdkVersion 16 [1], but our
Vuzix M100 is Android 4.0, SDK version 15.

[1] https://github.com/jitsi/jitsi-meet/blob/master/android/build.gradle

Best Regards,

Nam Vu

On Tue, Dec 26, 2017 at 8:28 PM, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:

Hi Nam,

Please use this maven repo on your android application :
https://github.com/meetrix/jitsi-maven-repository/tree/smart-maven. Let
me know if it works. Worked with Vuzix M300.

- BR

On Tue, Dec 26, 2017 at 4:13 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika,

I am working with Vuzix M100, could you please share more information
about your maven repository or your custom app?

Thanks

Nam Vu

On Tue, Dec 26, 2017 at 5:37 PM, Buddhika Jayawardhana < >>> buddhika.anushka@gmail.com> wrote:

Hi Nam,

Yes, I had to make some changes in libjitsi meet, then build the Jitsi
Meet SDK with it. Then published it as maven repository. That repo was used
to build custom app to smart glass. It worked for the particular smart
glass that I used. What is the Glass that you are working with ?

On Tue, Dec 26, 2017 at 3:46 PM, Nam Vu <zuzoovn@gmail.com> wrote:

Hi Buddhika

Can you find the solution with smart glasses [1]?

[1] https://github.com/buddhikajay/jitsi-meet/wiki/Android-A
pp-Not-Working-on-Smart-Glasses

Regards,

Nam Vu

On Mon, Oct 30, 2017 at 10:46 PM, Buddhika Jayawardhana < >>>>> buddhika.anushka@gmail.com> wrote:

Thanks for the quick reply. I will try and let you know.

On Mon, Oct 30, 2017 at 6:28 PM, Saúl Ibarra Corretgé < >>>>>> scorretge@atlassian.com> wrote:

> On Oct 30, 2017, at 13:21, Buddhika Jayawardhana < >>>>>>> buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I am using jitsi meet sdk for android to build an application for
a Smart Glass (Vuzix M300). The app joins a room without any issue when I
test it on a Android Phone. But when I try it on the Smart Glass I get the
following error.
>
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed
to create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"
>
> [5:49]
> E/unknown:React: console.error: "[__filename]", "<l>: ", "Failed
to create local tracks", ["video"], {"gum":{"error":{"name":null,"message":"Failed
to create new track"},"constraints":{"audio"
:false,"video":{"mandatory":{"minWidth":1280,"minHeight":720
,"maxWidth":1280,"maxHeight":720},"optional":[{"facingMode":
"user"}],"facingMode":"user","width":{"ideal":1280},"height"
:{"ideal":720}}},"devices":["video"]},"name":"gum.general","message":"Failed
to create new track","stack":"r@index.androi
d.bundle:455:24407\nindex.android.bundle:459:35694\nh@index.
android.bundle:459:15179\nindex.android.bundle:459:15428\nin
dex.android.bundle:448:1233\nvalue@index.android.bundle:79:3
019\nindex.android.bundle:79:1362\nindex.android.bundle:79:1
06\nvalue@index.android.bundle:79:1332\n[native code]"}
>
>
> I suspect that the minimum video resolutions case the problem. Is
there any tips to track down the issue ?
>

If the camera resolution is the problem, you will need to hack
around in react-native-webrtc: https://github.com/oney/react-
native-webrtc since we default to 720p.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>