[jitsi-dev] Upgrading Jitsi's Pootle server


#1

Hi,

Just to introduce myself, I am Dwayne from Translate, the makers of Pootle.
I have noticed that you are currently using an old version of Pootle at
http://translate.jitsi.org/

Pootle 2.8 is about to be released and we would like to chat about what we
can offer at Translate to help you migrate to the new version of Pootle
which is faster and more secure.

···

--
Dwayne

*Translate*
+27 12 460 1095 (work)


#2

Just to introduce myself, I am Dwayne from Translate, the makers of
Pootle. I have noticed that you are currently using an old version of
Pootle at http://translate.jitsi.org/

This Pootle instance is still at 2.5 RC1 and a migration will be a lot of work. Both maintained projects are using custom hooks to generate the output files (.properties for Jitsi and .json for jitsi-meet). These hooks were a native feature before 2.5 and were dropped (or at least crippled to be unusable) in RC1. So, in order to make an upgrade for us feasible these hooks need to be back.

We wouldn't need one set of hooks anymore if we could change the project type to .properties, however the UI doesn't allow that.

Also, it was a PITA to upgrade from 2.1 to 2.5 regardless of necessary patches to support the hook again. Now reading the upgrade notes it will again be a lot of work because there's no proper upgrade path (installing intermediate version, additional servers, etc.).

Pootle 2.8 is about to be released and we would like to chat about what we
can offer at Translate to help you migrate to the new version of Pootle which
is faster and more secure.

Great. How about making upgrades easier and possible from any version to the latest?

Ingo