[jitsi-dev] unsupported JNI version


#1

Hi,

I think I had this same message in jitsi 1.1 and I'm seeing it again in the latest 2.1. It's not important to me but I'd like to know why it's occurring. Is it because I may have an "old" MSOffice software installation (Outlook 2003)?

ERROR: Bundle [73] Error starting reference:file:sc-bundles/plugin-msofficecomm.jar (org.osgi.framework.BundleException: Activator start error in bundle [73].)
java.lang.UnsatisfiedLinkError: unsupported JNI version 0xFFFFFFFF required by C:\Users\vieri\Documents\jitsi\devel\jitsi-src-2.1.4521.10591\jitsi\lib\native\windows\jmsofficecomm.dll
  at java.lang.ClassLoader$NativeLibrary.load(Native Method)
  at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1939)
  at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1864)
  at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
  at java.lang.Runtime.loadLibrary0(Runtime.java:845)
  at java.lang.System.loadLibrary(System.java:1084)
  at net.java.sip.communicator.plugin.msofficecomm.Messenger.<clinit>(Messenger.java:159)
  at net.java.sip.communicator.plugin.msofficecomm.MsOfficeCommActivator.start(MsOfficeCommActivator.java:36)
  at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:629)
  at org.apache.felix.framework.Felix.activateBundle(Felix.java:1904)
  at org.apache.felix.framework.Felix.startBundle(Felix.java:1822)
  at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  at java.lang.Thread.run(Thread.java:722)

Thanks,

Vieri


#2

We never targeted and/or tested 2003. That said, I also get it with
Outlook 2013. We will have to investigate in order to find an answer.
.


#3

It will likely not work with 2003 because the API we used was documented as
2007+. Apart from that, Jitsu has to be installed by the setup and your
path suggests that you may be running from source.