[jitsi-dev] unstable debian package missing jitsi-meet?


#1

Hi all,

I just did a purge of my old (debian 8) installation and tried to install
everything from scratch using the debian package manager and the unstable
repo.

The installation goes without problems but I never get prompted for the
FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo folders
but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package in
unstable working rather well a few weeks ago.

Cheers,
Peter


#2

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install jitsi-meet.
And I did a proper purge beforehand and even manually deleted any leftovers
from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

···

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to install
everything from scratch using the debian package manager and the unstable
repo.

The installation goes without problems but I never get prompted for the
FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo folders
but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package in
unstable working rather well a few weeks ago.

Cheers,
Peter


#3

Hi,

Sorry to hear you have a problem. We recently updated the debian packaging
of all of the packages. Maybe you are hitting a problem caused by this
changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only in
unstable, stable is still with old packages.
What you can try after purging and before installing check the output of
these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was
not clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems we
discover.

Thanks
damencho

···

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install jitsi-meet.
And I did a proper purge beforehand and even manually deleted any leftovers
from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to install
everything from scratch using the debian package manager and the unstable
repo.

The installation goes without problems but I never get prompted for the
FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo folders
but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package in
unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged
(is there any info on these new packages? It seems they are destined for
those running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did ask
for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this is
the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the latest
and greatest. The error seems to be in reference to a missing config option
somewhere.

Cheers,
Peter

···

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian packaging
of all of the packages. Maybe you are hitting a problem caused by this
changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only in
unstable, stable is still with old packages.
What you can try after purging and before installing check the output of
these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was
not clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems we
discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install jitsi-meet.
And I did a proper purge beforehand and even manually deleted any leftovers
from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for the
FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package in
unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

More info.

It seems the scripts in the unstable repo are buggy. I see lots of
authentication failures in jicofo.log, and looking at the prosody config I
see that the component_secrets are set to "ok".
Is this some new Prosody feature to hide the passwords or is this a bug?

Component "conference.meet.my.domain" "muc"
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.meet.my.domain" }

Component "jitsi-videobridge.meet.my.domain"
    component_secret = "ok"

VirtualHost "auth.meet.my.domain"
    authentication = "internal_plain"

Component "focus.meet.my.domainl"
    component_secret = "ok"

Cheers,
Peter

···

On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged
(is there any info on these new packages? It seems they are destined for
those running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did ask
for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this
is the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the latest
and greatest. The error seems to be in reference to a missing config option
somewhere.

Cheers,
Peter

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian
packaging of all of the packages. Maybe you are hitting a problem caused by
this changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only
in unstable, stable is still with old packages.
What you can try after purging and before installing check the output of
these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was
not clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems we
discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install
jitsi-meet. And I did a proper purge beforehand and even manually deleted
any leftovers from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for the
FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package in
unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hum,

Something seems really wrong, normally those password are auto generated
and they should not look like this. Did you try the commands before
installing, I've wrote about? Do they show something before installing?

Regards
damencho

···

On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

More info.

It seems the scripts in the unstable repo are buggy. I see lots of
authentication failures in jicofo.log, and looking at the prosody config I
see that the component_secrets are set to "ok".
Is this some new Prosody feature to hide the passwords or is this a bug?

Component "conference.meet.my.domain" "muc"
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.meet.my.domain" }

Component "jitsi-videobridge.meet.my.domain"
    component_secret = "ok"

VirtualHost "auth.meet.my.domain"
    authentication = "internal_plain"

Component "focus.meet.my.domainl"
    component_secret = "ok"

Cheers,
Peter

On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged
(is there any info on these new packages? It seems they are destined for
those running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did
ask for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this
is the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the
latest and greatest. The error seems to be in reference to a missing config
option somewhere.

Cheers,
Peter

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian
packaging of all of the packages. Maybe you are hitting a problem caused by
this changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only
in unstable, stable is still with old packages.
What you can try after purging and before installing check the output of
these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was
not clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems
we discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install
jitsi-meet. And I did a proper purge beforehand and even manually deleted
any leftovers from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >>>> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for
the FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package
in unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Yup. Tried the commands and nothing was there

···

On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hum,

Something seems really wrong, normally those password are auto generated
and they should not look like this. Did you try the commands before
installing, I've wrote about? Do they show something before installing?

Regards
damencho

On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

More info.

It seems the scripts in the unstable repo are buggy. I see lots of
authentication failures in jicofo.log, and looking at the prosody config I
see that the component_secrets are set to "ok".
Is this some new Prosody feature to hide the passwords or is this a bug?

Component "conference.meet.my.domain" "muc"
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.meet.my.domain" }

Component "jitsi-videobridge.meet.my.domain"
    component_secret = "ok"

VirtualHost "auth.meet.my.domain"
    authentication = "internal_plain"

Component "focus.meet.my.domainl"
    component_secret = "ok"

Cheers,
Peter

On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged
(is there any info on these new packages? It seems they are destined for
those running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did
ask for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this
is the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the
latest and greatest. The error seems to be in reference to a missing config
option somewhere.

Cheers,
Peter

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian
packaging of all of the packages. Maybe you are hitting a problem caused by
this changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only
in unstable, stable is still with old packages.
What you can try after purging and before installing check the output
of these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was
not clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems
we discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> >>>> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install
jitsi-meet. And I did a proper purge beforehand and even manually deleted
any leftovers from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for
the FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package
in unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi again,
I just tried it on new vm with latest debian8 (what digital ocean
provides...) and here the java defaults to java7 and also I think
there is some problems with the debconf and reusing those values
between packages ... I was not seeing those when testing under ubuntu.
I think I see the problem you are facing, I will be checking it
tomorrow to see what is the actual fail and try fixing it.
If you want to use jetty to serve meet, you need to install
openjdk-8-jre-headless before installing jitsi-meet.

Thanks
damencho

···

On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Yup. Tried the commands and nothing was there

On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hum,

Something seems really wrong, normally those password are auto generated
and they should not look like this. Did you try the commands before
installing, I've wrote about? Do they show something before installing?

Regards
damencho

On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

More info.

It seems the scripts in the unstable repo are buggy. I see lots of
authentication failures in jicofo.log, and looking at the prosody config I
see that the component_secrets are set to "ok".
Is this some new Prosody feature to hide the passwords or is this a bug?

Component "conference.meet.my.domain" "muc"
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.meet.my.domain" }

Component "jitsi-videobridge.meet.my.domain"
    component_secret = "ok"

VirtualHost "auth.meet.my.domain"
    authentication = "internal_plain"

Component "focus.meet.my.domainl"
    component_secret = "ok"

Cheers,
Peter

On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged (is
there any info on these new packages? It seems they are destined for those
running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did
ask for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this
is the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the
latest and greatest. The error seems to be in reference to a missing config
option somewhere.

Cheers,
Peter

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>>> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian
packaging of all of the packages. Maybe you are hitting a problem caused by
this changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only
in unstable, stable is still with old packages.
What you can try after purging and before installing check the output
of these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was not
clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems
we discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> >>>>> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install
jitsi-meet. And I did a proper purge beforehand and even manually deleted
any leftovers from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>>> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for
the FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package
in unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

···

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi again,
I just tried it on new vm with latest debian8 (what digital ocean
provides...) and here the java defaults to java7 and also I think
there is some problems with the debconf and reusing those values
between packages ... I was not seeing those when testing under ubuntu.
I think I see the problem you are facing, I will be checking it
tomorrow to see what is the actual fail and try fixing it.
If you want to use jetty to serve meet, you need to install
openjdk-8-jre-headless before installing jitsi-meet.

Thanks
damencho

On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Yup. Tried the commands and nothing was there

On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hum,

Something seems really wrong, normally those password are auto generated
and they should not look like this. Did you try the commands before
installing, I've wrote about? Do they show something before installing?

Regards
damencho

On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:

More info.

It seems the scripts in the unstable repo are buggy. I see lots of
authentication failures in jicofo.log, and looking at the prosody config I
see that the component_secrets are set to "ok".
Is this some new Prosody feature to hide the passwords or is this a bug?

Component "conference.meet.my.domain" "muc"
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.meet.my.domain" }

Component "jitsi-videobridge.meet.my.domain"
    component_secret = "ok"

VirtualHost "auth.meet.my.domain"
    authentication = "internal_plain"

Component "focus.meet.my.domainl"
    component_secret = "ok"

Cheers,
Peter

On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com> >>>> wrote:

Indeed I think the problem was left over jitsi stuff from the
jitsi-meet-web-config package. I purged everything again and made sure
iitsi-meet-web-config and jitsi-meet-web packages were completely purged (is
there any info on these new packages? It seems they are destined for those
running apache or nginx, correct? In my case I'm only using Jetty.

I then tried a clean install using the unstable repo. This time it did
ask for the FQDN for the jvb and it also asked me for passwords for the
component secrets.
I did all that but when trying to open it I get a blank screen, and this
is the error thrown in the Chrome console.

app.bundle.min.js?v=1548:53 Uncaught ReferenceError: loggingConfig is
not defined

I haven't tried with stable repo yet since I'm eager to try out the
latest and greatest. The error seems to be in reference to a missing config
option somewhere.

Cheers,
Peter

On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>>>> wrote:

Hi,

Sorry to hear you have a problem. We recently updated the debian
packaging of all of the packages. Maybe you are hitting a problem caused by
this changes. I will take a look.
The strange thing is that the changes I'm mentioning are currently only
in unstable, stable is still with old packages.
What you can try after purging and before installing check the output
of these commands:
debconf-get-selections | grep jitsi
debconf-get-selections | grep jicofo
They should not have any output, you can try installing everything from
unstable and purge it. There was a bug in older versions and purging was not
clearing everything, but I think we fixed it in the newer versions of
packages.
Report how it goes, so we can eventually debug it and fix any problems
we discover.

Thanks
damencho

On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve <petervnv1@gmail.com> >>>>>> wrote:

Hmmm,

Just tried with the debian stable repo and am getting the same strange
behaviour I reported with unstable.
No errors during package installation with apt-get -y install
jitsi-meet. And I did a proper purge beforehand and even manually deleted
any leftovers from previous installs.

Yet the post-install script never runs and there is no meet folder in
/etc/jitsi.....

Anyone else experiencing this behaviour?

Cheers,
Peter

On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>>>> wrote:

Hi all,

I just did a purge of my old (debian 8) installation and tried to
install everything from scratch using the debian package manager and the
unstable repo.

The installation goes without problems but I never get prompted for
the FQDN of jitsi-meet like before.

Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
folders but there's no longer a meet folder created.

Is this a recently introduced bug? I remember the jitsi-meet package
in unstable working rather well a few weeks ago.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi Damian,

Thanks for your help.

I purged everything thoroughly and went back to stable and all is working
now.

Let me know when you've figured out the bugs with unstable as I'd like to
test it out too.

Cheers,
Peter

···

On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> wrote:

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi again,
> I just tried it on new vm with latest debian8 (what digital ocean
> provides...) and here the java defaults to java7 and also I think
> there is some problems with the debconf and reusing those values
> between packages ... I was not seeing those when testing under ubuntu.
> I think I see the problem you are facing, I will be checking it
> tomorrow to see what is the actual fail and try fixing it.
> If you want to use jetty to serve meet, you need to install
> openjdk-8-jre-headless before installing jitsi-meet.
>
> Thanks
> damencho
>
>
> On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
>> Yup. Tried the commands and nothing was there
>>
>> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>>
>>> Hum,
>>>
>>> Something seems really wrong, normally those password are auto
generated
>>> and they should not look like this. Did you try the commands before
>>> installing, I've wrote about? Do they show something before installing?
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve <petervnv1@gmail.com > > > >>> wrote:
>>>>
>>>> More info.
>>>>
>>>> It seems the scripts in the unstable repo are buggy. I see lots of
>>>> authentication failures in jicofo.log, and looking at the prosody
config I
>>>> see that the component_secrets are set to "ok".
>>>> Is this some new Prosody feature to hide the passwords or is this a
bug?
>>>>
>>>>
>>>> Component "conference.meet.my.domain" "muc"
>>>> --modules_enabled = { "token_verification" }
>>>> admins = { "focus@auth.meet.my.domain" }
>>>>
>>>> Component "jitsi-videobridge.meet.my.domain"
>>>> component_secret = "ok"
>>>>
>>>> VirtualHost "auth.meet.my.domain"
>>>> authentication = "internal_plain"
>>>>
>>>> Component "focus.meet.my.domainl"
>>>> component_secret = "ok"
>>>>
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve <petervnv1@gmail.com > > > >>>> wrote:
>>>>>
>>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> jitsi-meet-web-config package. I purged everything again and made
sure
>>>>> iitsi-meet-web-config and jitsi-meet-web packages were completely
purged (is
>>>>> there any info on these new packages? It seems they are destined for
those
>>>>> running apache or nginx, correct? In my case I'm only using Jetty.
>>>>>
>>>>> I then tried a clean install using the unstable repo. This time it
did
>>>>> ask for the FQDN for the jvb and it also asked me for passwords for
the
>>>>> component secrets.
>>>>> I did all that but when trying to open it I get a blank screen, and
this
>>>>> is the error thrown in the Chrome console.
>>>>>
>>>>>
>>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
loggingConfig is
>>>>> not defined
>>>>>
>>>>> I haven't tried with stable repo yet since I'm eager to try out the
>>>>> latest and greatest. The error seems to be in reference to a missing
config
>>>>> option somewhere.
>>>>>
>>>>>
>>>>> Cheers,
>>>>> Peter
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> > >>>>> wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Sorry to hear you have a problem. We recently updated the debian
>>>>>> packaging of all of the packages. Maybe you are hitting a problem
caused by
>>>>>> this changes. I will take a look.
>>>>>> The strange thing is that the changes I'm mentioning are currently
only
>>>>>> in unstable, stable is still with old packages.
>>>>>> What you can try after purging and before installing check the
output
>>>>>> of these commands:
>>>>>> debconf-get-selections | grep jitsi
>>>>>> debconf-get-selections | grep jicofo
>>>>>> They should not have any output, you can try installing everything
from
>>>>>> unstable and purge it. There was a bug in older versions and
purging was not
>>>>>> clearing everything, but I think we fixed it in the newer versions
of
>>>>>> packages.
>>>>>> Report how it goes, so we can eventually debug it and fix any
problems
>>>>>> we discover.
>>>>>>
>>>>>> Thanks
>>>>>> damencho
>>>>>>
>>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve < > petervnv1@gmail.com> > >>>>>> wrote:
>>>>>>>
>>>>>>> Hmmm,
>>>>>>>
>>>>>>> Just tried with the debian stable repo and am getting the same
strange
>>>>>>> behaviour I reported with unstable.
>>>>>>> No errors during package installation with apt-get -y install
>>>>>>> jitsi-meet. And I did a proper purge beforehand and even manually
deleted
>>>>>>> any leftovers from previous installs.
>>>>>>>
>>>>>>> Yet the post-install script never runs and there is no meet folder
in
>>>>>>> /etc/jitsi.....
>>>>>>>
>>>>>>> Anyone else experiencing this behaviour?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Peter
>>>>>>>
>>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve < > petervnv1@gmail.com> > >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> I just did a purge of my old (debian 8) installation and tried to
>>>>>>>> install everything from scratch using the debian package manager
and the
>>>>>>>> unstable repo.
>>>>>>>>
>>>>>>>> The installation goes without problems but I never get prompted
for
>>>>>>>> the FQDN of jitsi-meet like before.
>>>>>>>>
>>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
>>>>>>>> folders but there's no longer a meet folder created.
>>>>>>>>
>>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
package
>>>>>>>> in unstable working rather well a few weeks ago.
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Peter
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> dev mailing list
>>>>>>> dev@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> dev mailing list
>>>>>> dev@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Hi,

So today I purged everything that I've installed from stable. And then
installed in this order:
apt-get install jitsi-videobridge
apt-get install jicofo
apt-get install jitsi-meet
And it was fine. I purged it again and just did apt-get install
jitsi-meet and again it was fine.
I have the impression that initially when I've installed it on clean
machine the order was not that.
The order is important and it should be jvb, jicofo, meet
(https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12).
This is the order in the Depends in the jitsi-meet meta package.
I will delete my vm and will try this one again and see whether and
why the order is not kept.
In other words, if it is not working for you currently, purging and
installing with those 3 commands from unstable is a simple workaround.

Regards
damencho

···

On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi Damian,

Thanks for your help.

I purged everything thoroughly and went back to stable and all is working
now.

Let me know when you've figured out the bugs with unstable as I'd like to
test it out too.

Cheers,
Peter

On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> wrote:

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi again,
> I just tried it on new vm with latest debian8 (what digital ocean
> provides...) and here the java defaults to java7 and also I think
> there is some problems with the debconf and reusing those values
> between packages ... I was not seeing those when testing under ubuntu.
> I think I see the problem you are facing, I will be checking it
> tomorrow to see what is the actual fail and try fixing it.
> If you want to use jetty to serve meet, you need to install
> openjdk-8-jre-headless before installing jitsi-meet.
>
> Thanks
> damencho
>
>
> On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> >> > wrote:
>> Yup. Tried the commands and nothing was there
>>
>> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> >> >> wrote:
>>>
>>> Hum,
>>>
>>> Something seems really wrong, normally those password are auto
>>> generated
>>> and they should not look like this. Did you try the commands before
>>> installing, I've wrote about? Do they show something before
>>> installing?
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve >> >>> <petervnv1@gmail.com> >> >>> wrote:
>>>>
>>>> More info.
>>>>
>>>> It seems the scripts in the unstable repo are buggy. I see lots of
>>>> authentication failures in jicofo.log, and looking at the prosody
>>>> config I
>>>> see that the component_secrets are set to "ok".
>>>> Is this some new Prosody feature to hide the passwords or is this a
>>>> bug?
>>>>
>>>>
>>>> Component "conference.meet.my.domain" "muc"
>>>> --modules_enabled = { "token_verification" }
>>>> admins = { "focus@auth.meet.my.domain" }
>>>>
>>>> Component "jitsi-videobridge.meet.my.domain"
>>>> component_secret = "ok"
>>>>
>>>> VirtualHost "auth.meet.my.domain"
>>>> authentication = "internal_plain"
>>>>
>>>> Component "focus.meet.my.domainl"
>>>> component_secret = "ok"
>>>>
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve >> >>>> <petervnv1@gmail.com> >> >>>> wrote:
>>>>>
>>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> jitsi-meet-web-config package. I purged everything again and made
>>>>> sure
>>>>> iitsi-meet-web-config and jitsi-meet-web packages were completely
>>>>> purged (is
>>>>> there any info on these new packages? It seems they are destined for
>>>>> those
>>>>> running apache or nginx, correct? In my case I'm only using Jetty.
>>>>>
>>>>> I then tried a clean install using the unstable repo. This time it
>>>>> did
>>>>> ask for the FQDN for the jvb and it also asked me for passwords for
>>>>> the
>>>>> component secrets.
>>>>> I did all that but when trying to open it I get a blank screen, and
>>>>> this
>>>>> is the error thrown in the Chrome console.
>>>>>
>>>>>
>>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> loggingConfig is
>>>>> not defined
>>>>>
>>>>> I haven't tried with stable repo yet since I'm eager to try out the
>>>>> latest and greatest. The error seems to be in reference to a missing
>>>>> config
>>>>> option somewhere.
>>>>>
>>>>>
>>>>> Cheers,
>>>>> Peter
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >> >>>>> wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Sorry to hear you have a problem. We recently updated the debian
>>>>>> packaging of all of the packages. Maybe you are hitting a problem
>>>>>> caused by
>>>>>> this changes. I will take a look.
>>>>>> The strange thing is that the changes I'm mentioning are currently
>>>>>> only
>>>>>> in unstable, stable is still with old packages.
>>>>>> What you can try after purging and before installing check the
>>>>>> output
>>>>>> of these commands:
>>>>>> debconf-get-selections | grep jitsi
>>>>>> debconf-get-selections | grep jicofo
>>>>>> They should not have any output, you can try installing everything
>>>>>> from
>>>>>> unstable and purge it. There was a bug in older versions and
>>>>>> purging was not
>>>>>> clearing everything, but I think we fixed it in the newer versions
>>>>>> of
>>>>>> packages.
>>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>>> problems
>>>>>> we discover.
>>>>>>
>>>>>> Thanks
>>>>>> damencho
>>>>>>
>>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve >> >>>>>> <petervnv1@gmail.com> >> >>>>>> wrote:
>>>>>>>
>>>>>>> Hmmm,
>>>>>>>
>>>>>>> Just tried with the debian stable repo and am getting the same
>>>>>>> strange
>>>>>>> behaviour I reported with unstable.
>>>>>>> No errors during package installation with apt-get -y install
>>>>>>> jitsi-meet. And I did a proper purge beforehand and even manually
>>>>>>> deleted
>>>>>>> any leftovers from previous installs.
>>>>>>>
>>>>>>> Yet the post-install script never runs and there is no meet folder
>>>>>>> in
>>>>>>> /etc/jitsi.....
>>>>>>>
>>>>>>> Anyone else experiencing this behaviour?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Peter
>>>>>>>
>>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve >> >>>>>>> <petervnv1@gmail.com> >> >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> I just did a purge of my old (debian 8) installation and tried to
>>>>>>>> install everything from scratch using the debian package manager
>>>>>>>> and the
>>>>>>>> unstable repo.
>>>>>>>>
>>>>>>>> The installation goes without problems but I never get prompted
>>>>>>>> for
>>>>>>>> the FQDN of jitsi-meet like before.
>>>>>>>>
>>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
>>>>>>>> folders but there's no longer a meet folder created.
>>>>>>>>
>>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
>>>>>>>> package
>>>>>>>> in unstable working rather well a few weeks ago.
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Peter
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> dev mailing list
>>>>>>> dev@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> dev mailing list
>>>>>> dev@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Yep, I just confirmed it, the problem is the re-ordering
Setting up jitsi-meet-web (1.0.1555-1) ...
Setting up nginx-common (1.6.2-5+deb8u4) ...
Setting up nginx-full (1.6.2-5+deb8u4) ...
Setting up nginx (1.6.2-5+deb8u4) ...
Setting up jitsi-meet-web-config (1.0.1555-1) ...
Setting up jitsi-meet-prosody (1.0.1555-1) ...
Setting up jitsi-videobridge (852-1) ...
Setting up jicofo (1.0-316-1) ...
Setting up jitsi-meet (1.0.1557-1) ...

Need to think of it, why it acts like that. If there is a Debian guru
on the list and give a hand with this problem, that will be awesome.

···

On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

So today I purged everything that I've installed from stable. And then
installed in this order:
apt-get install jitsi-videobridge
apt-get install jicofo
apt-get install jitsi-meet
And it was fine. I purged it again and just did apt-get install
jitsi-meet and again it was fine.
I have the impression that initially when I've installed it on clean
machine the order was not that.
The order is important and it should be jvb, jicofo, meet
(https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12).
This is the order in the Depends in the jitsi-meet meta package.
I will delete my vm and will try this one again and see whether and
why the order is not kept.
In other words, if it is not working for you currently, purging and
installing with those 3 commands from unstable is a simple workaround.

Regards
damencho

On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi Damian,

Thanks for your help.

I purged everything thoroughly and went back to stable and all is working
now.

Let me know when you've figured out the bugs with unstable as I'd like to
test it out too.

Cheers,
Peter

On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> wrote:

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi again,
> I just tried it on new vm with latest debian8 (what digital ocean
> provides...) and here the java defaults to java7 and also I think
> there is some problems with the debconf and reusing those values
> between packages ... I was not seeing those when testing under ubuntu.
> I think I see the problem you are facing, I will be checking it
> tomorrow to see what is the actual fail and try fixing it.
> If you want to use jetty to serve meet, you need to install
> openjdk-8-jre-headless before installing jitsi-meet.
>
> Thanks
> damencho
>
>
> On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> >>> > wrote:
>> Yup. Tried the commands and nothing was there
>>
>> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> >>> >> wrote:
>>>
>>> Hum,
>>>
>>> Something seems really wrong, normally those password are auto
>>> generated
>>> and they should not look like this. Did you try the commands before
>>> installing, I've wrote about? Do they show something before
>>> installing?
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve >>> >>> <petervnv1@gmail.com> >>> >>> wrote:
>>>>
>>>> More info.
>>>>
>>>> It seems the scripts in the unstable repo are buggy. I see lots of
>>>> authentication failures in jicofo.log, and looking at the prosody
>>>> config I
>>>> see that the component_secrets are set to "ok".
>>>> Is this some new Prosody feature to hide the passwords or is this a
>>>> bug?
>>>>
>>>>
>>>> Component "conference.meet.my.domain" "muc"
>>>> --modules_enabled = { "token_verification" }
>>>> admins = { "focus@auth.meet.my.domain" }
>>>>
>>>> Component "jitsi-videobridge.meet.my.domain"
>>>> component_secret = "ok"
>>>>
>>>> VirtualHost "auth.meet.my.domain"
>>>> authentication = "internal_plain"
>>>>
>>>> Component "focus.meet.my.domainl"
>>>> component_secret = "ok"
>>>>
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve >>> >>>> <petervnv1@gmail.com> >>> >>>> wrote:
>>>>>
>>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> jitsi-meet-web-config package. I purged everything again and made
>>>>> sure
>>>>> iitsi-meet-web-config and jitsi-meet-web packages were completely
>>>>> purged (is
>>>>> there any info on these new packages? It seems they are destined for
>>>>> those
>>>>> running apache or nginx, correct? In my case I'm only using Jetty.
>>>>>
>>>>> I then tried a clean install using the unstable repo. This time it
>>>>> did
>>>>> ask for the FQDN for the jvb and it also asked me for passwords for
>>>>> the
>>>>> component secrets.
>>>>> I did all that but when trying to open it I get a blank screen, and
>>>>> this
>>>>> is the error thrown in the Chrome console.
>>>>>
>>>>>
>>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> loggingConfig is
>>>>> not defined
>>>>>
>>>>> I haven't tried with stable repo yet since I'm eager to try out the
>>>>> latest and greatest. The error seems to be in reference to a missing
>>>>> config
>>>>> option somewhere.
>>>>>
>>>>>
>>>>> Cheers,
>>>>> Peter
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>> >>>>> wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Sorry to hear you have a problem. We recently updated the debian
>>>>>> packaging of all of the packages. Maybe you are hitting a problem
>>>>>> caused by
>>>>>> this changes. I will take a look.
>>>>>> The strange thing is that the changes I'm mentioning are currently
>>>>>> only
>>>>>> in unstable, stable is still with old packages.
>>>>>> What you can try after purging and before installing check the
>>>>>> output
>>>>>> of these commands:
>>>>>> debconf-get-selections | grep jitsi
>>>>>> debconf-get-selections | grep jicofo
>>>>>> They should not have any output, you can try installing everything
>>>>>> from
>>>>>> unstable and purge it. There was a bug in older versions and
>>>>>> purging was not
>>>>>> clearing everything, but I think we fixed it in the newer versions
>>>>>> of
>>>>>> packages.
>>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>>> problems
>>>>>> we discover.
>>>>>>
>>>>>> Thanks
>>>>>> damencho
>>>>>>
>>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve >>> >>>>>> <petervnv1@gmail.com> >>> >>>>>> wrote:
>>>>>>>
>>>>>>> Hmmm,
>>>>>>>
>>>>>>> Just tried with the debian stable repo and am getting the same
>>>>>>> strange
>>>>>>> behaviour I reported with unstable.
>>>>>>> No errors during package installation with apt-get -y install
>>>>>>> jitsi-meet. And I did a proper purge beforehand and even manually
>>>>>>> deleted
>>>>>>> any leftovers from previous installs.
>>>>>>>
>>>>>>> Yet the post-install script never runs and there is no meet folder
>>>>>>> in
>>>>>>> /etc/jitsi.....
>>>>>>>
>>>>>>> Anyone else experiencing this behaviour?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Peter
>>>>>>>
>>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve >>> >>>>>>> <petervnv1@gmail.com> >>> >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> I just did a purge of my old (debian 8) installation and tried to
>>>>>>>> install everything from scratch using the debian package manager
>>>>>>>> and the
>>>>>>>> unstable repo.
>>>>>>>>
>>>>>>>> The installation goes without problems but I never get prompted
>>>>>>>> for
>>>>>>>> the FQDN of jitsi-meet like before.
>>>>>>>>
>>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
>>>>>>>> folders but there's no longer a meet folder created.
>>>>>>>>
>>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
>>>>>>>> package
>>>>>>>> in unstable working rather well a few weeks ago.
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Peter
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> dev mailing list
>>>>>>> dev@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> dev mailing list
>>>>>> dev@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

The dependency ordering can be broken because of circular dependency,
maybe there is such a problem currently because of jitsi-meet meta
package depending on jitsi-meet-web, jitsi-meet-web-config and
jitsi-meet-prosody. And both jitsi-meet-web-config and
jitsi-meet-prosody depend on jitsi-meet-web.
Will try to eliminate those and see does it fixes the problem.

···

On Tue, Dec 6, 2016 at 6:16 PM, Damian Minkov <damencho@jitsi.org> wrote:

Yep, I just confirmed it, the problem is the re-ordering
Setting up jitsi-meet-web (1.0.1555-1) ...
Setting up nginx-common (1.6.2-5+deb8u4) ...
Setting up nginx-full (1.6.2-5+deb8u4) ...
Setting up nginx (1.6.2-5+deb8u4) ...
Setting up jitsi-meet-web-config (1.0.1555-1) ...
Setting up jitsi-meet-prosody (1.0.1555-1) ...
Setting up jitsi-videobridge (852-1) ...
Setting up jicofo (1.0-316-1) ...
Setting up jitsi-meet (1.0.1557-1) ...

Need to think of it, why it acts like that. If there is a Debian guru
on the list and give a hand with this problem, that will be awesome.

On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

So today I purged everything that I've installed from stable. And then
installed in this order:
apt-get install jitsi-videobridge
apt-get install jicofo
apt-get install jitsi-meet
And it was fine. I purged it again and just did apt-get install
jitsi-meet and again it was fine.
I have the impression that initially when I've installed it on clean
machine the order was not that.
The order is important and it should be jvb, jicofo, meet
(https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12).
This is the order in the Depends in the jitsi-meet meta package.
I will delete my vm and will try this one again and see whether and
why the order is not kept.
In other words, if it is not working for you currently, purging and
installing with those 3 commands from unstable is a simple workaround.

Regards
damencho

On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi Damian,

Thanks for your help.

I purged everything thoroughly and went back to stable and all is working
now.

Let me know when you've figured out the bugs with unstable as I'd like to
test it out too.

Cheers,
Peter

On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> wrote:

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi again,
> I just tried it on new vm with latest debian8 (what digital ocean
> provides...) and here the java defaults to java7 and also I think
> there is some problems with the debconf and reusing those values
> between packages ... I was not seeing those when testing under ubuntu.
> I think I see the problem you are facing, I will be checking it
> tomorrow to see what is the actual fail and try fixing it.
> If you want to use jetty to serve meet, you need to install
> openjdk-8-jre-headless before installing jitsi-meet.
>
> Thanks
> damencho
>
>
> On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> >>>> > wrote:
>> Yup. Tried the commands and nothing was there
>>
>> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> >>>> >> wrote:
>>>
>>> Hum,
>>>
>>> Something seems really wrong, normally those password are auto
>>> generated
>>> and they should not look like this. Did you try the commands before
>>> installing, I've wrote about? Do they show something before
>>> installing?
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve >>>> >>> <petervnv1@gmail.com> >>>> >>> wrote:
>>>>
>>>> More info.
>>>>
>>>> It seems the scripts in the unstable repo are buggy. I see lots of
>>>> authentication failures in jicofo.log, and looking at the prosody
>>>> config I
>>>> see that the component_secrets are set to "ok".
>>>> Is this some new Prosody feature to hide the passwords or is this a
>>>> bug?
>>>>
>>>>
>>>> Component "conference.meet.my.domain" "muc"
>>>> --modules_enabled = { "token_verification" }
>>>> admins = { "focus@auth.meet.my.domain" }
>>>>
>>>> Component "jitsi-videobridge.meet.my.domain"
>>>> component_secret = "ok"
>>>>
>>>> VirtualHost "auth.meet.my.domain"
>>>> authentication = "internal_plain"
>>>>
>>>> Component "focus.meet.my.domainl"
>>>> component_secret = "ok"
>>>>
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve >>>> >>>> <petervnv1@gmail.com> >>>> >>>> wrote:
>>>>>
>>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> jitsi-meet-web-config package. I purged everything again and made
>>>>> sure
>>>>> iitsi-meet-web-config and jitsi-meet-web packages were completely
>>>>> purged (is
>>>>> there any info on these new packages? It seems they are destined for
>>>>> those
>>>>> running apache or nginx, correct? In my case I'm only using Jetty.
>>>>>
>>>>> I then tried a clean install using the unstable repo. This time it
>>>>> did
>>>>> ask for the FQDN for the jvb and it also asked me for passwords for
>>>>> the
>>>>> component secrets.
>>>>> I did all that but when trying to open it I get a blank screen, and
>>>>> this
>>>>> is the error thrown in the Chrome console.
>>>>>
>>>>>
>>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> loggingConfig is
>>>>> not defined
>>>>>
>>>>> I haven't tried with stable repo yet since I'm eager to try out the
>>>>> latest and greatest. The error seems to be in reference to a missing
>>>>> config
>>>>> option somewhere.
>>>>>
>>>>>
>>>>> Cheers,
>>>>> Peter
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>>> >>>>> wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Sorry to hear you have a problem. We recently updated the debian
>>>>>> packaging of all of the packages. Maybe you are hitting a problem
>>>>>> caused by
>>>>>> this changes. I will take a look.
>>>>>> The strange thing is that the changes I'm mentioning are currently
>>>>>> only
>>>>>> in unstable, stable is still with old packages.
>>>>>> What you can try after purging and before installing check the
>>>>>> output
>>>>>> of these commands:
>>>>>> debconf-get-selections | grep jitsi
>>>>>> debconf-get-selections | grep jicofo
>>>>>> They should not have any output, you can try installing everything
>>>>>> from
>>>>>> unstable and purge it. There was a bug in older versions and
>>>>>> purging was not
>>>>>> clearing everything, but I think we fixed it in the newer versions
>>>>>> of
>>>>>> packages.
>>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>>> problems
>>>>>> we discover.
>>>>>>
>>>>>> Thanks
>>>>>> damencho
>>>>>>
>>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve >>>> >>>>>> <petervnv1@gmail.com> >>>> >>>>>> wrote:
>>>>>>>
>>>>>>> Hmmm,
>>>>>>>
>>>>>>> Just tried with the debian stable repo and am getting the same
>>>>>>> strange
>>>>>>> behaviour I reported with unstable.
>>>>>>> No errors during package installation with apt-get -y install
>>>>>>> jitsi-meet. And I did a proper purge beforehand and even manually
>>>>>>> deleted
>>>>>>> any leftovers from previous installs.
>>>>>>>
>>>>>>> Yet the post-install script never runs and there is no meet folder
>>>>>>> in
>>>>>>> /etc/jitsi.....
>>>>>>>
>>>>>>> Anyone else experiencing this behaviour?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Peter
>>>>>>>
>>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve >>>> >>>>>>> <petervnv1@gmail.com> >>>> >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> I just did a purge of my old (debian 8) installation and tried to
>>>>>>>> install everything from scratch using the debian package manager
>>>>>>>> and the
>>>>>>>> unstable repo.
>>>>>>>>
>>>>>>>> The installation goes without problems but I never get prompted
>>>>>>>> for
>>>>>>>> the FQDN of jitsi-meet like before.
>>>>>>>>
>>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
>>>>>>>> folders but there's no longer a meet folder created.
>>>>>>>>
>>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
>>>>>>>> package
>>>>>>>> in unstable working rather well a few weeks ago.
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Peter
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> dev mailing list
>>>>>>> dev@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> dev mailing list
>>>>>> dev@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi again,

It is fixed now.

I didn't manage to identify the actual problem, I was suspecting some
circular dependency, but I didn't found one. I found that if you
install default-jre-headless before installing jitsi-meet, everything
is fine and order of setting up dependencies is kept. And we used to
have that dependency for jvb in pre-depends, so I moved it back there
and now everything is fine, cause default-jre-headless is configured
before the other packages.

Regards
damencho

···

On Tue, Dec 6, 2016 at 6:29 PM, Damian Minkov <damencho@jitsi.org> wrote:

The dependency ordering can be broken because of circular dependency,
maybe there is such a problem currently because of jitsi-meet meta
package depending on jitsi-meet-web, jitsi-meet-web-config and
jitsi-meet-prosody. And both jitsi-meet-web-config and
jitsi-meet-prosody depend on jitsi-meet-web.
Will try to eliminate those and see does it fixes the problem.

On Tue, Dec 6, 2016 at 6:16 PM, Damian Minkov <damencho@jitsi.org> wrote:

Yep, I just confirmed it, the problem is the re-ordering
Setting up jitsi-meet-web (1.0.1555-1) ...
Setting up nginx-common (1.6.2-5+deb8u4) ...
Setting up nginx-full (1.6.2-5+deb8u4) ...
Setting up nginx (1.6.2-5+deb8u4) ...
Setting up jitsi-meet-web-config (1.0.1555-1) ...
Setting up jitsi-meet-prosody (1.0.1555-1) ...
Setting up jitsi-videobridge (852-1) ...
Setting up jicofo (1.0-316-1) ...
Setting up jitsi-meet (1.0.1557-1) ...

Need to think of it, why it acts like that. If there is a Debian guru
on the list and give a hand with this problem, that will be awesome.

On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

So today I purged everything that I've installed from stable. And then
installed in this order:
apt-get install jitsi-videobridge
apt-get install jicofo
apt-get install jitsi-meet
And it was fine. I purged it again and just did apt-get install
jitsi-meet and again it was fine.
I have the impression that initially when I've installed it on clean
machine the order was not that.
The order is important and it should be jvb, jicofo, meet
(https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12).
This is the order in the Depends in the jitsi-meet meta package.
I will delete my vm and will try this one again and see whether and
why the order is not kept.
In other words, if it is not working for you currently, purging and
installing with those 3 commands from unstable is a simple workaround.

Regards
damencho

On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi Damian,

Thanks for your help.

I purged everything thoroughly and went back to stable and all is working
now.

Let me know when you've figured out the bugs with unstable as I'd like to
test it out too.

Cheers,
Peter

On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> wrote:

By the way I did:
   10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
jitsi-meet-web jitsi-meet-web-config
   11 apt-get --purge remove jicofo
   12 apt-get --purge remove jitsi-videobridge
Change to stable
apt-get install jitsi-meet
And everything was fine.

I'll keep you posted with my findings.

Regards
damencho

On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> wrote:
> Hi again,
> I just tried it on new vm with latest debian8 (what digital ocean
> provides...) and here the java defaults to java7 and also I think
> there is some problems with the debconf and reusing those values
> between packages ... I was not seeing those when testing under ubuntu.
> I think I see the problem you are facing, I will be checking it
> tomorrow to see what is the actual fail and try fixing it.
> If you want to use jetty to serve meet, you need to install
> openjdk-8-jre-headless before installing jitsi-meet.
>
> Thanks
> damencho
>
>
> On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>> > wrote:
>> Yup. Tried the commands and nothing was there
>>
>> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org> >>>>> >> wrote:
>>>
>>> Hum,
>>>
>>> Something seems really wrong, normally those password are auto
>>> generated
>>> and they should not look like this. Did you try the commands before
>>> installing, I've wrote about? Do they show something before
>>> installing?
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve >>>>> >>> <petervnv1@gmail.com> >>>>> >>> wrote:
>>>>
>>>> More info.
>>>>
>>>> It seems the scripts in the unstable repo are buggy. I see lots of
>>>> authentication failures in jicofo.log, and looking at the prosody
>>>> config I
>>>> see that the component_secrets are set to "ok".
>>>> Is this some new Prosody feature to hide the passwords or is this a
>>>> bug?
>>>>
>>>>
>>>> Component "conference.meet.my.domain" "muc"
>>>> --modules_enabled = { "token_verification" }
>>>> admins = { "focus@auth.meet.my.domain" }
>>>>
>>>> Component "jitsi-videobridge.meet.my.domain"
>>>> component_secret = "ok"
>>>>
>>>> VirtualHost "auth.meet.my.domain"
>>>> authentication = "internal_plain"
>>>>
>>>> Component "focus.meet.my.domainl"
>>>> component_secret = "ok"
>>>>
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve >>>>> >>>> <petervnv1@gmail.com> >>>>> >>>> wrote:
>>>>>
>>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> jitsi-meet-web-config package. I purged everything again and made
>>>>> sure
>>>>> iitsi-meet-web-config and jitsi-meet-web packages were completely
>>>>> purged (is
>>>>> there any info on these new packages? It seems they are destined for
>>>>> those
>>>>> running apache or nginx, correct? In my case I'm only using Jetty.
>>>>>
>>>>> I then tried a clean install using the unstable repo. This time it
>>>>> did
>>>>> ask for the FQDN for the jvb and it also asked me for passwords for
>>>>> the
>>>>> component secrets.
>>>>> I did all that but when trying to open it I get a blank screen, and
>>>>> this
>>>>> is the error thrown in the Chrome console.
>>>>>
>>>>>
>>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> loggingConfig is
>>>>> not defined
>>>>>
>>>>> I haven't tried with stable repo yet since I'm eager to try out the
>>>>> latest and greatest. The error seems to be in reference to a missing
>>>>> config
>>>>> option somewhere.
>>>>>
>>>>>
>>>>> Cheers,
>>>>> Peter
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov <damencho@jitsi.org> >>>>> >>>>> wrote:
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Sorry to hear you have a problem. We recently updated the debian
>>>>>> packaging of all of the packages. Maybe you are hitting a problem
>>>>>> caused by
>>>>>> this changes. I will take a look.
>>>>>> The strange thing is that the changes I'm mentioning are currently
>>>>>> only
>>>>>> in unstable, stable is still with old packages.
>>>>>> What you can try after purging and before installing check the
>>>>>> output
>>>>>> of these commands:
>>>>>> debconf-get-selections | grep jitsi
>>>>>> debconf-get-selections | grep jicofo
>>>>>> They should not have any output, you can try installing everything
>>>>>> from
>>>>>> unstable and purge it. There was a bug in older versions and
>>>>>> purging was not
>>>>>> clearing everything, but I think we fixed it in the newer versions
>>>>>> of
>>>>>> packages.
>>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>>> problems
>>>>>> we discover.
>>>>>>
>>>>>> Thanks
>>>>>> damencho
>>>>>>
>>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve >>>>> >>>>>> <petervnv1@gmail.com> >>>>> >>>>>> wrote:
>>>>>>>
>>>>>>> Hmmm,
>>>>>>>
>>>>>>> Just tried with the debian stable repo and am getting the same
>>>>>>> strange
>>>>>>> behaviour I reported with unstable.
>>>>>>> No errors during package installation with apt-get -y install
>>>>>>> jitsi-meet. And I did a proper purge beforehand and even manually
>>>>>>> deleted
>>>>>>> any leftovers from previous installs.
>>>>>>>
>>>>>>> Yet the post-install script never runs and there is no meet folder
>>>>>>> in
>>>>>>> /etc/jitsi.....
>>>>>>>
>>>>>>> Anyone else experiencing this behaviour?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Peter
>>>>>>>
>>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve >>>>> >>>>>>> <petervnv1@gmail.com> >>>>> >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> I just did a purge of my old (debian 8) installation and tried to
>>>>>>>> install everything from scratch using the debian package manager
>>>>>>>> and the
>>>>>>>> unstable repo.
>>>>>>>>
>>>>>>>> The installation goes without problems but I never get prompted
>>>>>>>> for
>>>>>>>> the FQDN of jitsi-meet like before.
>>>>>>>>
>>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and jicofo
>>>>>>>> folders but there's no longer a meet folder created.
>>>>>>>>
>>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
>>>>>>>> package
>>>>>>>> in unstable working rather well a few weeks ago.
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Peter
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> dev mailing list
>>>>>>> dev@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> dev mailing list
>>>>>> dev@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Thanks for the update Damian!

I will try to reinstall everything using the unstable repo and will report
back.

Cheers,
Peter

···

On Wed, Dec 7, 2016 at 11:17 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi again,

It is fixed now.

I didn't manage to identify the actual problem, I was suspecting some
circular dependency, but I didn't found one. I found that if you
install default-jre-headless before installing jitsi-meet, everything
is fine and order of setting up dependencies is kept. And we used to
have that dependency for jvb in pre-depends, so I moved it back there
and now everything is fine, cause default-jre-headless is configured
before the other packages.

Regards
damencho

On Tue, Dec 6, 2016 at 6:29 PM, Damian Minkov <damencho@jitsi.org> wrote:
> The dependency ordering can be broken because of circular dependency,
> maybe there is such a problem currently because of jitsi-meet meta
> package depending on jitsi-meet-web, jitsi-meet-web-config and
> jitsi-meet-prosody. And both jitsi-meet-web-config and
> jitsi-meet-prosody depend on jitsi-meet-web.
> Will try to eliminate those and see does it fixes the problem.
>
> On Tue, Dec 6, 2016 at 6:16 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>> Yep, I just confirmed it, the problem is the re-ordering
>> Setting up jitsi-meet-web (1.0.1555-1) ...
>> Setting up nginx-common (1.6.2-5+deb8u4) ...
>> Setting up nginx-full (1.6.2-5+deb8u4) ...
>> Setting up nginx (1.6.2-5+deb8u4) ...
>> Setting up jitsi-meet-web-config (1.0.1555-1) ...
>> Setting up jitsi-meet-prosody (1.0.1555-1) ...
>> Setting up jitsi-videobridge (852-1) ...
>> Setting up jicofo (1.0-316-1) ...
>> Setting up jitsi-meet (1.0.1557-1) ...
>>
>> Need to think of it, why it acts like that. If there is a Debian guru
>> on the list and give a hand with this problem, that will be awesome.
>>
>>
>> On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>> Hi,
>>>
>>> So today I purged everything that I've installed from stable. And then
>>> installed in this order:
>>> apt-get install jitsi-videobridge
>>> apt-get install jicofo
>>> apt-get install jitsi-meet
>>> And it was fine. I purged it again and just did apt-get install
>>> jitsi-meet and again it was fine.
>>> I have the impression that initially when I've installed it on clean
>>> machine the order was not that.
>>> The order is important and it should be jvb, jicofo, meet
>>> (https://github.com/jitsi/jitsi-meet-debian-meta/blob/
master/control-tmpl#L12).
>>> This is the order in the Depends in the jitsi-meet meta package.
>>> I will delete my vm and will try this one again and see whether and
>>> why the order is not kept.
>>> In other words, if it is not working for you currently, purging and
>>> installing with those 3 commands from unstable is a simple workaround.
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
>>>> Hi Damian,
>>>>
>>>> Thanks for your help.
>>>>
>>>> I purged everything thoroughly and went back to stable and all is
working
>>>> now.
>>>>
>>>> Let me know when you've figured out the bugs with unstable as I'd
like to
>>>> test it out too.
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>>>>
>>>>> By the way I did:
>>>>> 10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
>>>>> jitsi-meet-web jitsi-meet-web-config
>>>>> 11 apt-get --purge remove jicofo
>>>>> 12 apt-get --purge remove jitsi-videobridge
>>>>> Change to stable
>>>>> apt-get install jitsi-meet
>>>>> And everything was fine.
>>>>>
>>>>> I'll keep you posted with my findings.
>>>>>
>>>>> Regards
>>>>> damencho
>>>>>
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>>>> > Hi again,
>>>>> > I just tried it on new vm with latest debian8 (what digital ocean
>>>>> > provides...) and here the java defaults to java7 and also I think
>>>>> > there is some problems with the debconf and reusing those values
>>>>> > between packages ... I was not seeing those when testing under
ubuntu.
>>>>> > I think I see the problem you are facing, I will be checking it
>>>>> > tomorrow to see what is the actual fail and try fixing it.
>>>>> > If you want to use jetty to serve meet, you need to install
>>>>> > openjdk-8-jre-headless before installing jitsi-meet.
>>>>> >
>>>>> > Thanks
>>>>> > damencho
>>>>> >
>>>>> >
>>>>> > On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve < > petervnv1@gmail.com> > >>>>> > wrote:
>>>>> >> Yup. Tried the commands and nothing was there
>>>>> >>
>>>>> >> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov <damencho@jitsi.org > > > >>>>> >> wrote:
>>>>> >>>
>>>>> >>> Hum,
>>>>> >>>
>>>>> >>> Something seems really wrong, normally those password are auto
>>>>> >>> generated
>>>>> >>> and they should not look like this. Did you try the commands
before
>>>>> >>> installing, I've wrote about? Do they show something before
>>>>> >>> installing?
>>>>> >>>
>>>>> >>> Regards
>>>>> >>> damencho
>>>>> >>>
>>>>> >>>
>>>>> >>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve > >>>>> >>> <petervnv1@gmail.com> > >>>>> >>> wrote:
>>>>> >>>>
>>>>> >>>> More info.
>>>>> >>>>
>>>>> >>>> It seems the scripts in the unstable repo are buggy. I see lots
of
>>>>> >>>> authentication failures in jicofo.log, and looking at the
prosody
>>>>> >>>> config I
>>>>> >>>> see that the component_secrets are set to "ok".
>>>>> >>>> Is this some new Prosody feature to hide the passwords or is
this a
>>>>> >>>> bug?
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> Component "conference.meet.my.domain" "muc"
>>>>> >>>> --modules_enabled = { "token_verification" }
>>>>> >>>> admins = { "focus@auth.meet.my.domain" }
>>>>> >>>>
>>>>> >>>> Component "jitsi-videobridge.meet.my.domain"
>>>>> >>>> component_secret = "ok"
>>>>> >>>>
>>>>> >>>> VirtualHost "auth.meet.my.domain"
>>>>> >>>> authentication = "internal_plain"
>>>>> >>>>
>>>>> >>>> Component "focus.meet.my.domainl"
>>>>> >>>> component_secret = "ok"
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> Cheers,
>>>>> >>>> Peter
>>>>> >>>>
>>>>> >>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve > >>>>> >>>> <petervnv1@gmail.com> > >>>>> >>>> wrote:
>>>>> >>>>>
>>>>> >>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> >>>>> jitsi-meet-web-config package. I purged everything again and
made
>>>>> >>>>> sure
>>>>> >>>>> iitsi-meet-web-config and jitsi-meet-web packages were
completely
>>>>> >>>>> purged (is
>>>>> >>>>> there any info on these new packages? It seems they are
destined for
>>>>> >>>>> those
>>>>> >>>>> running apache or nginx, correct? In my case I'm only using
Jetty.
>>>>> >>>>>
>>>>> >>>>> I then tried a clean install using the unstable repo. This
time it
>>>>> >>>>> did
>>>>> >>>>> ask for the FQDN for the jvb and it also asked me for
passwords for
>>>>> >>>>> the
>>>>> >>>>> component secrets.
>>>>> >>>>> I did all that but when trying to open it I get a blank
screen, and
>>>>> >>>>> this
>>>>> >>>>> is the error thrown in the Chrome console.
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> >>>>> loggingConfig is
>>>>> >>>>> not defined
>>>>> >>>>>
>>>>> >>>>> I haven't tried with stable repo yet since I'm eager to try
out the
>>>>> >>>>> latest and greatest. The error seems to be in reference to a
missing
>>>>> >>>>> config
>>>>> >>>>> option somewhere.
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>> Cheers,
>>>>> >>>>> Peter
>>>>> >>>>>
>>>>> >>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov < > damencho@jitsi.org> > >>>>> >>>>> wrote:
>>>>> >>>>>>
>>>>> >>>>>> Hi,
>>>>> >>>>>>
>>>>> >>>>>> Sorry to hear you have a problem. We recently updated the
debian
>>>>> >>>>>> packaging of all of the packages. Maybe you are hitting a
problem
>>>>> >>>>>> caused by
>>>>> >>>>>> this changes. I will take a look.
>>>>> >>>>>> The strange thing is that the changes I'm mentioning are
currently
>>>>> >>>>>> only
>>>>> >>>>>> in unstable, stable is still with old packages.
>>>>> >>>>>> What you can try after purging and before installing check the
>>>>> >>>>>> output
>>>>> >>>>>> of these commands:
>>>>> >>>>>> debconf-get-selections | grep jitsi
>>>>> >>>>>> debconf-get-selections | grep jicofo
>>>>> >>>>>> They should not have any output, you can try installing
everything
>>>>> >>>>>> from
>>>>> >>>>>> unstable and purge it. There was a bug in older versions and
>>>>> >>>>>> purging was not
>>>>> >>>>>> clearing everything, but I think we fixed it in the newer
versions
>>>>> >>>>>> of
>>>>> >>>>>> packages.
>>>>> >>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>> >>>>>> problems
>>>>> >>>>>> we discover.
>>>>> >>>>>>
>>>>> >>>>>> Thanks
>>>>> >>>>>> damencho
>>>>> >>>>>>
>>>>> >>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve > >>>>> >>>>>> <petervnv1@gmail.com> > >>>>> >>>>>> wrote:
>>>>> >>>>>>>
>>>>> >>>>>>> Hmmm,
>>>>> >>>>>>>
>>>>> >>>>>>> Just tried with the debian stable repo and am getting the
same
>>>>> >>>>>>> strange
>>>>> >>>>>>> behaviour I reported with unstable.
>>>>> >>>>>>> No errors during package installation with apt-get -y install
>>>>> >>>>>>> jitsi-meet. And I did a proper purge beforehand and even
manually
>>>>> >>>>>>> deleted
>>>>> >>>>>>> any leftovers from previous installs.
>>>>> >>>>>>>
>>>>> >>>>>>> Yet the post-install script never runs and there is no meet
folder
>>>>> >>>>>>> in
>>>>> >>>>>>> /etc/jitsi.....
>>>>> >>>>>>>
>>>>> >>>>>>> Anyone else experiencing this behaviour?
>>>>> >>>>>>>
>>>>> >>>>>>> Cheers,
>>>>> >>>>>>> Peter
>>>>> >>>>>>>
>>>>> >>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve > >>>>> >>>>>>> <petervnv1@gmail.com> > >>>>> >>>>>>> wrote:
>>>>> >>>>>>>>
>>>>> >>>>>>>> Hi all,
>>>>> >>>>>>>>
>>>>> >>>>>>>> I just did a purge of my old (debian 8) installation and
tried to
>>>>> >>>>>>>> install everything from scratch using the debian package
manager
>>>>> >>>>>>>> and the
>>>>> >>>>>>>> unstable repo.
>>>>> >>>>>>>>
>>>>> >>>>>>>> The installation goes without problems but I never get
prompted
>>>>> >>>>>>>> for
>>>>> >>>>>>>> the FQDN of jitsi-meet like before.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and
jicofo
>>>>> >>>>>>>> folders but there's no longer a meet folder created.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Is this a recently introduced bug? I remember the jitsi-meet
>>>>> >>>>>>>> package
>>>>> >>>>>>>> in unstable working rather well a few weeks ago.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Cheers,
>>>>> >>>>>>>> Peter
>>>>> >>>>>>>
>>>>> >>>>>>>
>>>>> >>>>>>>
>>>>> >>>>>>> _______________________________________________
>>>>> >>>>>>> dev mailing list
>>>>> >>>>>>> dev@jitsi.org
>>>>> >>>>>>> Unsubscribe instructions and other list options:
>>>>> >>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>>>>
>>>>> >>>>>>
>>>>> >>>>>>
>>>>> >>>>>> _______________________________________________
>>>>> >>>>>> dev mailing list
>>>>> >>>>>> dev@jitsi.org
>>>>> >>>>>> Unsubscribe instructions and other list options:
>>>>> >>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> _______________________________________________
>>>>> >>>> dev mailing list
>>>>> >>>> dev@jitsi.org
>>>>> >>>> Unsubscribe instructions and other list options:
>>>>> >>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>
>>>>> >>>
>>>>> >>>
>>>>> >>> _______________________________________________
>>>>> >>> dev mailing list
>>>>> >>> dev@jitsi.org
>>>>> >>> Unsubscribe instructions and other list options:
>>>>> >>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>
>>>>> >>
>>>>> >>
>>>>> >> _______________________________________________
>>>>> >> dev mailing list
>>>>> >> dev@jitsi.org
>>>>> >> Unsubscribe instructions and other list options:
>>>>> >> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>> _______________________________________________
>>>>> dev mailing list
>>>>> dev@jitsi.org
>>>>> Unsubscribe instructions and other list options:
>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Hi !

I found this properties : net.java.sip.communicator.impl.protocol.CallWaitingDisabled=true

But i want to disabled sound only if i am already in call, is possible ?

Thank's in advance.

···

Le 09/12/2016 à 17:09, Peter Villeneuve a écrit :

Thanks for the update Damian!

I will try to reinstall everything using the unstable repo and will report back.

Cheers,
Peter

On Wed, Dec 7, 2016 at 11:17 PM, Damian Minkov <damencho@jitsi.org > <mailto:damencho@jitsi.org>> wrote:

    Hi again,

    It is fixed now.

    I didn't manage to identify the actual problem, I was suspecting some
    circular dependency, but I didn't found one. I found that if you
    install default-jre-headless before installing jitsi-meet, everything
    is fine and order of setting up dependencies is kept. And we used to
    have that dependency for jvb in pre-depends, so I moved it back there
    and now everything is fine, cause default-jre-headless is configured
    before the other packages.

    Regards
    damencho

    On Tue, Dec 6, 2016 at 6:29 PM, Damian Minkov <damencho@jitsi.org > <mailto:damencho@jitsi.org>> wrote:
    > The dependency ordering can be broken because of circular
    dependency,
    > maybe there is such a problem currently because of jitsi-meet meta
    > package depending on jitsi-meet-web, jitsi-meet-web-config and
    > jitsi-meet-prosody. And both jitsi-meet-web-config and
    > jitsi-meet-prosody depend on jitsi-meet-web.
    > Will try to eliminate those and see does it fixes the problem.
    >
    > On Tue, Dec 6, 2016 at 6:16 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> wrote:
    >> Yep, I just confirmed it, the problem is the re-ordering
    >> Setting up jitsi-meet-web (1.0.1555-1) ...
    >> Setting up nginx-common (1.6.2-5+deb8u4) ...
    >> Setting up nginx-full (1.6.2-5+deb8u4) ...
    >> Setting up nginx (1.6.2-5+deb8u4) ...
    >> Setting up jitsi-meet-web-config (1.0.1555-1) ...
    >> Setting up jitsi-meet-prosody (1.0.1555-1) ...
    >> Setting up jitsi-videobridge (852-1) ...
    >> Setting up jicofo (1.0-316-1) ...
    >> Setting up jitsi-meet (1.0.1557-1) ...
    >>
    >> Need to think of it, why it acts like that. If there is a
    Debian guru
    >> on the list and give a hand with this problem, that will be
    awesome.
    >>
    >> On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> wrote:
    >>> Hi,
    >>>
    >>> So today I purged everything that I've installed from stable.
    And then
    >>> installed in this order:
    >>> apt-get install jitsi-videobridge
    >>> apt-get install jicofo
    >>> apt-get install jitsi-meet
    >>> And it was fine. I purged it again and just did apt-get install
    >>> jitsi-meet and again it was fine.
    >>> I have the impression that initially when I've installed it on
    clean
    >>> machine the order was not that.
    >>> The order is important and it should be jvb, jicofo, meet
    >>>
    (https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12
    <https://github.com/jitsi/jitsi-meet-debian-meta/blob/master/control-tmpl#L12>).
    >>> This is the order in the Depends in the jitsi-meet meta package.
    >>> I will delete my vm and will try this one again and see
    whether and
    >>> why the order is not kept.
    >>> In other words, if it is not working for you currently,
    purging and
    >>> installing with those 3 commands from unstable is a simple
    workaround.
    >>>
    >>> Regards
    >>> damencho
    >>>
    >>> On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> wrote:
    >>>> Hi Damian,
    >>>>
    >>>> Thanks for your help.
    >>>>
    >>>> I purged everything thoroughly and went back to stable and
    all is working
    >>>> now.
    >>>>
    >>>> Let me know when you've figured out the bugs with unstable as
    I'd like to
    >>>> test it out too.
    >>>>
    >>>> Cheers,
    >>>> Peter
    >>>>
    >>>> On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> wrote:
    >>>>>
    >>>>> By the way I did:
    >>>>> 10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
    >>>>> jitsi-meet-web jitsi-meet-web-config
    >>>>> 11 apt-get --purge remove jicofo
    >>>>> 12 apt-get --purge remove jitsi-videobridge
    >>>>> Change to stable
    >>>>> apt-get install jitsi-meet
    >>>>> And everything was fine.
    >>>>>
    >>>>> I'll keep you posted with my findings.
    >>>>>
    >>>>> Regards
    >>>>> damencho
    >>>>>
    >>>>> On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> wrote:
    >>>>> > Hi again,
    >>>>> > I just tried it on new vm with latest debian8 (what
    digital ocean
    >>>>> > provides...) and here the java defaults to java7 and also
    I think
    >>>>> > there is some problems with the debconf and reusing those
    values
    >>>>> > between packages ... I was not seeing those when testing
    under ubuntu.
    >>>>> > I think I see the problem you are facing, I will be
    checking it
    >>>>> > tomorrow to see what is the actual fail and try fixing it.
    >>>>> > If you want to use jetty to serve meet, you need to install
    >>>>> > openjdk-8-jre-headless before installing jitsi-meet.
    >>>>> >
    >>>>> > Thanks
    >>>>> > damencho
    >>>>> >
    >>>>> > On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >>>>> > wrote:
    >>>>> >> Yup. Tried the commands and nothing was there
    >>>>> >>
    >>>>> >> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> > >>>>> >> wrote:
    >>>>> >>>
    >>>>> >>> Hum,
    >>>>> >>>
    >>>>> >>> Something seems really wrong, normally those password
    are auto
    >>>>> >>> generated
    >>>>> >>> and they should not look like this. Did you try the
    commands before
    >>>>> >>> installing, I've wrote about? Do they show something before
    >>>>> >>> installing?
    >>>>> >>>
    >>>>> >>> Regards
    >>>>> >>> damencho
    >>>>> >>>
    >>>>> >>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve > >>>>> >>> <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >>>>> >>> wrote:
    >>>>> >>>>
    >>>>> >>>> More info.
    >>>>> >>>>
    >>>>> >>>> It seems the scripts in the unstable repo are buggy. I
    see lots of
    >>>>> >>>> authentication failures in jicofo.log, and looking at
    the prosody
    >>>>> >>>> config I
    >>>>> >>>> see that the component_secrets are set to "ok".
    >>>>> >>>> Is this some new Prosody feature to hide the passwords
    or is this a
    >>>>> >>>> bug?
    >>>>> >>>>
    >>>>> >>>> Component "conference.meet.my.domain" "muc"
    >>>>> >>>> --modules_enabled = { "token_verification" }
    >>>>> >>>> admins = { "focus@auth.meet.my.domain" }
    >>>>> >>>>
    >>>>> >>>> Component "jitsi-videobridge.meet.my
    <http://jitsi-videobridge.meet.my>.domain"
    >>>>> >>>> component_secret = "ok"
    >>>>> >>>>
    >>>>> >>>> VirtualHost "auth.meet.my.domain"
    >>>>> >>>> authentication = "internal_plain"
    >>>>> >>>>
    >>>>> >>>> Component "focus.meet.my.domainl"
    >>>>> >>>> component_secret = "ok"
    >>>>> >>>>
    >>>>> >>>> Cheers,
    >>>>> >>>> Peter
    >>>>> >>>>
    >>>>> >>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve > >>>>> >>>> <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >>>>> >>>> wrote:
    >>>>> >>>>>
    >>>>> >>>>> Indeed I think the problem was left over jitsi stuff
    from the
    >>>>> >>>>> jitsi-meet-web-config package. I purged everything
    again and made
    >>>>> >>>>> sure
    >>>>> >>>>> iitsi-meet-web-config and jitsi-meet-web packages were
    completely
    >>>>> >>>>> purged (is
    >>>>> >>>>> there any info on these new packages? It seems they
    are destined for
    >>>>> >>>>> those
    >>>>> >>>>> running apache or nginx, correct? In my case I'm only
    using Jetty.
    >>>>> >>>>>
    >>>>> >>>>> I then tried a clean install using the unstable repo.
    This time it
    >>>>> >>>>> did
    >>>>> >>>>> ask for the FQDN for the jvb and it also asked me for
    passwords for
    >>>>> >>>>> the
    >>>>> >>>>> component secrets.
    >>>>> >>>>> I did all that but when trying to open it I get a
    blank screen, and
    >>>>> >>>>> this
    >>>>> >>>>> is the error thrown in the Chrome console.
    >>>>> >>>>>
    >>>>> >>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
    >>>>> >>>>> loggingConfig is
    >>>>> >>>>> not defined
    >>>>> >>>>>
    >>>>> >>>>> I haven't tried with stable repo yet since I'm eager
    to try out the
    >>>>> >>>>> latest and greatest. The error seems to be in
    reference to a missing
    >>>>> >>>>> config
    >>>>> >>>>> option somewhere.
    >>>>> >>>>>
    >>>>> >>>>> Cheers,
    >>>>> >>>>> Peter
    >>>>> >>>>>
    >>>>> >>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov > <damencho@jitsi.org <mailto:damencho@jitsi.org>> > >>>>> >>>>> wrote:
    >>>>> >>>>>>
    >>>>> >>>>>> Hi,
    >>>>> >>>>>>
    >>>>> >>>>>> Sorry to hear you have a problem. We recently updated
    the debian
    >>>>> >>>>>> packaging of all of the packages. Maybe you are
    hitting a problem
    >>>>> >>>>>> caused by
    >>>>> >>>>>> this changes. I will take a look.
    >>>>> >>>>>> The strange thing is that the changes I'm mentioning
    are currently
    >>>>> >>>>>> only
    >>>>> >>>>>> in unstable, stable is still with old packages.
    >>>>> >>>>>> What you can try after purging and before installing
    check the
    >>>>> >>>>>> output
    >>>>> >>>>>> of these commands:
    >>>>> >>>>>> debconf-get-selections | grep jitsi
    >>>>> >>>>>> debconf-get-selections | grep jicofo
    >>>>> >>>>>> They should not have any output, you can try
    installing everything
    >>>>> >>>>>> from
    >>>>> >>>>>> unstable and purge it. There was a bug in older
    versions and
    >>>>> >>>>>> purging was not
    >>>>> >>>>>> clearing everything, but I think we fixed it in the
    newer versions
    >>>>> >>>>>> of
    >>>>> >>>>>> packages.
    >>>>> >>>>>> Report how it goes, so we can eventually debug it and
    fix any
    >>>>> >>>>>> problems
    >>>>> >>>>>> we discover.
    >>>>> >>>>>>
    >>>>> >>>>>> Thanks
    >>>>> >>>>>> damencho
    >>>>> >>>>>>
    >>>>> >>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve > >>>>> >>>>>> <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >>>>> >>>>>> wrote:
    >>>>> >>>>>>>
    >>>>> >>>>>>> Hmmm,
    >>>>> >>>>>>>
    >>>>> >>>>>>> Just tried with the debian stable repo and am
    getting the same
    >>>>> >>>>>>> strange
    >>>>> >>>>>>> behaviour I reported with unstable.
    >>>>> >>>>>>> No errors during package installation with apt-get
    -y install
    >>>>> >>>>>>> jitsi-meet. And I did a proper purge beforehand and
    even manually
    >>>>> >>>>>>> deleted
    >>>>> >>>>>>> any leftovers from previous installs.
    >>>>> >>>>>>>
    >>>>> >>>>>>> Yet the post-install script never runs and there is
    no meet folder
    >>>>> >>>>>>> in
    >>>>> >>>>>>> /etc/jitsi.....
    >>>>> >>>>>>>
    >>>>> >>>>>>> Anyone else experiencing this behaviour?
    >>>>> >>>>>>>
    >>>>> >>>>>>> Cheers,
    >>>>> >>>>>>> Peter
    >>>>> >>>>>>>
    >>>>> >>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve > >>>>> >>>>>>> <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> > >>>>> >>>>>>> wrote:
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> Hi all,
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> I just did a purge of my old (debian 8)
    installation and tried to
    >>>>> >>>>>>>> install everything from scratch using the debian
    package manager
    >>>>> >>>>>>>> and the
    >>>>> >>>>>>>> unstable repo.
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> The installation goes without problems but I never
    get prompted
    >>>>> >>>>>>>> for
    >>>>> >>>>>>>> the FQDN of jitsi-meet like before.
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> Also, when I look in /etc/jitsi/ I see the
    videobridge and jicofo
    >>>>> >>>>>>>> folders but there's no longer a meet folder created.
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> Is this a recently introduced bug? I remember the
    jitsi-meet
    >>>>> >>>>>>>> package
    >>>>> >>>>>>>> in unstable working rather well a few weeks ago.
    >>>>> >>>>>>>>
    >>>>> >>>>>>>> Cheers,
    >>>>> >>>>>>>> Peter
    >>>>> >>>>>>>
    >>>>> >>>>>>> _______________________________________________
    >>>>> >>>>>>> dev mailing list
    >>>>> >>>>>>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> >>>>>>> Unsubscribe instructions and other list options:
    >>>>> >>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>> >>>>>>
    >>>>> >>>>>> _______________________________________________
    >>>>> >>>>>> dev mailing list
    >>>>> >>>>>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> >>>>>> Unsubscribe instructions and other list options:
    >>>>> >>>>>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>> >>>>>
    >>>>> >>>>
    >>>>> >>>> _______________________________________________
    >>>>> >>>> dev mailing list
    >>>>> >>>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> >>>> Unsubscribe instructions and other list options:
    >>>>> >>>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>> >>>
    >>>>> >>> _______________________________________________
    >>>>> >>> dev mailing list
    >>>>> >>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> >>> Unsubscribe instructions and other list options:
    >>>>> >>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>> >>
    >>>>> >> _______________________________________________
    >>>>> >> dev mailing list
    >>>>> >> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> >> Unsubscribe instructions and other list options:
    >>>>> >> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>>
    >>>>> _______________________________________________
    >>>>> dev mailing list
    >>>>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>>> Unsubscribe instructions and other list options:
    >>>>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>
    >>>>
    >>>> _______________________________________________
    >>>> dev mailing list
    >>>> dev@jitsi.org <mailto:dev@jitsi.org>
    >>>> Unsubscribe instructions and other list options:
    >>>> http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev
    <http://lists.jitsi.org/mailman/listinfo/dev>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Rocco Sette
netika Technicien Système & Réseau
3 rue de Sarrelouis - 67000 Strasbourg
rocco.sette@netika.net <mailto:rocco.sette@netika.net>
Hotline KaliLab : +33 (0)3 68 46 16 50
Accueil : +33 (0)3 68 46 16 28
Fax : +33 (0)3 88 52 82 02

Twitter <https://twitter.com/netika_france> LinkedIN <http://www.linkedin.com/company/netika-sarl> Viadeo <http://www.viadeo.com/v/company/netika>

La préservation de l'environnement est un exercice quotidien : n'imprimez ce mail que si nécessaire.


#17

Thanks Damian.
All working fine now (used unstable).

Cheers

···

On Fri, Dec 9, 2016 at 4:09 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks for the update Damian!

I will try to reinstall everything using the unstable repo and will report
back.

Cheers,
Peter

On Wed, Dec 7, 2016 at 11:17 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi again,

It is fixed now.

I didn't manage to identify the actual problem, I was suspecting some
circular dependency, but I didn't found one. I found that if you
install default-jre-headless before installing jitsi-meet, everything
is fine and order of setting up dependencies is kept. And we used to
have that dependency for jvb in pre-depends, so I moved it back there
and now everything is fine, cause default-jre-headless is configured
before the other packages.

Regards
damencho

On Tue, Dec 6, 2016 at 6:29 PM, Damian Minkov <damencho@jitsi.org> wrote:
> The dependency ordering can be broken because of circular dependency,
> maybe there is such a problem currently because of jitsi-meet meta
> package depending on jitsi-meet-web, jitsi-meet-web-config and
> jitsi-meet-prosody. And both jitsi-meet-web-config and
> jitsi-meet-prosody depend on jitsi-meet-web.
> Will try to eliminate those and see does it fixes the problem.
>
> On Tue, Dec 6, 2016 at 6:16 PM, Damian Minkov <damencho@jitsi.org> >> wrote:
>> Yep, I just confirmed it, the problem is the re-ordering
>> Setting up jitsi-meet-web (1.0.1555-1) ...
>> Setting up nginx-common (1.6.2-5+deb8u4) ...
>> Setting up nginx-full (1.6.2-5+deb8u4) ...
>> Setting up nginx (1.6.2-5+deb8u4) ...
>> Setting up jitsi-meet-web-config (1.0.1555-1) ...
>> Setting up jitsi-meet-prosody (1.0.1555-1) ...
>> Setting up jitsi-videobridge (852-1) ...
>> Setting up jicofo (1.0-316-1) ...
>> Setting up jitsi-meet (1.0.1557-1) ...
>>
>> Need to think of it, why it acts like that. If there is a Debian guru
>> on the list and give a hand with this problem, that will be awesome.
>>
>>
>> On Tue, Dec 6, 2016 at 6:01 PM, Damian Minkov <damencho@jitsi.org> >> wrote:
>>> Hi,
>>>
>>> So today I purged everything that I've installed from stable. And then
>>> installed in this order:
>>> apt-get install jitsi-videobridge
>>> apt-get install jicofo
>>> apt-get install jitsi-meet
>>> And it was fine. I purged it again and just did apt-get install
>>> jitsi-meet and again it was fine.
>>> I have the impression that initially when I've installed it on clean
>>> machine the order was not that.
>>> The order is important and it should be jvb, jicofo, meet
>>> (https://github.com/jitsi/jitsi-meet-debian-meta/blob/master
/control-tmpl#L12).
>>> This is the order in the Depends in the jitsi-meet meta package.
>>> I will delete my vm and will try this one again and see whether and
>>> why the order is not kept.
>>> In other words, if it is not working for you currently, purging and
>>> installing with those 3 commands from unstable is a simple workaround.
>>>
>>> Regards
>>> damencho
>>>
>>>
>>> On Tue, Dec 6, 2016 at 6:48 AM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
>>>> Hi Damian,
>>>>
>>>> Thanks for your help.
>>>>
>>>> I purged everything thoroughly and went back to stable and all is
working
>>>> now.
>>>>
>>>> Let me know when you've figured out the bugs with unstable as I'd
like to
>>>> test it out too.
>>>>
>>>> Cheers,
>>>> Peter
>>>>
>>>> On Mon, Dec 5, 2016 at 11:47 PM, Damian Minkov <damencho@jitsi.org> >> wrote:
>>>>>
>>>>> By the way I did:
>>>>> 10 apt-get --purge remove jitsi-meet jitsi-meet-prosody
>>>>> jitsi-meet-web jitsi-meet-web-config
>>>>> 11 apt-get --purge remove jicofo
>>>>> 12 apt-get --purge remove jitsi-videobridge
>>>>> Change to stable
>>>>> apt-get install jitsi-meet
>>>>> And everything was fine.
>>>>>
>>>>> I'll keep you posted with my findings.
>>>>>
>>>>> Regards
>>>>> damencho
>>>>>
>>>>>
>>>>> On Mon, Dec 5, 2016 at 5:41 PM, Damian Minkov <damencho@jitsi.org> >> wrote:
>>>>> > Hi again,
>>>>> > I just tried it on new vm with latest debian8 (what digital ocean
>>>>> > provides...) and here the java defaults to java7 and also I think
>>>>> > there is some problems with the debconf and reusing those values
>>>>> > between packages ... I was not seeing those when testing under
ubuntu.
>>>>> > I think I see the problem you are facing, I will be checking it
>>>>> > tomorrow to see what is the actual fail and try fixing it.
>>>>> > If you want to use jetty to serve meet, you need to install
>>>>> > openjdk-8-jre-headless before installing jitsi-meet.
>>>>> >
>>>>> > Thanks
>>>>> > damencho
>>>>> >
>>>>> >
>>>>> > On Mon, Dec 5, 2016 at 3:50 PM, Peter Villeneuve < >> petervnv1@gmail.com> >> >>>>> > wrote:
>>>>> >> Yup. Tried the commands and nothing was there
>>>>> >>
>>>>> >> On Mon, Dec 5, 2016 at 7:20 PM, Damian Minkov < >> damencho@jitsi.org> >> >>>>> >> wrote:
>>>>> >>>
>>>>> >>> Hum,
>>>>> >>>
>>>>> >>> Something seems really wrong, normally those password are auto
>>>>> >>> generated
>>>>> >>> and they should not look like this. Did you try the commands
before
>>>>> >>> installing, I've wrote about? Do they show something before
>>>>> >>> installing?
>>>>> >>>
>>>>> >>> Regards
>>>>> >>> damencho
>>>>> >>>
>>>>> >>>
>>>>> >>> On Mon, Dec 5, 2016 at 12:41 PM, Peter Villeneuve >> >>>>> >>> <petervnv1@gmail.com> >> >>>>> >>> wrote:
>>>>> >>>>
>>>>> >>>> More info.
>>>>> >>>>
>>>>> >>>> It seems the scripts in the unstable repo are buggy. I see
lots of
>>>>> >>>> authentication failures in jicofo.log, and looking at the
prosody
>>>>> >>>> config I
>>>>> >>>> see that the component_secrets are set to "ok".
>>>>> >>>> Is this some new Prosody feature to hide the passwords or is
this a
>>>>> >>>> bug?
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> Component "conference.meet.my.domain" "muc"
>>>>> >>>> --modules_enabled = { "token_verification" }
>>>>> >>>> admins = { "focus@auth.meet.my.domain" }
>>>>> >>>>
>>>>> >>>> Component "jitsi-videobridge.meet.my.domain"
>>>>> >>>> component_secret = "ok"
>>>>> >>>>
>>>>> >>>> VirtualHost "auth.meet.my.domain"
>>>>> >>>> authentication = "internal_plain"
>>>>> >>>>
>>>>> >>>> Component "focus.meet.my.domainl"
>>>>> >>>> component_secret = "ok"
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> Cheers,
>>>>> >>>> Peter
>>>>> >>>>
>>>>> >>>> On Mon, Dec 5, 2016 at 6:24 PM, Peter Villeneuve >> >>>>> >>>> <petervnv1@gmail.com> >> >>>>> >>>> wrote:
>>>>> >>>>>
>>>>> >>>>> Indeed I think the problem was left over jitsi stuff from the
>>>>> >>>>> jitsi-meet-web-config package. I purged everything again and
made
>>>>> >>>>> sure
>>>>> >>>>> iitsi-meet-web-config and jitsi-meet-web packages were
completely
>>>>> >>>>> purged (is
>>>>> >>>>> there any info on these new packages? It seems they are
destined for
>>>>> >>>>> those
>>>>> >>>>> running apache or nginx, correct? In my case I'm only using
Jetty.
>>>>> >>>>>
>>>>> >>>>> I then tried a clean install using the unstable repo. This
time it
>>>>> >>>>> did
>>>>> >>>>> ask for the FQDN for the jvb and it also asked me for
passwords for
>>>>> >>>>> the
>>>>> >>>>> component secrets.
>>>>> >>>>> I did all that but when trying to open it I get a blank
screen, and
>>>>> >>>>> this
>>>>> >>>>> is the error thrown in the Chrome console.
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>> app.bundle.min.js?v=1548:53 Uncaught ReferenceError:
>>>>> >>>>> loggingConfig is
>>>>> >>>>> not defined
>>>>> >>>>>
>>>>> >>>>> I haven't tried with stable repo yet since I'm eager to try
out the
>>>>> >>>>> latest and greatest. The error seems to be in reference to a
missing
>>>>> >>>>> config
>>>>> >>>>> option somewhere.
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>> Cheers,
>>>>> >>>>> Peter
>>>>> >>>>>
>>>>> >>>>> On Mon, Dec 5, 2016 at 5:31 PM, Damian Minkov < >> damencho@jitsi.org> >> >>>>> >>>>> wrote:
>>>>> >>>>>>
>>>>> >>>>>> Hi,
>>>>> >>>>>>
>>>>> >>>>>> Sorry to hear you have a problem. We recently updated the
debian
>>>>> >>>>>> packaging of all of the packages. Maybe you are hitting a
problem
>>>>> >>>>>> caused by
>>>>> >>>>>> this changes. I will take a look.
>>>>> >>>>>> The strange thing is that the changes I'm mentioning are
currently
>>>>> >>>>>> only
>>>>> >>>>>> in unstable, stable is still with old packages.
>>>>> >>>>>> What you can try after purging and before installing check
the
>>>>> >>>>>> output
>>>>> >>>>>> of these commands:
>>>>> >>>>>> debconf-get-selections | grep jitsi
>>>>> >>>>>> debconf-get-selections | grep jicofo
>>>>> >>>>>> They should not have any output, you can try installing
everything
>>>>> >>>>>> from
>>>>> >>>>>> unstable and purge it. There was a bug in older versions and
>>>>> >>>>>> purging was not
>>>>> >>>>>> clearing everything, but I think we fixed it in the newer
versions
>>>>> >>>>>> of
>>>>> >>>>>> packages.
>>>>> >>>>>> Report how it goes, so we can eventually debug it and fix any
>>>>> >>>>>> problems
>>>>> >>>>>> we discover.
>>>>> >>>>>>
>>>>> >>>>>> Thanks
>>>>> >>>>>> damencho
>>>>> >>>>>>
>>>>> >>>>>> On Mon, Dec 5, 2016 at 10:44 AM, Peter Villeneuve >> >>>>> >>>>>> <petervnv1@gmail.com> >> >>>>> >>>>>> wrote:
>>>>> >>>>>>>
>>>>> >>>>>>> Hmmm,
>>>>> >>>>>>>
>>>>> >>>>>>> Just tried with the debian stable repo and am getting the
same
>>>>> >>>>>>> strange
>>>>> >>>>>>> behaviour I reported with unstable.
>>>>> >>>>>>> No errors during package installation with apt-get -y
install
>>>>> >>>>>>> jitsi-meet. And I did a proper purge beforehand and even
manually
>>>>> >>>>>>> deleted
>>>>> >>>>>>> any leftovers from previous installs.
>>>>> >>>>>>>
>>>>> >>>>>>> Yet the post-install script never runs and there is no meet
folder
>>>>> >>>>>>> in
>>>>> >>>>>>> /etc/jitsi.....
>>>>> >>>>>>>
>>>>> >>>>>>> Anyone else experiencing this behaviour?
>>>>> >>>>>>>
>>>>> >>>>>>> Cheers,
>>>>> >>>>>>> Peter
>>>>> >>>>>>>
>>>>> >>>>>>> On Mon, Dec 5, 2016 at 4:00 PM, Peter Villeneuve >> >>>>> >>>>>>> <petervnv1@gmail.com> >> >>>>> >>>>>>> wrote:
>>>>> >>>>>>>>
>>>>> >>>>>>>> Hi all,
>>>>> >>>>>>>>
>>>>> >>>>>>>> I just did a purge of my old (debian 8) installation and
tried to
>>>>> >>>>>>>> install everything from scratch using the debian package
manager
>>>>> >>>>>>>> and the
>>>>> >>>>>>>> unstable repo.
>>>>> >>>>>>>>
>>>>> >>>>>>>> The installation goes without problems but I never get
prompted
>>>>> >>>>>>>> for
>>>>> >>>>>>>> the FQDN of jitsi-meet like before.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Also, when I look in /etc/jitsi/ I see the videobridge and
jicofo
>>>>> >>>>>>>> folders but there's no longer a meet folder created.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Is this a recently introduced bug? I remember the
jitsi-meet
>>>>> >>>>>>>> package
>>>>> >>>>>>>> in unstable working rather well a few weeks ago.
>>>>> >>>>>>>>
>>>>> >>>>>>>> Cheers,
>>>>> >>>>>>>> Peter
>>>>> >>>>>>>
>>>>> >>>>>>>
>>>>> >>>>>>>
>>>>> >>>>>>> _______________________________________________
>>>>> >>>>>>> dev mailing list
>>>>> >>>>>>> dev@jitsi.org
>>>>> >>>>>>> Unsubscribe instructions and other list options:
>>>>> >>>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>>>>
>>>>> >>>>>>
>>>>> >>>>>>
>>>>> >>>>>> _______________________________________________
>>>>> >>>>>> dev mailing list
>>>>> >>>>>> dev@jitsi.org
>>>>> >>>>>> Unsubscribe instructions and other list options:
>>>>> >>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>>>
>>>>> >>>>>
>>>>> >>>>
>>>>> >>>>
>>>>> >>>> _______________________________________________
>>>>> >>>> dev mailing list
>>>>> >>>> dev@jitsi.org
>>>>> >>>> Unsubscribe instructions and other list options:
>>>>> >>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>>
>>>>> >>>
>>>>> >>>
>>>>> >>> _______________________________________________
>>>>> >>> dev mailing list
>>>>> >>> dev@jitsi.org
>>>>> >>> Unsubscribe instructions and other list options:
>>>>> >>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>> >>
>>>>> >>
>>>>> >>
>>>>> >> _______________________________________________
>>>>> >> dev mailing list
>>>>> >> dev@jitsi.org
>>>>> >> Unsubscribe instructions and other list options:
>>>>> >> http://lists.jitsi.org/mailman/listinfo/dev
>>>>>
>>>>> _______________________________________________
>>>>> dev mailing list
>>>>> dev@jitsi.org
>>>>> Unsubscribe instructions and other list options:
>>>>> http://lists.jitsi.org/mailman/listinfo/dev
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#18

Hi !

I found this properties : net.java.sip.communicator.impl.protocol.CallWaitingDisabled=true

But i want to disabled sound only if i am already in call, is possible ?

Thank's in advance.

Attached Message Part (171 Bytes)

···

--
Rocco Sette
netika Technicien Système & Réseau
3 rue de Sarrelouis - 67000 Strasbourg
rocco.sette@netika.net <mailto:rocco.sette@netika.net>
Hotline KaliLab : +33 (0)3 68 46 16 50
Accueil : +33 (0)3 68 46 16 28
Fax : +33 (0)3 88 52 82 02

Twitter <https://twitter.com/netika_france> LinkedIN <http://www.linkedin.com/company/netika-sarl> Viadeo <http://www.viadeo.com/v/company/netika>

La préservation de l'environnement est un exercice quotidien : n'imprimez ce mail que si nécessaire.