[jitsi-dev] Unable to start conference at Jitsi Meet after update


#1

Hi, Jitsi team!

Yesterday I updated the components of Jitsi Meet (testing repo) to the
following versions:

jicofo [1.0-371-1 -> 1.0-376-1]
jitsi-meet [1.0.2520-1 -> 1.0.2550-1]
jitsi-meet-prosody [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web-config [1.0.2352-1 -> 1.0.2372-1]
jitsi-videobridge [997-1 -> 1002-1]

The bridge seems to be up however I get an error checking its status:

···

-----------------------------------------------------------------------
root@conference:~# systemctl status jitsi-videobridge
● jitsi-videobridge.service - LSB: Jitsi Videobridge
   Loaded: loaded (/etc/init.d/jitsi-videobridge)
  Drop-In: /etc/systemd/system/jitsi-videobridge.service.d
           └─override.conf
   Active: active (running) since Tue 2017-10-17 19:11:08 -03; 14h ago
  Process: 25735 ExecStop=/etc/init.d/jitsi-videobridge stop
(code=exited, status=0/SUCCESS)
  Process: 25742 ExecStart=/etc/init.d/jitsi-videobridge start
(code=exited, status=0/SUCCESS)
   CGroup: /system.slice/jitsi-videobridge.service
           └─25750 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=/tmp
-Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64
-Dnet.j...

Oct 17 19:11:08 conference jitsi-videobridge[25742]: Starting
jitsi-videobridge: jvb started.
Oct 17 19:11:08 conference systemd[1]: Started LSB: Jitsi Videobridge.
-----------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.013 second
response time |time=0.013187s;;;0.000000 size=159B;;;0
-----------------------------------------------------------------------

Here are the errors I see in the Chromium error console when trying to
start a conference. I was not able to copy the text to paste it here
because errors appear at regular intervals and that caused my selection
to be demarcated. So I took several screenshots.

https://ibin.co/3eDD8DaEyyBD.jpg
https://ibin.co/3eDDSCSsKHKB.jpg
https://ibin.co/3eDDiR3W2rLj.jpg
https://ibin.co/3eDDx6rKFOiu.jpg
https://ibin.co/3eDE8LjJ817Y.jpg
https://ibin.co/3eDEIxsxP8ky.jpg
https://ibin.co/3eDESKbwTSSO.jpg
https://ibin.co/3eDEuQmtfwmu.jpg
https://ibin.co/3eDF5MIiFd3C.jpg
https://ibin.co/3eDFFySMX0rx.jpg
https://ibin.co/3eDFSm7Av8x8.jpg
https://ibin.co/3eDFe0z9nnLe.jpg
https://ibin.co/3eDFrRMIneqQ.jpg
https://ibin.co/3eDGAUAREgLi.jpg
https://ibin.co/3eDGMLkkioqA.jpg

Any help is appreciated.

Thanks in advance.

Kind regards,
Daniel


#2

Hi,

···

On Oct 18, 2017, at 16:10, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Jitsi team!

Yesterday I updated the components of Jitsi Meet (testing repo) to the
following versions:

jicofo [1.0-371-1 -> 1.0-376-1]
jitsi-meet [1.0.2520-1 -> 1.0.2550-1]
jitsi-meet-prosody [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web-config [1.0.2352-1 -> 1.0.2372-1]
jitsi-videobridge [997-1 -> 1002-1]

The bridge seems to be up however I get an error checking its status:

-----------------------------------------------------------------------
root@conference:~# systemctl status jitsi-videobridge
● jitsi-videobridge.service - LSB: Jitsi Videobridge
  Loaded: loaded (/etc/init.d/jitsi-videobridge)
Drop-In: /etc/systemd/system/jitsi-videobridge.service.d
          └─override.conf
  Active: active (running) since Tue 2017-10-17 19:11:08 -03; 14h ago
Process: 25735 ExecStop=/etc/init.d/jitsi-videobridge stop
(code=exited, status=0/SUCCESS)
Process: 25742 ExecStart=/etc/init.d/jitsi-videobridge start
(code=exited, status=0/SUCCESS)
  CGroup: /system.slice/jitsi-videobridge.service
          └─25750 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=/tmp
-Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64
-Dnet.j...

Oct 17 19:11:08 conference jitsi-videobridge[25742]: Starting
jitsi-videobridge: jvb started.
Oct 17 19:11:08 conference systemd[1]: Started LSB: Jitsi Videobridge.
-----------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.013 second
response time |time=0.013187s;;;0.000000 size=159B;;;0
-----------------------------------------------------------------------

Here are the errors I see in the Chromium error console when trying to
start a conference. I was not able to copy the text to paste it here
because errors appear at regular intervals and that caused my selection
to be demarcated. So I took several screenshots.

https://ibin.co/3eDD8DaEyyBD.jpg
https://ibin.co/3eDDSCSsKHKB.jpg
https://ibin.co/3eDDiR3W2rLj.jpg
https://ibin.co/3eDDx6rKFOiu.jpg
https://ibin.co/3eDE8LjJ817Y.jpg
https://ibin.co/3eDEIxsxP8ky.jpg
https://ibin.co/3eDESKbwTSSO.jpg
https://ibin.co/3eDEuQmtfwmu.jpg
https://ibin.co/3eDF5MIiFd3C.jpg
https://ibin.co/3eDFFySMX0rx.jpg
https://ibin.co/3eDFSm7Av8x8.jpg
https://ibin.co/3eDFe0z9nnLe.jpg
https://ibin.co/3eDFrRMIneqQ.jpg
https://ibin.co/3eDGAUAREgLi.jpg
https://ibin.co/3eDGMLkkioqA.jpg

Any help is appreciated.

Do you have a customized interface_config.js? If so, make sure you have all options of our interface_config.js file. You might be missing this one:

INVITE_OPTIONS: ['invite', 'dialout', 'addtocall’],

Since it’s new.

Cheers,

--
Saúl


#3

Could be related to the smack update and the certificate verification issue that was fixed?

···

On Oct 18, 2017, at 12:08 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 18/10/17 11:27, Saúl Ibarra Corretgé wrote:

Hi,

Hi, Saúl.

Yesterday I updated the components of Jitsi Meet (testing repo) to the
following versions:

jicofo [1.0-371-1 -> 1.0-376-1]
jitsi-meet [1.0.2520-1 -> 1.0.2550-1]
jitsi-meet-prosody [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web-config [1.0.2352-1 -> 1.0.2372-1]
jitsi-videobridge [997-1 -> 1002-1]

The bridge seems to be up however I get an error checking its status:

-----------------------------------------------------------------------
root@conference:~# systemctl status jitsi-videobridge
● jitsi-videobridge.service - LSB: Jitsi Videobridge
Loaded: loaded (/etc/init.d/jitsi-videobridge)
Drop-In: /etc/systemd/system/jitsi-videobridge.service.d
         └─override.conf
Active: active (running) since Tue 2017-10-17 19:11:08 -03; 14h ago
Process: 25735 ExecStop=/etc/init.d/jitsi-videobridge stop
(code=exited, status=0/SUCCESS)
Process: 25742 ExecStart=/etc/init.d/jitsi-videobridge start
(code=exited, status=0/SUCCESS)
CGroup: /system.slice/jitsi-videobridge.service
         └─25750 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=/tmp
-Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64
-Dnet.j...

Oct 17 19:11:08 conference jitsi-videobridge[25742]: Starting
jitsi-videobridge: jvb started.
Oct 17 19:11:08 conference systemd[1]: Started LSB: Jitsi Videobridge.
-----------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.013 second
response time |time=0.013187s;;;0.000000 size=159B;;;0
-----------------------------------------------------------------------

Here are the errors I see in the Chromium error console when trying to
start a conference. I was not able to copy the text to paste it here
because errors appear at regular intervals and that caused my selection
to be demarcated. So I took several screenshots.

https://ibin.co/3eDD8DaEyyBD.jpg
https://ibin.co/3eDDSCSsKHKB.jpg
https://ibin.co/3eDDiR3W2rLj.jpg
https://ibin.co/3eDDx6rKFOiu.jpg
https://ibin.co/3eDE8LjJ817Y.jpg
https://ibin.co/3eDEIxsxP8ky.jpg
https://ibin.co/3eDESKbwTSSO.jpg
https://ibin.co/3eDEuQmtfwmu.jpg
https://ibin.co/3eDF5MIiFd3C.jpg
https://ibin.co/3eDFFySMX0rx.jpg
https://ibin.co/3eDFSm7Av8x8.jpg
https://ibin.co/3eDFe0z9nnLe.jpg
https://ibin.co/3eDFrRMIneqQ.jpg
https://ibin.co/3eDGAUAREgLi.jpg
https://ibin.co/3eDGMLkkioqA.jpg

Any help is appreciated.

Do you have a customized interface_config.js? If so, make sure you have
all options of our interface_config.js file. You might be missing
this one:>
INVITE_OPTIONS: ['invite', 'dialout', 'addtocall’],

Since it’s new.

Thanks for your reply.

I have added these lines that I did not have in my custom
interface_config.js file but I still cannot start a conference.

Maybe the problem is elsewhere because the bridge is not active. I have
restarted JVB and jicofo, but it made no difference unless you've
changed the test URL.

-------------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.010 second
response time |time=0.010436s;;;0.000000 size=159B;;;0
-------------------------------------------------------------------------

I'm also getting a repetitive message that says "conference focus is not
available".

These are the errors I'm seeing on the Chromium console. It seems that
there are three entries that are repeated over and over again in the
same sequence.

-------------------------------------------------------------------------
[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 1000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 1000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 1

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 2000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 2000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 2

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 4000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 4000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 4

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 8000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

Logger.js:125 [modules/xmpp/moderator.js]
<i._allocateConferenceFocusError>: Focus error, retry after 8000
-------------------------------------------------------------------------

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Have you checked jicofo logs on startup?

···

On Wed, Oct 18, 2017 at 12:13 PM, George Politis <gp@jitsi.org> wrote:

Could be related to the smack update and the certificate verification issue that was fixed?

On Oct 18, 2017, at 12:08 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 18/10/17 11:27, Saúl Ibarra Corretgé wrote:

Hi,

Hi, Saúl.

Yesterday I updated the components of Jitsi Meet (testing repo) to the
following versions:

jicofo [1.0-371-1 -> 1.0-376-1]
jitsi-meet [1.0.2520-1 -> 1.0.2550-1]
jitsi-meet-prosody [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web-config [1.0.2352-1 -> 1.0.2372-1]
jitsi-videobridge [997-1 -> 1002-1]

The bridge seems to be up however I get an error checking its status:

-----------------------------------------------------------------------
root@conference:~# systemctl status jitsi-videobridge
● jitsi-videobridge.service - LSB: Jitsi Videobridge
Loaded: loaded (/etc/init.d/jitsi-videobridge)
Drop-In: /etc/systemd/system/jitsi-videobridge.service.d
         └─override.conf
Active: active (running) since Tue 2017-10-17 19:11:08 -03; 14h ago
Process: 25735 ExecStop=/etc/init.d/jitsi-videobridge stop
(code=exited, status=0/SUCCESS)
Process: 25742 ExecStart=/etc/init.d/jitsi-videobridge start
(code=exited, status=0/SUCCESS)
CGroup: /system.slice/jitsi-videobridge.service
         └─25750 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=/tmp
-Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64
-Dnet.j...

Oct 17 19:11:08 conference jitsi-videobridge[25742]: Starting
jitsi-videobridge: jvb started.
Oct 17 19:11:08 conference systemd[1]: Started LSB: Jitsi Videobridge.
-----------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.013 second
response time |time=0.013187s;;;0.000000 size=159B;;;0
-----------------------------------------------------------------------

Here are the errors I see in the Chromium error console when trying to
start a conference. I was not able to copy the text to paste it here
because errors appear at regular intervals and that caused my selection
to be demarcated. So I took several screenshots.

https://ibin.co/3eDD8DaEyyBD.jpg
https://ibin.co/3eDDSCSsKHKB.jpg
https://ibin.co/3eDDiR3W2rLj.jpg
https://ibin.co/3eDDx6rKFOiu.jpg
https://ibin.co/3eDE8LjJ817Y.jpg
https://ibin.co/3eDEIxsxP8ky.jpg
https://ibin.co/3eDESKbwTSSO.jpg
https://ibin.co/3eDEuQmtfwmu.jpg
https://ibin.co/3eDF5MIiFd3C.jpg
https://ibin.co/3eDFFySMX0rx.jpg
https://ibin.co/3eDFSm7Av8x8.jpg
https://ibin.co/3eDFe0z9nnLe.jpg
https://ibin.co/3eDFrRMIneqQ.jpg
https://ibin.co/3eDGAUAREgLi.jpg
https://ibin.co/3eDGMLkkioqA.jpg

Any help is appreciated.

Do you have a customized interface_config.js? If so, make sure you have
all options of our interface_config.js file. You might be missing
this one:>
INVITE_OPTIONS: ['invite', 'dialout', 'addtocall’],

Since it’s new.

Thanks for your reply.

I have added these lines that I did not have in my custom
interface_config.js file but I still cannot start a conference.

Maybe the problem is elsewhere because the bridge is not active. I have
restarted JVB and jicofo, but it made no difference unless you've
changed the test URL.

-------------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.010 second
response time |time=0.010436s;;;0.000000 size=159B;;;0
-------------------------------------------------------------------------

I'm also getting a repetitive message that says "conference focus is not
available".

These are the errors I'm seeing on the Chromium console. It seems that
there are three entries that are repeated over and over again in the
same sequence.

-------------------------------------------------------------------------
[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 1000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 1000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 1

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 2000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 2000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 2

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 4000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 4000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 4

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 8000
   at i._allocateConferenceFocusError (moderator.js:411)
   at moderator.js:339
   at u.Handler.handler (strophe.js:2735)
   at u.Handler.run (strophe.js:2013)
   at strophe.js:3110
   at Object.forEachChild (strophe.js:993)
   at u.Connection._dataRecv (strophe.js:3098)
   at e.Bosh._onRequestStateChange (strophe.js:4729)

Logger.js:125 [modules/xmpp/moderator.js]
<i._allocateConferenceFocusError>: Focus error, retry after 8000
-------------------------------------------------------------------------

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

Hi, Saúl.

Yesterday I updated the components of Jitsi Meet (testing repo) to the
following versions:

jicofo [1.0-371-1 -> 1.0-376-1]
jitsi-meet [1.0.2520-1 -> 1.0.2550-1]
jitsi-meet-prosody [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web [1.0.2352-1 -> 1.0.2372-1]
jitsi-meet-web-config [1.0.2352-1 -> 1.0.2372-1]
jitsi-videobridge [997-1 -> 1002-1]

The bridge seems to be up however I get an error checking its status:

-----------------------------------------------------------------------
root@conference:~# systemctl status jitsi-videobridge
● jitsi-videobridge.service - LSB: Jitsi Videobridge
  Loaded: loaded (/etc/init.d/jitsi-videobridge)
Drop-In: /etc/systemd/system/jitsi-videobridge.service.d
          └─override.conf
  Active: active (running) since Tue 2017-10-17 19:11:08 -03; 14h ago
Process: 25735 ExecStop=/etc/init.d/jitsi-videobridge stop
(code=exited, status=0/SUCCESS)
Process: 25742 ExecStart=/etc/init.d/jitsi-videobridge start
(code=exited, status=0/SUCCESS)
  CGroup: /system.slice/jitsi-videobridge.service
          └─25750 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=/tmp
-Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64
-Dnet.j...

Oct 17 19:11:08 conference jitsi-videobridge[25742]: Starting
jitsi-videobridge: jvb started.
Oct 17 19:11:08 conference systemd[1]: Started LSB: Jitsi Videobridge.
-----------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.013 second
response time |time=0.013187s;;;0.000000 size=159B;;;0
-----------------------------------------------------------------------

Here are the errors I see in the Chromium error console when trying to
start a conference. I was not able to copy the text to paste it here
because errors appear at regular intervals and that caused my selection
to be demarcated. So I took several screenshots.

https://ibin.co/3eDD8DaEyyBD.jpg
https://ibin.co/3eDDSCSsKHKB.jpg
https://ibin.co/3eDDiR3W2rLj.jpg
https://ibin.co/3eDDx6rKFOiu.jpg
https://ibin.co/3eDE8LjJ817Y.jpg
https://ibin.co/3eDEIxsxP8ky.jpg
https://ibin.co/3eDESKbwTSSO.jpg
https://ibin.co/3eDEuQmtfwmu.jpg
https://ibin.co/3eDF5MIiFd3C.jpg
https://ibin.co/3eDFFySMX0rx.jpg
https://ibin.co/3eDFSm7Av8x8.jpg
https://ibin.co/3eDFe0z9nnLe.jpg
https://ibin.co/3eDFrRMIneqQ.jpg
https://ibin.co/3eDGAUAREgLi.jpg
https://ibin.co/3eDGMLkkioqA.jpg

Any help is appreciated.

Do you have a customized interface_config.js? If so, make sure you have
all options of our interface_config.js file. You might be missing
this one:>
INVITE_OPTIONS: ['invite', 'dialout', 'addtocall’],

Since it’s new.

Thanks for your reply.

I have added these lines that I did not have in my custom
interface_config.js file but I still cannot start a conference.

Maybe the problem is elsewhere because the bridge is not active. I have
restarted JVB and jicofo, but it made no difference unless you've
changed the test URL.

···

On 18/10/17 11:27, Saúl Ibarra Corretgé wrote:

-------------------------------------------------------------------------
root@conference:~# /usr/lib/nagios/plugins/check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.010 second
response time |time=0.010436s;;;0.000000 size=159B;;;0
-------------------------------------------------------------------------

I'm also getting a repetitive message that says "conference focus is not
available".

These are the errors I'm seeing on the Chromium console. It seems that
there are three entries that are repeated over and over again in the
same sequence.

-------------------------------------------------------------------------
[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 1000
    at i._allocateConferenceFocusError (moderator.js:411)
    at moderator.js:339
    at u.Handler.handler (strophe.js:2735)
    at u.Handler.run (strophe.js:2013)
    at strophe.js:3110
    at Object.forEachChild (strophe.js:993)
    at u.Connection._dataRecv (strophe.js:3098)
    at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 1000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 1

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 2000
    at i._allocateConferenceFocusError (moderator.js:411)
    at moderator.js:339
    at u.Handler.handler (strophe.js:2735)
    at u.Handler.run (strophe.js:2013)
    at strophe.js:3110
    at Object.forEachChild (strophe.js:993)
    at u.Connection._dataRecv (strophe.js:3098)
    at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 2000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 2

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 4000
    at i._allocateConferenceFocusError (moderator.js:411)
    at moderator.js:339
    at u.Handler.handler (strophe.js:2735)
    at u.Handler.run (strophe.js:2013)
    at strophe.js:3110
    at Object.forEachChild (strophe.js:993)
    at u.Connection._dataRecv (strophe.js:3098)
    at e.Bosh._onRequestStateChange (strophe.js:4729)

[modules/xmpp/moderator.js] <i._allocateConferenceFocusError>: Focus
error, retry after 4000

[conference.js] <e.value>: CONFERENCE FAILED:
conference.focusDisconnected focus.conf.opcion-libre.com.ar 4

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Focus error,
retry after 8000
    at i._allocateConferenceFocusError (moderator.js:411)
    at moderator.js:339
    at u.Handler.handler (strophe.js:2735)
    at u.Handler.run (strophe.js:2013)
    at strophe.js:3110
    at Object.forEachChild (strophe.js:993)
    at u.Connection._dataRecv (strophe.js:3098)
    at e.Bosh._onRequestStateChange (strophe.js:4729)

Logger.js:125 [modules/xmpp/moderator.js]
<i._allocateConferenceFocusError>: Focus error, retry after 8000
-------------------------------------------------------------------------

Thanks for your time.

Kind regards,
Daniel


#6

Hi, George/Damian.

Could be related to the smack update and the certificate verification
issue that was fixed?

After reading this reply, I checked for new updates and I applied the
following ones:

jicofo [1.0-376-1 -> 1.0-377-1]
jitsi-meet [1.0.2550-1 -> 1.0.2555-1]
jitsi-meet-prosody [1.0.2372-1 -> 1.0.2375-1]
jitsi-meet-web [1.0.2372-1 -> 1.0.2375-1]
jitsi-meet-web-config [1.0.2372-1 -> 1.0.2375-1]
jitsi-videobridge [1002-1 -> 1004-1]

But unfortunately this did not solve the problem and I still see the
three entries of the Chrome console (mentioned in the previous email)
that are repeated again and again.

Have you checked jicofo logs on startup?

Reviewing the jicofo log after restart, this part caught my attention:

···

On 18/10/17 14:41, Damian Minkov wrote:

-----------------------------------------------------------------------------
Jicofo 2017-10-18 18:28:19.622 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to
find jitsi-defaults.properties with class loader, will continue without it.
Jicofo 2017-10-18 18:28:19.624 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() Normal
classloader
Jicofo 2017-10-18 18:28:19.629 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to
find jitsi-default-overrides.properties with class loader, will continue
without it.
Jicofo 2017-10-18 18:28:19.721 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
permitted
        at
sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at
sun.nio.fs.UnixFileAttributeViews$Posix.setMode(UnixFileAttributeViews.java:230)

        at
sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(UnixFileAttributeViews.java:252)

        at java.nio.file.Files.setPosixFilePermissions(Files.java:1992)
        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.fixPermissions(ConfigurationActivator.java:166)

        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.start(ConfigurationActivator.java:87)

        at
org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
Jicofo 2017-10-18 18:28:19.847 INFO: [10]
util.NetworkUtils.<clinit>().117 java.net.preferIPv6Addresses=null
Jicofo 2017-10-18 18:28:19.849 INFO: [10]
util.NetworkUtils.<clinit>().118 java.net.preferIPv4Stack=null
Jicofo 2017-10-18 18:28:19.889 INFO: [10]
impl.netaddr.NetworkAddressManagerServiceImpl.start().92 Network Address
Manager ...[] STARTED ]
Jicofo 2017-10-18 18:28:19.897 INFO: [10]
impl.netaddr.NetworkAddressManagerServiceImpl.start().98 Network Address
Manager Service ...[REGISTERED]
Jicofo 2017-10-18 18:28:19.948 INFO: [10]
org.jitsi.version.AbstractVersionActivator.start().119 JiCoFo Version:
JiCoFo 1.0.1.0-377
Jicofo 2017-10-18 18:28:21.075 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().170 Automatically grant
'owner' role: true
Jicofo 2017-10-18 18:28:21.080 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().183 Jibri requests in
PENDING state will be timed out after: 90 seconds
Jicofo 2017-10-18 18:28:21.082 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().197 Lonely participants
will be "terminated" after 20000 milliseconds
Jicofo 2017-10-18 18:28:21.181 INFO: [10]
org.jitsi.jicofo.BridgeSelector.createBridgeSelectionStrategy().202
Using SingleBridgeSelectionStrategy
Jicofo 2017-10-18 18:28:21.185 INFO: [10]
org.jitsi.jicofo.BridgeSelector.<init>().172 Using
org.jitsi.jicofo.BridgeSelector$SingleBridgeSelectionStrategy
Jicofo 2017-10-18 18:28:21.189 INFO: [10]
org.jitsi.jicofo.BridgeSelector.init().685 Bridge failure reset
threshold: 300000
-----------------------------------------------------------------------------

Reviewing the JVB log after restart, it shows only the following:

-----------------------------------------------------------------------------
Exception in thread "main" java.lang.UnsupportedClassVersionError:
org/jitsi/videobridge/Main : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        at
sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
-----------------------------------------------------------------------------

Does it suggest something to you?

Thanks for your reply and your time.

Kind regards,
Daniel


#7

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

···

On Wed, Oct 18, 2017 at 4:38 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, George/Damian.

On 18/10/17 14:41, Damian Minkov wrote:

Could be related to the smack update and the certificate verification
issue that was fixed?

After reading this reply, I checked for new updates and I applied the
following ones:

jicofo [1.0-376-1 -> 1.0-377-1]
jitsi-meet [1.0.2550-1 -> 1.0.2555-1]
jitsi-meet-prosody [1.0.2372-1 -> 1.0.2375-1]
jitsi-meet-web [1.0.2372-1 -> 1.0.2375-1]
jitsi-meet-web-config [1.0.2372-1 -> 1.0.2375-1]
jitsi-videobridge [1002-1 -> 1004-1]

But unfortunately this did not solve the problem and I still see the
three entries of the Chrome console (mentioned in the previous email)
that are repeated again and again.

Have you checked jicofo logs on startup?

Reviewing the jicofo log after restart, this part caught my attention:

-----------------------------------------------------------------------------
Jicofo 2017-10-18 18:28:19.622 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to
find jitsi-defaults.properties with class loader, will continue without it.
Jicofo 2017-10-18 18:28:19.624 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() Normal
classloader
Jicofo 2017-10-18 18:28:19.629 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to
find jitsi-default-overrides.properties with class loader, will continue
without it.
Jicofo 2017-10-18 18:28:19.721 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
permitted
        at
sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at
sun.nio.fs.UnixFileAttributeViews$Posix.setMode(UnixFileAttributeViews.java:230)

        at
sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(UnixFileAttributeViews.java:252)

        at java.nio.file.Files.setPosixFilePermissions(Files.java:1992)
        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.fixPermissions(ConfigurationActivator.java:166)

        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.start(ConfigurationActivator.java:87)

        at
org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
Jicofo 2017-10-18 18:28:19.847 INFO: [10]
util.NetworkUtils.<clinit>().117 java.net.preferIPv6Addresses=null
Jicofo 2017-10-18 18:28:19.849 INFO: [10]
util.NetworkUtils.<clinit>().118 java.net.preferIPv4Stack=null
Jicofo 2017-10-18 18:28:19.889 INFO: [10]
impl.netaddr.NetworkAddressManagerServiceImpl.start().92 Network Address
Manager ...[] STARTED ]
Jicofo 2017-10-18 18:28:19.897 INFO: [10]
impl.netaddr.NetworkAddressManagerServiceImpl.start().98 Network Address
Manager Service ...[REGISTERED]
Jicofo 2017-10-18 18:28:19.948 INFO: [10]
org.jitsi.version.AbstractVersionActivator.start().119 JiCoFo Version:
JiCoFo 1.0.1.0-377
Jicofo 2017-10-18 18:28:21.075 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().170 Automatically grant
'owner' role: true
Jicofo 2017-10-18 18:28:21.080 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().183 Jibri requests in
PENDING state will be timed out after: 90 seconds
Jicofo 2017-10-18 18:28:21.082 INFO: [10]
org.jitsi.jicofo.JitsiMeetGlobalConfig.init().197 Lonely participants
will be "terminated" after 20000 milliseconds
Jicofo 2017-10-18 18:28:21.181 INFO: [10]
org.jitsi.jicofo.BridgeSelector.createBridgeSelectionStrategy().202
Using SingleBridgeSelectionStrategy
Jicofo 2017-10-18 18:28:21.185 INFO: [10]
org.jitsi.jicofo.BridgeSelector.<init>().172 Using
org.jitsi.jicofo.BridgeSelector$SingleBridgeSelectionStrategy
Jicofo 2017-10-18 18:28:21.189 INFO: [10]
org.jitsi.jicofo.BridgeSelector.init().685 Bridge failure reset
threshold: 300000
-----------------------------------------------------------------------------

Reviewing the JVB log after restart, it shows only the following:

-----------------------------------------------------------------------------
Exception in thread "main" java.lang.UnsupportedClassVersionError:
org/jitsi/videobridge/Main : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        at
sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
-----------------------------------------------------------------------------

Does it suggest something to you?

Thanks for your reply and your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi, Damian.

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I see. I had thought that maybe it might have to do with the Java
version, but I was not sure. I'm using java 7 with Debian Jessie here:

root@conference:~# aptitude search openjdk | grep ^i
i openjdk-7-jdk - OpenJDK Development Kit (JDK)
i A openjdk-7-jre - OpenJDK Java runtime, using
Hotspot JIT
i A openjdk-7-jre-headless - OpenJDK Java runtime, using
Hotspot JIT (h

Then I will have to configure the jessie-backports repository.

Thanks for your reply.

Kind regards,
Daniel

···

On 18/10/17 19:13, Damian Minkov wrote:


#9

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

Boris

···

On 18/10/2017 17:23, Daniel Bareiro wrote:

Hi, Damian.

On 18/10/17 19:13, Damian Minkov wrote:

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.


#10

Hi, Boris.

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

No problem. Thanks to you for having pushed this update.

I will wait for the next packet generation cycle for the testing repo.

As I already have java7 installed, after java8 is installed, do I have
to do some manual configuration to instruct Jitsi Meet about which of
the two versions of Java should it use?

Kind regards,
Daniel

···

On 18/10/17 19:38, Boris Grozev wrote:


#11

I don't know. Jitsi-videobridge will just run "java". If that doesn't work, please let us know (and as a quick fix you can hard-code the correct version in /usr/share/jitsi-videobridge/jvb.sh)

Regards,
Boris

···

On 19/10/2017 11:24, Daniel Bareiro wrote:

Hi, Boris.

On 18/10/17 19:38, Boris Grozev wrote:

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

No problem. Thanks to you for having pushed this update.

I will wait for the next packet generation cycle for the testing repo.

As I already have java7 installed, after java8 is installed, do I have
to do some manual configuration to instruct Jitsi Meet about which of
the two versions of Java should it use?


#12

Hi, Boris.

···

On 19/10/17 13:40, Boris Grozev wrote:

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

No problem. Thanks to you for having pushed this update.

I will wait for the next packet generation cycle for the testing repo.

As I already have java7 installed, after java8 is installed, do I have
to do some manual configuration to instruct Jitsi Meet about which of
the two versions of Java should it use?

I don't know. Jitsi-videobridge will just run "java". If that doesn't
work, please let us know (and as a quick fix you can hard-code the
correct version in /usr/share/jitsi-videobridge/jvb.sh)

Thanks for your reply.

I would like to test the changes you have applied but there is still no
new versions available in the testing repository. Is it possible that
something is postponing the generation of packages?

Kind regards,
Daniel


#13

Hi again, Boris/Jitsi team.

jvb.log (24.1 KB)

···

On 21/10/17 09:30, Daniel Bareiro wrote:

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

No problem. Thanks to you for having pushed this update.

I will wait for the next packet generation cycle for the testing repo.

As I already have java7 installed, after java8 is installed, do I have
to do some manual configuration to instruct Jitsi Meet about which of
the two versions of Java should it use?

I don't know. Jitsi-videobridge will just run "java". If that doesn't
work, please let us know (and as a quick fix you can hard-code the
correct version in /usr/share/jitsi-videobridge/jvb.sh)

Thanks for your reply.

I would like to test the changes you have applied but there is still no
new versions available in the testing repository. Is it possible that
something is postponing the generation of packages?

While I'm awaiting for the release of the new packages, I have installed
java8 from jessie-backports and I set java8 as default:

===========================================================================
root@conference:/usr/bin# update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection Path Priority
Status
------------------------------------------------------------
  0 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071
auto mode
  1 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071
manual mode
* 2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1069
manual mode

Press enter to keep the current choice[*], or type selection number:

root@conference:/usr/bin# java -version
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-1~bpo8+1-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

But still JVB is not getting up and running:

===========================================================================
root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.012 second
response time |time=0.011891s;;;0.000000 size=159B;;;0

Maybe I'm missing something? I attached the JVB logs after restart.

The log suggests that JVB is using java8, I think:

===========================================================================
JVB 2017-10-23 10:15:43.551 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
java.runtime.version=1.8.0_131-8u131-b11-1~bpo8+1-b11

In the log I also found this exception:

===========================================================================
JVB 2017-10-23 10:15:45.048 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation not
permitted

Kind regards,
Daniel


#14

I don't see anything suspicious in the jvb logs, what about jicofo logs?

···

On Mon, Oct 23, 2017 at 8:29 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi again, Boris/Jitsi team.

On 21/10/17 09:30, Daniel Bareiro wrote:

Hum, it seems something with latest updates from Boris of moving to
java8. Which java are you using?

Hey Boris, we also need to update the dependency of the debian package
to require java8.

I'm sorry, I missed that. I just pushed an update.

Thanks for looking into this.

No problem. Thanks to you for having pushed this update.

I will wait for the next packet generation cycle for the testing repo.

As I already have java7 installed, after java8 is installed, do I have
to do some manual configuration to instruct Jitsi Meet about which of
the two versions of Java should it use?

I don't know. Jitsi-videobridge will just run "java". If that doesn't
work, please let us know (and as a quick fix you can hard-code the
correct version in /usr/share/jitsi-videobridge/jvb.sh)

Thanks for your reply.

I would like to test the changes you have applied but there is still no
new versions available in the testing repository. Is it possible that
something is postponing the generation of packages?

While I'm awaiting for the release of the new packages, I have installed
java8 from jessie-backports and I set java8 as default:

===========================================================================
root@conference:/usr/bin# update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection Path Priority
Status
------------------------------------------------------------
  0 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071
auto mode
  1 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071
manual mode
* 2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1069
manual mode

Press enter to keep the current choice[*], or type selection number:

root@conference:/usr/bin# java -version
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-1~bpo8+1-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

But still JVB is not getting up and running:

===========================================================================
root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP CRITICAL: HTTP/1.1 500 Server Error - 159 bytes in 0.012 second
response time |time=0.011891s;;;0.000000 size=159B;;;0

Maybe I'm missing something? I attached the JVB logs after restart.

The log suggests that JVB is using java8, I think:

===========================================================================
JVB 2017-10-23 10:15:43.551 INFO: [10]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
java.runtime.version=1.8.0_131-8u131-b11-1~bpo8+1-b11

In the log I also found this exception:

===========================================================================
JVB 2017-10-23 10:15:45.048 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation not
permitted

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Hi, Damian.

jicofo_npe.log (37 KB)

···

On 23/10/17 19:11, Damian Minkov wrote:

I don't see anything suspicious in the jvb logs, what about jicofo logs?

Thanks for your reply.

I thought this exception in jvb.log might be problematic:

------------------------------------------------------------------------
JVB 2017-10-23 10:15:45.048 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation not
permitted
------------------------------------------------------------------------

So this is not suspicious?

I was reviewing Jicofo's logs and I found a similar exception:

------------------------------------------------------------------------
Jicofo 2017-10-23 19:42:04.420 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
permitted
        at
sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at
sun.nio.fs.UnixFileAttributeViews$Posix.setMode(UnixFileAttributeViews.java:238)

        at
sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(UnixFileAttributeViews.java:260)

        at java.nio.file.Files.setPosixFilePermissions(Files.java:2045)
        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.fixPermissions(ConfigurationActivator.java:166)

        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.start(ConfigurationActivator.java:87)

        at
org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
------------------------------------------------------------------------

However after restarting Jicofo, the bridge got up and running:

------------------------------------------------------------------------
root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP OK: HTTP/1.1 200 OK - 202 bytes in 0.037 second response time

time=0.037342s;;;0.000000 size=202B;;;0

------------------------------------------------------------------------

But when trying to enter a room, Jicofo shows a Null Pointer Exception.
I am attaching the logs of Jicofo for it.

The browser also displays a message saying "Focus [...] not available".

Thanks for your time.

Kind regards,
Daniel


#16

Hi, Damian.

I don't see anything suspicious in the jvb logs, what about jicofo logs?

Thanks for your reply.

I thought this exception in jvb.log might be problematic:

------------------------------------------------------------------------
JVB 2017-10-23 10:15:45.048 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation not
permitted
------------------------------------------------------------------------

So this is not suspicious?

I was reviewing Jicofo's logs and I found a similar exception:

------------------------------------------------------------------------
Jicofo 2017-10-23 19:42:04.420 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
permitted
        at
sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at
sun.nio.fs.UnixFileAttributeViews$Posix.setMode(UnixFileAttributeViews.java:238)

        at
sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(UnixFileAttributeViews.java:260)

        at java.nio.file.Files.setPosixFilePermissions(Files.java:2045)
        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.fixPermissions(ConfigurationActivator.java:166)

        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.start(ConfigurationActivator.java:87)

        at
org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
------------------------------------------------------------------------

Nope, these exceptions are harmless, we will address them at some
point. We've updated the configuration service in jvb and jicofo and
then we started seeing those.

However after restarting Jicofo, the bridge got up and running:

------------------------------------------------------------------------
root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP OK: HTTP/1.1 200 OK - 202 bytes in 0.037 second response time
>time=0.037342s;;;0.000000 size=202B;;;0
------------------------------------------------------------------------

But when trying to enter a room, Jicofo shows a Null Pointer Exception.
I am attaching the logs of Jicofo for it.

The browser also displays a message saying "Focus [...] not available".

Are you using authentication? Can you share your setup (meet, prosody
and jicofo)? It seems like not authenticated user is trying to create
a room or something like that, but I'm just guessing here based on the
exceptions and the iq error I see "not-authorized" that is coming from
guest.your.domain.

Regards
damencho

···

On Mon, Oct 23, 2017 at 6:05 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 23/10/17 19:11, Damian Minkov wrote:

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

Hi, Damian.

I don't see anything suspicious in the jvb logs, what about jicofo logs?

Thanks for your reply.

I thought this exception in jvb.log might be problematic:

------------------------------------------------------------------------
JVB 2017-10-23 10:15:45.048 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation not
permitted
------------------------------------------------------------------------

So this is not suspicious?

I was reviewing Jicofo's logs and I found a similar exception:

------------------------------------------------------------------------
Jicofo 2017-10-23 19:42:04.420 SEVERE: [10]
impl.configuration.ConfigurationActivator.log() Error creating c lib
instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
permitted
        at
sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at
sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at
sun.nio.fs.UnixFileAttributeViews$Posix.setMode(UnixFileAttributeViews.java:238)

        at
sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(UnixFileAttributeViews.java:260)

        at java.nio.file.Files.setPosixFilePermissions(Files.java:2045)
        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.fixPermissions(ConfigurationActivator.java:166)

        at
net.java.sip.communicator.impl.configuration.ConfigurationActivator.start(ConfigurationActivator.java:87)

        at
org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)

        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)

        at
org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
------------------------------------------------------------------------

Nope, these exceptions are harmless, we will address them at some
point. We've updated the configuration service in jvb and jicofo and
then we started seeing those.

Thanks for the clarification.

However after restarting Jicofo, the bridge got up and running:

------------------------------------------------------------------------
root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
8888 -u /about/health?list_jvb=true
HTTP OK: HTTP/1.1 200 OK - 202 bytes in 0.037 second response time
>time=0.037342s;;;0.000000 size=202B;;;0
------------------------------------------------------------------------

But when trying to enter a room, Jicofo shows a Null Pointer Exception.
I am attaching the logs of Jicofo for it.

The browser also displays a message saying "Focus [...] not available".

Are you using authentication? Can you share your setup (meet, prosody
and jicofo)? It seems like not authenticated user is trying to create
a room or something like that, but I'm just guessing here based on the
exceptions and the iq error I see "not-authorized" that is coming from
guest.your.domain.

Yes, I am using authentication here. Although I have not made any
changes to the configuration files before the upgrade. That is, that
configuration was working well before the upgrade. I suppose that at
some point it should appear the dialog to enter user/password, but it
doesn't happen.

I send you by private message the configuration files I am using. Let me
know if you need anything else, please.

Thanks for your reply and your time.

Kind regards,
Daniel

···

On 23/10/17 23:29, Damian Minkov wrote:


#18

Hi,

A problem is identified which affects versions in stable and unstable, we
are working on a fix.

Regards
damencho

···

On Tue, Oct 24, 2017 at 1:22 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 23/10/17 23:29, Damian Minkov wrote:

>>> I don't see anything suspicious in the jvb logs, what about jicofo
logs?

>> Thanks for your reply.
>>
>> I thought this exception in jvb.log might be problematic:
>>
>> ------------------------------------------------------------
------------
>> JVB 2017-10-23 10:15:45.048 SEVERE: [10]
>> impl.configuration.ConfigurationActivator.log() Error creating c lib
>> instance for fixing file permissions
>> java.nio.file.FileSystemException: /etc/jitsi/videobridge: Operation
not
>> permitted
>> ------------------------------------------------------------
------------
>>
>> So this is not suspicious?
>>
>> I was reviewing Jicofo's logs and I found a similar exception:
>>
>> ------------------------------------------------------------
------------
>> Jicofo 2017-10-23 19:42:04.420 SEVERE: [10]
>> impl.configuration.ConfigurationActivator.log() Error creating c lib
>> instance for fixing file permissions
>> java.nio.file.FileSystemException: /etc/jitsi/jicofo: Operation not
>> permitted
>> at
>> sun.nio.fs.UnixException.translateToIOException(UnixException.java:91)
>> at
>> sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
>> at
>> sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
>> at
>> sun.nio.fs.UnixFileAttributeViews$Posix.setMode(
UnixFileAttributeViews.java:238)
>>
>> at
>> sun.nio.fs.UnixFileAttributeViews$Posix.setPermissions(
UnixFileAttributeViews.java:260)
>>
>> at java.nio.file.Files.setPosixFilePermissions(Files.java:2045)
>> at
>> net.java.sip.communicator.impl.configuration.ConfigurationActivator.
fixPermissions(ConfigurationActivator.java:166)
>>
>> at
>> net.java.sip.communicator.impl.configuration.
ConfigurationActivator.start(ConfigurationActivator.java:87)
>>
>> at
>> org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
>> at
>> org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(
FrameworkImpl.java:460)
>>
>> at
>> org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$
Command.run(FrameworkStartLevelImpl.java:126)
>>
>> at
>> org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(
AsyncExecutor.java:111)
>>
>> at
>> org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(
AsyncExecutor.java:17)
>>
>> at
>> org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(
AsyncExecutor.java:220)
>> ------------------------------------------------------------
------------

> Nope, these exceptions are harmless, we will address them at some
> point. We've updated the configuration service in jvb and jicofo and
> then we started seeing those.

Thanks for the clarification.

>> However after restarting Jicofo, the bridge got up and running:
>>
>> ------------------------------------------------------------
------------
>> root@conference:/usr/lib/nagios/plugins# ./check_http -H localhost -p
>> 8888 -u /about/health?list_jvb=true
>> HTTP OK: HTTP/1.1 200 OK - 202 bytes in 0.037 second response time
>> >time=0.037342s;;;0.000000 size=202B;;;0
>> ------------------------------------------------------------
------------
>>
>> But when trying to enter a room, Jicofo shows a Null Pointer Exception.
>> I am attaching the logs of Jicofo for it.
>>
>> The browser also displays a message saying "Focus [...] not available".

> Are you using authentication? Can you share your setup (meet, prosody
> and jicofo)? It seems like not authenticated user is trying to create
> a room or something like that, but I'm just guessing here based on the
> exceptions and the iq error I see "not-authorized" that is coming from
> guest.your.domain.

Yes, I am using authentication here. Although I have not made any
changes to the configuration files before the upgrade. That is, that
configuration was working well before the upgrade. I suppose that at
some point it should appear the dialog to enter user/password, but it
doesn't happen.

I send you by private message the configuration files I am using. Let me
know if you need anything else, please.

Thanks for your reply and your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#19

Hi,

Hi, Damian. Thanks for coming back about this.

A problem is identified which affects versions in stable and unstable,
we are working on a fix.

Were you able to replicate it with the config files I sent you?

Does this problem only occur when authentication is configured?

Thanks for your time checking it.

Kind regards,
Daniel

···

On 27/10/17 16:15, Damian Minkov wrote:


#20

Hi again,

Yes, it is a problem with authentication configured, there is also an NPE
after we merged smack4, but this was a quick fix.
We discovered it is a problem and with the stable release.
I haven't looked through your configs, but the symptoms are the same and we
have tested with latest versions.

Regards
damencho

···

On Fri, Oct 27, 2017 at 2:43 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 27/10/17 16:15, Damian Minkov wrote:

> Hi,

Hi, Damian. Thanks for coming back about this.

> A problem is identified which affects versions in stable and unstable,
> we are working on a fix.

Were you able to replicate it with the config files I sent you?

Does this problem only occur when authentication is configured?

Thanks for your time checking it.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev