[jitsi-dev] Unable to run from IntelliJ


#1

Hey guys,

I've followed the instructions at
https://jitsi.org/Documentation/ConfigureIdeaNew for running jitsi from
IntellIj. However when I run the 'run' target from ant, the GUI doesn't pop
up, and I end up getting this stacktrace:

http://i.imgur.com/PK9wLWc.png

Any ideas?

Here's what I've done:

1) Checked out Gitsi's git repo via intelliJ

2) When the project runs the first time, it gives a bunch of errors about
ice4j.iml and libjitsi.iml not being found, and modules not being loaded. I
ignored them.

3) I configured Jdk 1.7 as the jdk to use.

4) I opened up the Ant tasks window and tried to run 'rebuild'. It
complained that jdk 1.6 was required for that, so I went into properties
and changed jdk to 1.7 instead. Rebuild then ran with 6 warnings but no
errors.

5) I then ran 'run'. I got the loading icon for a while, and then it ended
up in that screenshot I've posted above: http://i.imgur.com/PK9wLWc.png .
The GUI didn't come up.

I'm on Linux Mint, 32 bit.

Am I better off using Eclipse? Would appreciate any help, thanks.


#2

Forgot to mention, I have previously installed Jitsi on the same system,
via the installer. And it runs fine when run outside the IDE (via the
shortcut made by the installer)

ยทยทยท

On Thu, Oct 30, 2014 at 5:02 AM, Ali Akhtar <ali.rac200@gmail.com> wrote:

Hey guys,

I've followed the instructions at
https://jitsi.org/Documentation/ConfigureIdeaNew for running jitsi from
IntellIj. However when I run the 'run' target from ant, the GUI doesn't pop
up, and I end up getting this stacktrace:

http://i.imgur.com/PK9wLWc.png

Any ideas?

Here's what I've done:

1) Checked out Gitsi's git repo via intelliJ

2) When the project runs the first time, it gives a bunch of errors about
ice4j.iml and libjitsi.iml not being found, and modules not being loaded. I
ignored them.

3) I configured Jdk 1.7 as the jdk to use.

4) I opened up the Ant tasks window and tried to run 'rebuild'. It
complained that jdk 1.6 was required for that, so I went into properties
and changed jdk to 1.7 instead. Rebuild then ran with 6 warnings but no
errors.

5) I then ran 'run'. I got the loading icon for a while, and then it ended
up in that screenshot I've posted above: http://i.imgur.com/PK9wLWc.png .
The GUI didn't come up.

I'm on Linux Mint, 32 bit.

Am I better off using Eclipse? Would appreciate any help, thanks.