[jitsi-dev] Unable to access Jitsi Meet after configuring Jigasi


#1

Hi Jitsi Team!

After configuring Jigasi, I have not been able to access Jitsi Meet
again. I just get a gray screen. The only thing I did in config.js was
to uncomment the call_control line. Am I missing something?

This is what I see in the Chrome console:

···

----------------------------------------------------------------------
(TIME) index.html loaded: 787.2000000206754
(index):165 Uncaught SyntaxError: Unexpected identifier
Logger.js:125 [modules/browser/BrowserCapabilities.js] <new t>: This
appears to be chrome, ver: 65.0
AuthHandler.js:18 Uncaught ReferenceError: config is not defined
    at Object.<anonymous> (AuthHandler.js:18)
    at Object.<anonymous> (AuthHandler.js:229)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (connection.js:184)
    at Object.<anonymous> (connection.js:144)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (jquery.autosize.js:274)
    at Object.<anonymous> (conference.js:2757)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (Profile.js:191)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (Profile.js:191)
    at t (bootstrap 6b9338f…:19)
    at bootstrap 6b9338f…:62
    at bootstrap 6b9338f…:62
configLanguageDetector.js:22 Uncaught ReferenceError: config is not defined
    at Object.lookup (configLanguageDetector.js:22)
    at index.js:97
    at Array.forEach (<anonymous>)
    at e.value (index.js:95)
    at t.changeLanguage (i18next.js:286)
    at s (i18next.js:159)
----------------------------------------------------------------------

Thanks in advance.

Kind regards,
Daniel


#2

Maybe you are missing a comma or something, I suppose your config.js is
malformed. You don't need to uncomment that line, it will be
auto-discovered.

···

On Fri, Apr 13, 2018 at 3:12 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi Jitsi Team!

After configuring Jigasi, I have not been able to access Jitsi Meet
again. I just get a gray screen. The only thing I did in config.js was
to uncomment the call_control line. Am I missing something?

This is what I see in the Chrome console:

----------------------------------------------------------------------
(TIME) index.html loaded: 787.2000000206754
(index):165 Uncaught SyntaxError: Unexpected identifier
Logger.js:125 [modules/browser/BrowserCapabilities.js] <new t>: This
appears to be chrome, ver: 65.0
AuthHandler.js:18 Uncaught ReferenceError: config is not defined
    at Object.<anonymous> (AuthHandler.js:18)
    at Object.<anonymous> (AuthHandler.js:229)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (connection.js:184)
    at Object.<anonymous> (connection.js:144)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (jquery.autosize.js:274)
    at Object.<anonymous> (conference.js:2757)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (Profile.js:191)
    at t (bootstrap 6b9338f…:19)
    at Object.<anonymous> (Profile.js:191)
    at t (bootstrap 6b9338f…:19)
    at bootstrap 6b9338f…:62
    at bootstrap 6b9338f…:62
configLanguageDetector.js:22 Uncaught ReferenceError: config is not defined
    at Object.lookup (configLanguageDetector.js:22)
    at index.js:97
    at Array.forEach (<anonymous>)
    at e.value (index.js:95)
    at t.changeLanguage (i18next.js:286)
    at s (i18next.js:159)
----------------------------------------------------------------------

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi, Damian.

Maybe you are missing a comma or something, I suppose your config.js is
malformed.

I found it!

Yes. It was a syntax error.

It turns out that in the standard configuration, we only have 'muc' as
the only variable in the 'hosts' block. That's why it does not have a
comma at the end. But when I uncommented 'call_control' below, I left it
with a comma at the end. Then I removed that comma and added a comma in
'muc'. Problem solved :slight_smile:

You don't need to uncomment that line, it will be auto-discovered.

Ah! I thought it was necessary. So that line is still there commented
from when it was necessary to add that configuration?

Thanks for your time.

Kind regards,
Daniel

···

On 13/04/18 17:23, Damian Minkov wrote:


#4

Hi, Damian.

> Maybe you are missing a comma or something, I suppose your config.js is
> malformed.

I found it!

Yes. It was a syntax error.

It turns out that in the standard configuration, we only have 'muc' as
the only variable in the 'hosts' block. That's why it does not have a
comma at the end. But when I uncommented 'call_control' below, I left it
with a comma at the end. Then I removed that comma and added a comma in
'muc'. Problem solved :slight_smile:

> You don't need to uncomment that line, it will be auto-discovered.

Ah! I thought it was necessary. So that line is still there commented
from when it was necessary to add that configuration?

Yep it was long time ago when this autodicovery was not implemented. We
need to remove it from the template.

···

On Fri, Apr 13, 2018 at 3:55 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 13/04/18 17:23, Damian Minkov wrote:

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Perfect. I will take note of this.

Thanks, Damian!

Kind regards,
Daniel

···

On 13/04/18 18:14, Damian Minkov wrote:

> > You don't need to uncomment that line, it will be auto-discovered.

> Ah! I thought it was necessary. So that line is still there commented
> from when it was necessary to add that configuration?

Yep it was long time ago when this autodicovery was not implemented. We
need to remove it from the template.