[jitsi-dev] Unable to accept call in google voice


#1

Hi

I have installed jitsi-1.0-beta1-nightly.build.3682-x64.exe, I
am experiencing problems in accepting Google Voice calls, When i pick up the
phone, using jitsi, Google voice says to press '1' to accept the call, when
i open up dialer in the jitsi option menu, it does not send the DTMF code
and in turn google voice transfers the call to voice mail.

Please help.

thanks


#2

Hey there,

I suspect you are getting the call through a SIP provider. Is this
correct? Jitsi currently only supports DTMFs through RTP and SIP INFO,
make sure that your SIP provider handles them and can properly relay
them to Google Voice.

Cheers,
Emil

На 29.09.11 20:44, shariq muhammad написа:

···

Hi

I have installed jitsi-1.0-beta1-nightly.build.3682-x64.exe, I
am experiencing problems in accepting Google Voice calls, When i pick up
the phone, using jitsi, Google voice says to press '1' to accept the
call, when i open up dialer in the jitsi option menu, it does not send
the DTMF code and in turn google voice transfers the call to voice mail.

Please help.

thanks

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#3

Hi Emil,

I have configured Google Voice directly, the same thing works when i use the
yate desktop client.

Their is no SIP in between but may be Windows 7 x64 i am using may be the
audio routing is having problem for DTMF. Although i can hear DTMF short
burst in headphones but its not going to GV end. another possibility can be
that certain sound cards implement a feedback loop between speaker and mic,
if you guys test disabling that i think the scenario will reproduce, mine
does not feedback the speakers back into mic audio.

Thanks,
Shariq

···

On Fri, Sep 30, 2011 at 6:15 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey there,

I suspect you are getting the call through a SIP provider. Is this
correct? Jitsi currently only supports DTMFs through RTP and SIP INFO,
make sure that your SIP provider handles them and can properly relay
them to Google Voice.

Cheers,
Emil

На 29.09.11 20:44, shariq muhammad написа:
>
> Hi
>
> I have installed jitsi-1.0-beta1-nightly.build.3682-x64.exe, I
> am experiencing problems in accepting Google Voice calls, When i pick up
> the phone, using jitsi, Google voice says to press '1' to accept the
> call, when i open up dialer in the jitsi option menu, it does not send
> the DTMF code and in turn google voice transfers the call to voice mail.
>
> Please help.
>
> thanks

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#4

Hi all,

DTMF is currently not implemented for XMPP. We only support DTMF for SIP right now and we will implement it for XMPP in the near future.

Regards,

···

--
Seb

Le 30/09/11 17:35, shariq muhammad a écrit :

Hi Emil,

I have configured Google Voice directly, the same thing works when i use the yate desktop client.

Their is no SIP in between but may be Windows 7 x64 i am using may be the audio routing is having problem for DTMF. Although i can hear DTMF short burst in headphones but its not going to GV end. another possibility can be that certain sound cards implement a feedback loop between speaker and mic, if you guys test disabling that i think the scenario will reproduce, mine does not feedback the speakers back into mic audio.

Thanks,
Shariq

On Fri, Sep 30, 2011 at 6:15 AM, Emil Ivov <emcho@jitsi.org > <mailto:emcho@jitsi.org>> wrote:

    Hey there,

    I suspect you are getting the call through a SIP provider. Is this
    correct? Jitsi currently only supports DTMFs through RTP and SIP INFO,
    make sure that your SIP provider handles them and can properly relay
    them to Google Voice.

    Cheers,
    Emil

    На 29.09.11 20:44, shariq muhammad написа:
    >
    > Hi
    >
    > I have installed jitsi-1.0-beta1-nightly.build.3682-x64.exe, I
    > am experiencing problems in accepting Google Voice calls, When i
    pick up
    > the phone, using jitsi, Google voice says to press '1' to accept the
    > call, when i open up dialer in the jitsi option menu, it does
    not send
    > the DTMF code and in turn google voice transfers the call to
    voice mail.
    >
    > Please help.
    >
    > thanks

    --
    Emil Ivov, Ph.D. 67000 Strasbourg,
    Project Lead France
    Jitsi
    emcho@jitsi.org <mailto:emcho@jitsi.org> PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
    http://jitsi.org FAX: +33.1.77.62.47.31
    <tel:%2B33.1.77.62.47.31>