[jitsi-dev] Ugly Layout on Debian


#1

Hey

While I looked at the spellcheck stuff, I noticed GTK warnings and the ugly
layout that other also mentioned before. Installing the package
"gtk2-engines-pixbuf" solves the warning and Jitsi runs with a proper
layout.
According to some Ubuntu bugs [1,2] that package should no longer be needed
for GTK, but apparently it is needed - at least by us or the Java bindings.
-> Should we list gtk2-engines-pixbuf as a dependency for Jitsi?

Ingo

[1] https://bugs.launchpad.net/ubuntu/+source/quickly/+bug/853232
[2] https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/762167


#2

Yes, we should probably do this indeed.

···

On Mon, Nov 18, 2013 at 9:23 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

Hey

While I looked at the spellcheck stuff, I noticed GTK warnings and the ugly
layout that other also mentioned before. Installing the package
"gtk2-engines-pixbuf" solves the warning and Jitsi runs with a proper
layout.
According to some Ubuntu bugs [1,2] that package should no longer be needed
for GTK, but apparently it is needed - at least by us or the Java bindings.
-> Should we list gtk2-engines-pixbuf as a dependency for Jitsi?

Ingo

[1] https://bugs.launchpad.net/ubuntu/+source/quickly/+bug/853232
[2] https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/762167

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#3

Java is somewhat weird and often looks really crappy on Linux. At least
on the distribution I'm using (Arch Linux) it uses the butt-ugly default
style. So for those who have this issue, executing the following line
should help a bit (on login would be best).

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=gasp
-Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'

I assume some distros (Ubuntu) do this by default. Can't comment on the
gtk2-engines-pixbuf issue since there's no such package on Arch.

Regards,
Philipp

···

On Mon, 18 Nov 2013 21:23:37 +0100 "Ingo Bauersachs" <ingo@jitsi.org> wrote:

Hey

While I looked at the spellcheck stuff, I noticed GTK warnings and
the ugly layout that other also mentioned before. Installing the
package "gtk2-engines-pixbuf" solves the warning and Jitsi runs with
a proper layout.
According to some Ubuntu bugs [1,2] that package should no longer be
needed for GTK, but apparently it is needed - at least by us or the
Java bindings. -> Should we list gtk2-engines-pixbuf as a dependency
for Jitsi?

Ingo

[1] https://bugs.launchpad.net/ubuntu/+source/quickly/+bug/853232
[2] https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/762167