[jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04


#1

Hi,
First of all I hope that this mailing list is the right place to ask this kind of questions - if this is not the case please accept my apologies and redirect me ;)!

I am trying to install jitsi-meet by following the manual installation instructions (https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md ) on Ubuntu 16.04 server. Following the instructions the installation of jicofo component did not work, so I used the procedure from https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-ubuntu-14-04/ (maven and dependencies). The build was successful, however now I have the problem of "connecting" jicofo component to prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is password that I used when registering user in prosody with --> prosodyctl register focus auth.194.249.1.37 GESLO001):
                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG --user_domain=auth.194.249.1.37 --user_name=focus --user_password=GESLO001 </dev/null >> /var/log/jicofo/jicofo.log 2>&1 &

The prosody log gives me:
Sep 05 17:54:43 focus.194.249.1.37:component warn Component not connected, bouncing error for: <iq id='f4Wwi-8' type='get' to='focus.194.249.1.37' from='focus@auth.194.249.1.37/focus23879797006114'>
Jicofo log gives me:
Jicofo 2016-09-06 12:38:09.910 SEVERE: [30] org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException: Connection refused, host:194.249.1.37, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused

I am running all of the components on one machine. Also the jitsi-videobridge connects successfully to prosody. I believe this suggests it is not the firewall/NAT problem. I checked the prosody configuration (see below) and it seems to be right (according to the installation instructions). Can somebody help me with this please? What am I doing wrong? How could I debug this further (the log information is not very helpful).

VirtualHost "194.249.1.37"
      authentication = "anonymous"
      ssl = {
            key = "/var/lib/prosody/194.249.1.37.key";
            certificate = "/var/lib/prosody/194.249.1.37.crt";
      }
      modules_enabled = {
            "bosh";
            "pubsub";
      }
VirtualHost "auth.194.249.1.37"
      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"
      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"
      component_secret = "TE36khMG"

Cheers,
Jernej

···

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------


#2

Hi,

Make sure prosody is listening on 194.249.1.37:5347.
component_ports = { 5347 }
component_interface = "194.249.1.37"

Regards
damencho

···

On Wed, Sep 7, 2016 at 5:56 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

First of all I hope that this mailing list is the right place to ask this
kind of questions – if this is not the case please accept my apologies and
redirect me ;)!

I am trying to install jitsi-meet by following the manual installation
instructions
(https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md ) on
Ubuntu 16.04 server. Following the instructions the installation of jicofo
component did not work, so I used the procedure from
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-ubuntu-14-04/
(maven and dependencies). The build was successful, however now I have the
problem of “connecting” jicofo component to prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is password
that I used when registering user in prosody with à prosodyctl register
focus auth.194.249.1.37 GESLO001):

                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG
--user_domain=auth.194.249.1.37 --user_name=focus --user_password=GESLO001
</dev/null >> /var/log/jicofo/jicofo.log 2>&1 &

The prosody log gives me:

Sep 05 17:54:43 focus.194.249.1.37:component warn Component not
connected, bouncing error for: <iq id='f4Wwi-8' type='get'
to='focus.194.249.1.37' from='focus@auth.194.249.1.37/focus23879797006114'>

Jicofo log gives me:

Jicofo 2016-09-06 12:38:09.910 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused, host:194.249.1.37, port:5347

org.xmpp.component.ComponentException: java.net.ConnectException: Connection
refused

I am running all of the components on one machine. Also the
jitsi-videobridge connects successfully to prosody. I believe this suggests
it is not the firewall/NAT problem. I checked the prosody configuration (see
below) and it seems to be right (according to the installation
instructions). Can somebody help me with this please? What am I doing
wrong? How could I debug this further (the log information is not very
helpful).

VirtualHost "194.249.1.37"

      authentication = "anonymous"

      ssl = {

            key = "/var/lib/prosody/194.249.1.37.key";

            certificate = "/var/lib/prosody/194.249.1.37.crt";

      }

      modules_enabled = {

            "bosh";

            "pubsub";

      }

VirtualHost "auth.194.249.1.37"

      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"

      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"

      component_secret = "TE36khMG"

Cheers,

Jernej

------------------------------------------------
Jernej Trnkoczy

Researcher

Faculty of Civil and Geodetic Engineering

University of Ljubljana

Phone: +386 1 4768 588

e-mail: jernej.trnkoczy@fgg.uni-lj.si

------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Damian,
After adding the lines
component_ports = { 5347 }
component_interface = "194.249.1.37"

to /etc/prosody/conf.avail/194.249.1.37.cfg.lua I now get the following error in prosody log:
: Sep 07 16:36:53 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address.

Now this is strange because I double-checked the ports with netstat. To be completely sure there is no firewall/NAT issue I installed Tomcat, reconfigured it to port 5347 and sent the request from another network - it works just fine. I have no clue why Prosody has the problem with "assigning the requested address". Any recommendations?

Cheers,
Jernej

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. september 2016 16:10
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

Make sure prosody is listening on 194.249.1.37:5347.
component_ports = { 5347 }
component_interface = "194.249.1.37"

Regards
damencho

On Wed, Sep 7, 2016 at 5:56 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

First of all I hope that this mailing list is the right place to ask
this kind of questions – if this is not the case please accept my
apologies and redirect me ;)!

I am trying to install jitsi-meet by following the manual installation
instructions
(https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
) on Ubuntu 16.04 server. Following the instructions the installation
of jicofo component did not work, so I used the procedure from
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-u
buntu-14-04/ (maven and dependencies). The build was successful,
however now I have the problem of “connecting” jicofo component to
prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is
password that I used when registering user in prosody with à
prosodyctl register focus auth.194.249.1.37 GESLO001):

                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG
--user_domain=auth.194.249.1.37 --user_name=focus
--user_password=GESLO001 </dev/null >> /var/log/jicofo/jicofo.log 2>&1
&

The prosody log gives me:

Sep 05 17:54:43 focus.194.249.1.37:component warn Component not
connected, bouncing error for: <iq id='f4Wwi-8' type='get'
to='focus.194.249.1.37'
from='focus@auth.194.249.1.37/focus23879797006114'>

Jicofo log gives me:

Jicofo 2016-09-06 12:38:09.910 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused, host:194.249.1.37, port:5347

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused

I am running all of the components on one machine. Also the
jitsi-videobridge connects successfully to prosody. I believe this
suggests it is not the firewall/NAT problem. I checked the prosody
configuration (see
below) and it seems to be right (according to the installation
instructions). Can somebody help me with this please? What am I doing
wrong? How could I debug this further (the log information is not very
helpful).

VirtualHost "194.249.1.37"

      authentication = "anonymous"

      ssl = {

            key = "/var/lib/prosody/194.249.1.37.key";

            certificate = "/var/lib/prosody/194.249.1.37.crt";

      }

      modules_enabled = {

            "bosh";

            "pubsub";

      }

VirtualHost "auth.194.249.1.37"

      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"

      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"

      component_secret = "TE36khMG"

Cheers,

Jernej

------------------------------------------------
Jernej Trnkoczy

Researcher

Faculty of Civil and Geodetic Engineering

University of Ljubljana

Phone: +386 1 4768 588

e-mail: jernej.trnkoczy@fgg.uni-lj.si

------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

194.249.1.37 is a local address for the machine right?
If it is, I have no idea why prosody fails to bind to it.

···

On Wed, Sep 7, 2016 at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,
After adding the lines
component_ports = { 5347 }
component_interface = "194.249.1.37"

to /etc/prosody/conf.avail/194.249.1.37.cfg.lua I now get the following error in prosody log:
: Sep 07 16:36:53 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address.

Now this is strange because I double-checked the ports with netstat. To be completely sure there is no firewall/NAT issue I installed Tomcat, reconfigured it to port 5347 and sent the request from another network - it works just fine. I have no clue why Prosody has the problem with "assigning the requested address". Any recommendations?

Cheers,
Jernej

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. september 2016 16:10
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

Make sure prosody is listening on 194.249.1.37:5347.
component_ports = { 5347 }
component_interface = "194.249.1.37"

Regards
damencho

On Wed, Sep 7, 2016 at 5:56 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

First of all I hope that this mailing list is the right place to ask
this kind of questions – if this is not the case please accept my
apologies and redirect me ;)!

I am trying to install jitsi-meet by following the manual installation
instructions
(https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
) on Ubuntu 16.04 server. Following the instructions the installation
of jicofo component did not work, so I used the procedure from
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-u
buntu-14-04/ (maven and dependencies). The build was successful,
however now I have the problem of “connecting” jicofo component to
prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is
password that I used when registering user in prosody with à
prosodyctl register focus auth.194.249.1.37 GESLO001):

                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG
--user_domain=auth.194.249.1.37 --user_name=focus
--user_password=GESLO001 </dev/null >> /var/log/jicofo/jicofo.log 2>&1
&

The prosody log gives me:

Sep 05 17:54:43 focus.194.249.1.37:component warn Component not
connected, bouncing error for: <iq id='f4Wwi-8' type='get'
to='focus.194.249.1.37'
from='focus@auth.194.249.1.37/focus23879797006114'>

Jicofo log gives me:

Jicofo 2016-09-06 12:38:09.910 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused, host:194.249.1.37, port:5347

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused

I am running all of the components on one machine. Also the
jitsi-videobridge connects successfully to prosody. I believe this
suggests it is not the firewall/NAT problem. I checked the prosody
configuration (see
below) and it seems to be right (according to the installation
instructions). Can somebody help me with this please? What am I doing
wrong? How could I debug this further (the log information is not very
helpful).

VirtualHost "194.249.1.37"

      authentication = "anonymous"

      ssl = {

            key = "/var/lib/prosody/194.249.1.37.key";

            certificate = "/var/lib/prosody/194.249.1.37.crt";

      }

      modules_enabled = {

            "bosh";

            "pubsub";

      }

VirtualHost "auth.194.249.1.37"

      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"

      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"

      component_secret = "TE36khMG"

Cheers,

Jernej

------------------------------------------------
Jernej Trnkoczy

Researcher

Faculty of Civil and Geodetic Engineering

University of Ljubljana

Phone: +386 1 4768 588

e-mail: jernej.trnkoczy@fgg.uni-lj.si

------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi Jernej,

I strongly suggest setting up Jitsi-Meet on Debian instead of Ubuntu.

I encountered many problems with Ubuntu before, but initial installation on Debian went much smoother.

Cheers,

Sunny

···

Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: dev <dev-bounces@jitsi.org> on behalf of Damian Minkov <damencho@jitsi.org>
Sent: Wednesday, September 7, 2016 9:31 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

194.249.1.37 is a local address for the machine right?
If it is, I have no idea why prosody fails to bind to it.

On Wed, Sep 7, 2016 at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,
After adding the lines
component_ports = { 5347 }
component_interface = "194.249.1.37"

to /etc/prosody/conf.avail/194.249.1.37.cfg.lua I now get the following error in prosody log:
: Sep 07 16:36:53 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address.

Now this is strange because I double-checked the ports with netstat. To be completely sure there is no firewall/NAT issue I installed Tomcat, reconfigured it to port 5347 and sent the request from another network - it works just fine. I have no clue why Prosody has the problem with "assigning the requested address". Any recommendations?

Cheers,
Jernej

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. september 2016 16:10
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

Make sure prosody is listening on 194.249.1.37:5347.
component_ports = { 5347 }
component_interface = "194.249.1.37"

Regards
damencho

On Wed, Sep 7, 2016 at 5:56 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

First of all I hope that this mailing list is the right place to ask
this kind of questions – if this is not the case please accept my
apologies and redirect me ;)!

I am trying to install jitsi-meet by following the manual installation
instructions
(https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
) on Ubuntu 16.04 server. Following the instructions the installation
of jicofo component did not work, so I used the procedure from
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-u
buntu-14-04/ (maven and dependencies). The build was successful,
however now I have the problem of “connecting” jicofo component to
prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is
password that I used when registering user in prosody with à
prosodyctl register focus auth.194.249.1.37 GESLO001):

                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG
--user_domain=auth.194.249.1.37 --user_name=focus
--user_password=GESLO001 </dev/null >> /var/log/jicofo/jicofo.log 2>&1
&

The prosody log gives me:

Sep 05 17:54:43 focus.194.249.1.37:component warn Component not
connected, bouncing error for: <iq id='f4Wwi-8' type='get'
to='focus.194.249.1.37'
from='focus@auth.194.249.1.37/focus23879797006114'>

Jicofo log gives me:

Jicofo 2016-09-06 12:38:09.910 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused, host:194.249.1.37, port:5347

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused

I am running all of the components on one machine. Also the
jitsi-videobridge connects successfully to prosody. I believe this
suggests it is not the firewall/NAT problem. I checked the prosody
configuration (see
below) and it seems to be right (according to the installation
instructions). Can somebody help me with this please? What am I doing
wrong? How could I debug this further (the log information is not very
helpful).

VirtualHost "194.249.1.37"

      authentication = "anonymous"

      ssl = {

            key = "/var/lib/prosody/194.249.1.37.key";

            certificate = "/var/lib/prosody/194.249.1.37.crt";

      }

      modules_enabled = {

            "bosh";

            "pubsub";

      }

VirtualHost "auth.194.249.1.37"

      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"

      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"

      component_secret = "TE36khMG"

Cheers,

Jernej

------------------------------------------------
Jernej Trnkoczy

Researcher

Faculty of Civil and Geodetic Engineering

University of Ljubljana

Phone: +386 1 4768 588

e-mail: jernej.trnkoczy@fgg.uni-lj.si

------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi Damien,
The IP number 194.249.1.37 is a public IP of the machine where I am installing Prosody. There is no private networking configured on this machine. As I said I have no problems of running Apache Tomcat configured on port 5347 on this machine - I can access Tomcat services using 194.249.1.37:5347 without any problems. I have no idea why Prosody has problems accessing this port (of course I stopped and uninstalled Tomcat before running prosody ;). Below is a complete prosody log (in debug mode) - in case anybody sees something suspicious there... Unfortunately I am not familiar with Prosody and it's "peculiarities".
I will now try to install jitsi meet on Debian - as Sunny reported he encountered many problems with Ubuntu, but in his experience installation on Debian went much smoother... I'll get back to report if Debian proves to be the magic cure :)!

Sep 08 09:57:18 general info Hello and welcome to Prosody version 0.9.10
Sep 08 09:57:19 general info Prosody is using the select backend for connection handling
Sep 08 09:57:19 hostmanager debug Activated host: 194.249.1.37
Sep 08 09:57:19 usermanager debug host '194.249.1.37' now set to use user provider 'anonymous'
Sep 08 09:57:19 portmanager debug No active service for http, activating...
Sep 08 09:57:19 socket debug server.lua: new server listener on '[::]:5280'
Sep 08 09:57:19 portmanager debug Added listening service http to [::]:5280
Sep 08 09:57:19 socket debug server.lua: new server listener on '[*]:5280'
Sep 08 09:57:19 portmanager debug Added listening service http to [*]:5280
Sep 08 09:57:19 portmanager info Activated service 'http' on [::]:5280, [*]:5280
Sep 08 09:57:19 portmanager debug No active service for https, activating...
Sep 08 09:57:19 socket debug server.lua: new ssl server listener on '[::]:5281'
Sep 08 09:57:19 portmanager debug Added listening service https to [::]:5281
Sep 08 09:57:19 socket debug server.lua: new ssl server listener on '[*]:5281'
Sep 08 09:57:19 portmanager debug Added listening service https to [*]:5281
Sep 08 09:57:19 portmanager info Activated service 'https' on [::]:5281, [*]:5281
Sep 08 09:57:19 194.249.1.37:http debug Serving 'bosh' at https://194.249.1.37:5281/http-bind
Sep 08 09:57:20 portmanager debug No active service for c2s, activating...
Sep 08 09:57:20 socket debug server.lua: new server listener on '[::]:5222'
Sep 08 09:57:20 portmanager debug Added listening service c2s to [::]:5222
Sep 08 09:57:20 socket debug server.lua: new server listener on '[*]:5222'
Sep 08 09:57:20 portmanager debug Added listening service c2s to [*]:5222
Sep 08 09:57:20 portmanager info Activated service 'c2s' on [::]:5222, [*]:5222
Sep 08 09:57:20 portmanager debug No active service for legacy_ssl, activating...
Sep 08 09:57:20 portmanager info Activated service 'legacy_ssl' on no ports
Sep 08 09:57:20 portmanager debug No active service for s2s, activating...
Sep 08 09:57:20 socket debug server.lua: new server listener on '[::]:5269'
Sep 08 09:57:20 portmanager debug Added listening service s2s to [::]:5269
Sep 08 09:57:20 socket debug server.lua: new server listener on '[*]:5269'
Sep 08 09:57:20 portmanager debug Added listening service s2s to [*]:5269
Sep 08 09:57:20 portmanager info Activated service 's2s' on [::]:5269, [*]:5269
Sep 08 09:57:20 mod_posix info Prosody is about to detach from the console, disabling further console output
Sep 08 09:57:20 mod_posix info Successfully daemonized to PID 17445
Sep 08 09:57:20 hostmanager debug Activated host: localhost
Sep 08 09:57:20 localhost:auth_internal_plain debug initializing internal_plain authentication provider for host 'localhost'
Sep 08 09:57:20 usermanager debug host 'localhost' now set to use user provider 'internal_plain'
Sep 08 09:57:20 hostmanager debug Activated host: auth.194.249.1.37
Sep 08 09:57:20 auth.194.249.1.37:auth_internal_plain debug initializing internal_plain authentication provider for host 'auth.194.249.1.37'
Sep 08 09:57:20 usermanager debug host 'auth.194.249.1.37' now set to use user provider 'internal_plain'
Sep 08 09:57:20 hostmanager debug Activated host: conference.194.249.1.37
Sep 08 09:57:20 datamanager debug Assuming empty persistent storage ('cannot open /var/lib/prosody/conference%2e194%2e249%2e1%2e37/persistent.dat: No such file or directory') for user: nil@conference.194.249.1.37
Sep 08 09:57:20 hostmanager debug Activated host: jitsi-videobridge.194.249.1.37
Sep 08 09:57:20 portmanager debug No active service for component, activating...
Sep 08 09:57:20 socket warn server.lua, [193.249.1.37]:5347: Cannot assign requested address
Sep 08 09:57:20 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address
Sep 08 09:57:20 portmanager info Activated service 'component' on no ports
Sep 08 09:57:20 hostmanager debug Activated host: focus.194.249.1.37

Cheers,
Jernej

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. september 2016 18:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

194.249.1.37 is a local address for the machine right?
If it is, I have no idea why prosody fails to bind to it.

On Wed, Sep 7, 2016 at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,
After adding the lines
component_ports = { 5347 }
component_interface = "194.249.1.37"

to /etc/prosody/conf.avail/194.249.1.37.cfg.lua I now get the following error in prosody log:
: Sep 07 16:36:53 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address.

Now this is strange because I double-checked the ports with netstat. To be completely sure there is no firewall/NAT issue I installed Tomcat, reconfigured it to port 5347 and sent the request from another network - it works just fine. I have no clue why Prosody has the problem with "assigning the requested address". Any recommendations?

Cheers,
Jernej

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. september 2016 16:10
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

Make sure prosody is listening on 194.249.1.37:5347.
component_ports = { 5347 }
component_interface = "194.249.1.37"

Regards
damencho

On Wed, Sep 7, 2016 at 5:56 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

First of all I hope that this mailing list is the right place to ask
this kind of questions – if this is not the case please accept my
apologies and redirect me ;)!

I am trying to install jitsi-meet by following the manual
installation instructions
(https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.m
d
) on Ubuntu 16.04 server. Following the instructions the installation
of jicofo component did not work, so I used the procedure from
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-
u buntu-14-04/ (maven and dependencies). The build was successful,
however now I have the problem of “connecting” jicofo component to
prosody XMPP server.

I am starting the jicofo with the following command (GESLO001 is
password that I used when registering user in prosody with à
prosodyctl register focus auth.194.249.1.37 GESLO001):

                ./jicofo.sh --domain=194.249.1.37 --secret=TE36khMG
--user_domain=auth.194.249.1.37 --user_name=focus
--user_password=GESLO001 </dev/null >> /var/log/jicofo/jicofo.log
2>&1 &

The prosody log gives me:

Sep 05 17:54:43 focus.194.249.1.37:component warn Component not
connected, bouncing error for: <iq id='f4Wwi-8' type='get'
to='focus.194.249.1.37'
from='focus@auth.194.249.1.37/focus23879797006114'>

Jicofo log gives me:

Jicofo 2016-09-06 12:38:09.910 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused, host:194.249.1.37, port:5347

org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused

I am running all of the components on one machine. Also the
jitsi-videobridge connects successfully to prosody. I believe this
suggests it is not the firewall/NAT problem. I checked the prosody
configuration (see
below) and it seems to be right (according to the installation
instructions). Can somebody help me with this please? What am I
doing wrong? How could I debug this further (the log information is
not very helpful).

VirtualHost "194.249.1.37"

      authentication = "anonymous"

      ssl = {

            key = "/var/lib/prosody/194.249.1.37.key";

            certificate = "/var/lib/prosody/194.249.1.37.crt";

      }

      modules_enabled = {

            "bosh";

            "pubsub";

      }

VirtualHost "auth.194.249.1.37"

      authentication = "internal_plain"

admins = { "focus@auth.194.249.1.37" }

Component "conference.194.249.1.37" "muc"

Component "jitsi-videobridge.194.249.1.37"

      component_secret = "GB5sMOMK"

Component "focus.194.249.1.37"

      component_secret = "TE36khMG"

Cheers,

Jernej

------------------------------------------------
Jernej Trnkoczy

Researcher

Faculty of Civil and Geodetic Engineering

University of Ljubljana

Phone: +386 1 4768 588

e-mail: jernej.trnkoczy@fgg.uni-lj.si

------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

It is not prosody, I think. Something on your OS is not allowing
prosody to open the port, maybe some selinux or somthing else, not
sure what this might be.
I haven't seen such a problem on default ubuntu installation 14.04 or 16.04.

Regards
damencho

···

On Thu, Sep 8, 2016 at 3:05 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Sep 08 09:57:20 socket warn server.lua, [193.249.1.37]:5347: Cannot assign requested address
Sep 08 09:57:20 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address
Sep 08 09:57:20 portmanager info Activated service 'component' on no ports
Sep 08 09:57:20 hostmanager debug Activated host: focus.194.249.1.37


#8

Hi,
Damian you were right - it was not Prosody - but it was me making a stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation instructions at https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md are wrong. I have some insights on this issue now and would like to share it - maybe it will help somebody... So here it goes:

The jitsi-videobridge and jicofo components are "external" components of the Prosody server. This means that when they are started they will need to contact Prosody. By default Prosody is configured that it only accepts requests on "localhost" interface and port 5347 (default port). This means that the "external" components will have to make a call to "localhost:5347" - if not they will be rejected. In the manual installation instructions you start jitsi-videobridge with the following command:
./jvb.sh --host=localhost --domain=jitsi.example.com --port=5347 --secret=YOURSECRET1 & --> this is OK since videobridge will call "localhost=5347" and Prosody will accept it

However following the manual installation instructions you start jicofo with the following command:
./jicofo.sh --domain=jitsi.example.com --secret=YOURSECRET2 --user_domain=auth.jitsi.example.com --user_name=focus --user_password=YOURSECRET3 --> this is NOT OK because you are not passing the parameter --host. If you open the jicofo.sh script you will see that in this case by default jicofo will use the same parameter provided for --domain also for the --host. Example: if you set --domain=194.249.2.88 without setting the --host then jicofo will use --host=194.249.2.88 by default and try to contact Prosody with "194.249.2.88:5347" - and it will get rejected!

You can get around this by reconfiguring Prosody to accept the calls on some other interface. Adding the component_ports = { 5347 } and component_interface = "194.249.2.88" lines to prosody configuration file will force Prosody to accept the connections on 194.249.2.88 – so jicofo will start just fine (with the above command). However in this case jitsi-videobridge will not start with ./jvb.sh --host=localhost --domain=jitsi.example.com --port=5347 --secret=YOURSECRET1 & – because it will call “localhost:5347” and get rejected.

Bottom line: use --host=localhost when starting both jitsi-videobridge and jicofo (or alternatively modify the prosody configuration to listen on some other interface – and then use this interface when calling both jitsi-videobridge and jicofo)!

Hope this helps…
Cheers,
Jernej

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 8. september 2016 16:05
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

On Thu, Sep 8, 2016 at 3:05 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Sep 08 09:57:20 socket warn server.lua, [193.249.1.37]:5347: Cannot assign requested address
Sep 08 09:57:20 portmanager error Failed to open server port 5347 on 193.249.1.37, Cannot assign requested address
Sep 08 09:57:20 portmanager info Activated service 'component' on no ports
Sep 08 09:57:20 hostmanager debug Activated host: focus.194.249.1.37

It is not prosody, I think. Something on your OS is not allowing prosody to open the port, maybe some selinux or somthing else, not sure what this might be.
I haven't seen such a problem on default ubuntu installation 14.04 or 16.04.

Regards
damencho

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi

Hi,
Damian you were right - it was not Prosody - but it was me making a stupid
and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation instructions
at *https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md*
<https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md>
are wrong. I have some insights on this issue now and would like to share
it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I tried
all tips and suggestions without success.

Could be a good idea to revise this page, including situations like servers
behind a NAT or using a server in a DMZ and the jisti in a internal net.

Other interesting thing is to write a "troubleshoot" section, with tools to
debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

···

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si>:


#10

Hi,

Any help on those pages is welcome. Generally we do not recommend
using the manual install, its just there for reference. What we keep
up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs,
check whether that particular config file is read and taken into
account by jvb, further check whether the ips are correct and all port
forwarding are working.

Regards
damencho

···

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho <filhocf@gmail.com> wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a stupid
and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation instructions
at https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md are
wrong. I have some insights on this issue now and would like to share it -
maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I tried
all tips and suggestions without success.

Could be a good idea to revise this page, including situations like servers
behind a NAT or using a server in a DMZ and the jisti in a internal net.

Other interesting thing is to write a "troubleshoot" section, with tools to
debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Hi,
The reason why I try to do the manual install is that I want to make a Docker container containing complete server-side of jitsi meet. The problem is the interactive installation - I should not provide the IP of the host during the installation but rather at container startup. Doing easy-install at first and then calling reconfigure scripts later did not work for me. This is why now I am trying to understand every step in the manual installation - which will hopefully allow me to build the correct docker file and then reconfigure all the jitsi-meet components at container startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual installation - https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md . From the instructions it seems like all you need to do is pull from github and edit /srv/jitsi.example.com/config.js script.

On the other hand in the post https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-ubuntu-14-04/ that I was following when I had issues building jicofo (maven dependencies etc). The instructions for “Deploy Jitsi Meet” step are much more complex than in the original documentation – i.e. install node.js , use npm install and make (to build something that I do not really know what it is). I followed them and got stuck with errors when doing npm install – see the trace below (I am doing that as root - so I have no idea why permission denied).

My question is are these steps (installin node.js , use npm to install and then make jitsi meet etc…) really needed or not? What is their purpose? I thought that jitsi meet is a collection of javascript files with some configuration - and this javascript is then opened in the browser and uses prosody, videobridge and jicofo (that were installed in previous steps). So why do we need node.js and then do the npm install and make… Can somebody give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to eliminate the errors when calling the npm install?

I am really sorry to post these questions, but I am not very experienced in Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js | exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]`
npm ERR! Exit status 126
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node ./start_browserify.js | exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the lib-jitsi-meet package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node" "/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run version && npm run uglifyjs`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend using the manual install, its just there for reference. What we keep up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs, check whether that particular config file is read and taken into account by jvb, further check whether the ips are correct and all port forwarding are working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho <filhocf@gmail.com<mailto:filhocf@gmail.com>> wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
are wrong. I have some insights on this issue now and would like to share it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I
tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi,

Hi,
The reason why I try to do the manual install is that I want to make a
Docker container containing complete server-side of jitsi meet. The problem
is the interactive installation - I should not provide the IP of the host
during the installation but rather at container startup. Doing easy-install
at first and then calling reconfigure scripts later did not work for me.
This is why now I am trying to understand every step in the manual
installation - which will hopefully allow me to build the correct docker
file and then reconfigure all the jitsi-meet components at container
startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual installation -
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md . From
the instructions it seems like all you need to do is pull from github and
edit /srv/jitsi.example.com/config.js script.

Nope this is old. You need to read the jitsi-meet readme instructions.
Basically you need to do:
- checkout
- npm install
- make
Make sure you install latest node from https://nodejs.org (6.x.x).

On the other hand in the post
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-ubuntu-14-04/
that I was following when I had issues building jicofo (maven dependencies
etc). The instructions for “Deploy Jitsi Meet” step are much more complex
than in the original documentation – i.e. install node.js , use npm install
and make (to build something that I do not really know what it is). I
followed them and got stuck with errors when doing npm install – see the
trace below (I am doing that as root - so I have no idea why permission
denied).

My question is are these steps (installin node.js , use npm to install and
then make jitsi meet etc…) really needed or not? What is their purpose? I
thought that jitsi meet is a collection of javascript files with some
configuration - and this javascript is then opened in the browser and uses
prosody, videobridge and jicofo (that were installed in previous steps). So
why do we need node.js and then do the npm install and make… Can somebody
give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to
eliminate the errors when calling the npm install?

Update node. Yes its a javascript app but it used node modules and
this are all the sources, the usable javascript will be available
after running the make file, which will use tools like browserify,
uglify-js and so on, to produce the resulting files that can be placed
on the webserver.

I am really sorry to post these questions, but I am not very experienced in
Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

For some reason your node installation is somehow broken, as you see
this permission denied error. Not familiar with docker at all to be of
any help, but using ubuntu its very easy to install it using these
steps:
https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
There is a docker image on their site if this is of any help.

Regards
damencho

···

On Fri, Sep 9, 2016 at 11:00 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js |
exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s lib-jitsi-meet.js
]`
npm ERR! Exit status 126
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node
./start_browserify.js | exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js
&& [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the lib-jitsi-meet
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node"
"/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run
version && npm run uglifyjs`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run
browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on
Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend using the
manual install, its just there for reference. What we keep up to date and
test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs, check
whether that particular config file is read and taken into account by jvb,
further check whether the ips are correct and all port forwarding are
working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho <filhocf@gmail.com> > wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej
<Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
are wrong. I have some insights on this issue now and would like to share
it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I
tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a
internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hi Damian,

I've somehow solved the problem of building jitsi-meet webapp, however it does not work for me. I am using a simple nginx configuration file as provided below. The configuration of jitsi-meet is as given here - https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example .
When I open http://194.249.1.37 the web page opens, however when I create a room and try to join I get the following error: "Permission denied. There was an error connecting to your microphone. You have not granted to use your microphone...". I do not know about "Not granting the use of microphone" - the browser did not ask me about sharing webcam and microphone (as it should).

There must be something wrong with web app, maybe it is not configured correctly? Probably wrong config.js - I've noticed that in the template config.js file there is much more configuration now... So is the config given at https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example still relevant?
Maybe also the nginx.conf is wrong?
The third option is that the jitsi-meet project was build only "partially" - I saw some "strange" errors during the make - but it finished as there was nothing seriously wrong...

Cheers,
Jernej

NGINX CONFIGURATION:

server {
        listen 80;

        server_name 194.249.1.37;

        #set the root - this should be the path to jitsi-meet app
        root /srv/194.249.1.37;

        index index.html;
        location ~ ^/([a-zA-Z0-9=\?]+)$ {
                rewrite ^/(.*)$ / break;
        }
        location / {
                ssi on;
        }

        #BOSH
        location /http-bind {
                proxy_pass http://localhost:5280/http-bind;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
        }
}

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 23:16
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

On Fri, Sep 9, 2016 at 11:00 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,
The reason why I try to do the manual install is that I want to make a
Docker container containing complete server-side of jitsi meet. The
problem is the interactive installation - I should not provide the IP
of the host during the installation but rather at container startup.
Doing easy-install at first and then calling reconfigure scripts later did not work for me.
This is why now I am trying to understand every step in the manual
installation - which will hopefully allow me to build the correct
docker file and then reconfigure all the jitsi-meet components at
container startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual
installation -
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
. From the instructions it seems like all you need to do is pull from github and edit /srv/jitsi.example.com/config.js script.

Nope this is old. You need to read the jitsi-meet readme instructions.
Basically you need to do:
- checkout
- npm install
- make
Make sure you install latest node from https://nodejs.org (6.x.x).

On the other hand in the post
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-u
buntu-14-04/ that I was following when I had issues building jicofo
(maven dependencies etc). The instructions for “Deploy Jitsi Meet”
step are much more complex than in the original documentation – i.e.
install node.js , use npm install and make (to build something that I
do not really know what it is). I followed them and got stuck with
errors when doing npm install – see the trace below (I am doing that
as root - so I have no idea why permission denied).

My question is are these steps (installin node.js , use npm to install
and then make jitsi meet etc…) really needed or not? What is their
purpose? I thought that jitsi meet is a collection of javascript files
with some configuration - and this javascript is then opened in the
browser and uses prosody, videobridge and jicofo (that were installed
in previous steps). So why do we need node.js and then do the npm
install and make… Can somebody give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to
eliminate the errors when calling the npm install?

Update node. Yes its a javascript app but it used node modules and this are all the sources, the usable javascript will be available after running the make file, which will use tools like browserify, uglify-js and so on, to produce the resulting files that can be placed on the webserver.

I am really sorry to post these questions, but I am not very
experienced in Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

For some reason your node installation is somehow broken, as you see this permission denied error. Not familiar with docker at all to be of any help, but using ubuntu its very easy to install it using these
steps:
https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
There is a docker image on their site if this is of any help.

Regards
damencho

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js
> exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s
lib-jitsi-meet.js ]` npm ERR! Exit status 126 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node
./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the
lib-jitsi-meet package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ] npm ERR! You can get
information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node"
"/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run
version && npm run uglifyjs` npm ERR! Exit status 1 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run
browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet
package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this
project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend
using the manual install, its just there for reference. What we keep
up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs,
check whether that particular config file is read and taken into
account by jvb, further check whether the ips are correct and all port
forwarding are working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho > <filhocf@gmail.com> > wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej
<Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.m
d are wrong. I have some insights on this issue now and would like
to share it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I
tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a
internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi,

http will not work. It is that wbertc works only with https. You need
to change that first.

Regards
damencho

···

On Mon, Sep 12, 2016 at 10:27 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,

I've somehow solved the problem of building jitsi-meet webapp, however it does not work for me. I am using a simple nginx configuration file as provided below. The configuration of jitsi-meet is as given here - https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example .
When I open http://194.249.1.37 the web page opens, however when I create a room and try to join I get the following error: "Permission denied. There was an error connecting to your microphone. You have not granted to use your microphone...". I do not know about "Not granting the use of microphone" - the browser did not ask me about sharing webcam and microphone (as it should).

There must be something wrong with web app, maybe it is not configured correctly? Probably wrong config.js - I've noticed that in the template config.js file there is much more configuration now... So is the config given at https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example still relevant?
Maybe also the nginx.conf is wrong?
The third option is that the jitsi-meet project was build only "partially" - I saw some "strange" errors during the make - but it finished as there was nothing seriously wrong...

Cheers,
Jernej

NGINX CONFIGURATION:

server {
        listen 80;

        server_name 194.249.1.37;

        #set the root - this should be the path to jitsi-meet app
        root /srv/194.249.1.37;

        index index.html;
        location ~ ^/([a-zA-Z0-9=\?]+)$ {
                rewrite ^/(.*)$ / break;
        }
        location / {
                ssi on;
        }

        #BOSH
        location /http-bind {
                proxy_pass http://localhost:5280/http-bind;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
        }
}

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 23:16
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

On Fri, Sep 9, 2016 at 11:00 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,
The reason why I try to do the manual install is that I want to make a
Docker container containing complete server-side of jitsi meet. The
problem is the interactive installation - I should not provide the IP
of the host during the installation but rather at container startup.
Doing easy-install at first and then calling reconfigure scripts later did not work for me.
This is why now I am trying to understand every step in the manual
installation - which will hopefully allow me to build the correct
docker file and then reconfigure all the jitsi-meet components at
container startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual
installation -
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
. From the instructions it seems like all you need to do is pull from github and edit /srv/jitsi.example.com/config.js script.

Nope this is old. You need to read the jitsi-meet readme instructions.
Basically you need to do:
- checkout
- npm install
- make
Make sure you install latest node from https://nodejs.org (6.x.x).

On the other hand in the post
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-u
buntu-14-04/ that I was following when I had issues building jicofo
(maven dependencies etc). The instructions for “Deploy Jitsi Meet”
step are much more complex than in the original documentation – i.e.
install node.js , use npm install and make (to build something that I
do not really know what it is). I followed them and got stuck with
errors when doing npm install – see the trace below (I am doing that
as root - so I have no idea why permission denied).

My question is are these steps (installin node.js , use npm to install
and then make jitsi meet etc…) really needed or not? What is their
purpose? I thought that jitsi meet is a collection of javascript files
with some configuration - and this javascript is then opened in the
browser and uses prosody, videobridge and jicofo (that were installed
in previous steps). So why do we need node.js and then do the npm
install and make… Can somebody give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to
eliminate the errors when calling the npm install?

Update node. Yes its a javascript app but it used node modules and this are all the sources, the usable javascript will be available after running the make file, which will use tools like browserify, uglify-js and so on, to produce the resulting files that can be placed on the webserver.

I am really sorry to post these questions, but I am not very
experienced in Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

For some reason your node installation is somehow broken, as you see this permission denied error. Not familiar with docker at all to be of any help, but using ubuntu its very easy to install it using these
steps:
https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
There is a docker image on their site if this is of any help.

Regards
damencho

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js
> exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s
lib-jitsi-meet.js ]` npm ERR! Exit status 126 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node
./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the
lib-jitsi-meet package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ] npm ERR! You can get
information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node"
"/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run
version && npm run uglifyjs` npm ERR! Exit status 1 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run
browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet
package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this
project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend
using the manual install, its just there for reference. What we keep
up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs,
check whether that particular config file is read and taken into
account by jvb, further check whether the ips are correct and all port
forwarding are working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho >> <filhocf@gmail.com> >> wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej
<Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.m
d are wrong. I have some insights on this issue now and would like
to share it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop). I
tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a
internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Hi Damian,
Changing the configuration of nginx to serve the jitsi-meet webapp using HTTPS seems to help a lot. Finally it seems that I came to a working installation :)! I setup the nginx https on port 444 - since the 443 port was already in use. I believe it is the jetty server listening on 443 - can you please tell me what is this jetty server doing - what is it's purpose and which component starts it?

I would like to thank you for your great support. Manual installation of jitsi-meet without the knowledge of the system, it's components and configuration seems to be quite a challenging task. Especially if you are not very good at Linux (like me). It is very difficult to find the right information and current official installation instructions are pretty difficult to follow. Maybe I could provide a more detailed instructions based on what I have learned over last couple of weeks - what would be the right procedure to do so?

Cheers,
Jernej

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 12. september 2016 17:37
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

http will not work. It is that wbertc works only with https. You need to change that first.

Regards
damencho

On Mon, Sep 12, 2016 at 10:27 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,

I've somehow solved the problem of building jitsi-meet webapp, however it does not work for me. I am using a simple nginx configuration file as provided below. The configuration of jitsi-meet is as given here - https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example .
When I open http://194.249.1.37 the web page opens, however when I create a room and try to join I get the following error: "Permission denied. There was an error connecting to your microphone. You have not granted to use your microphone...". I do not know about "Not granting the use of microphone" - the browser did not ask me about sharing webcam and microphone (as it should).

There must be something wrong with web app, maybe it is not configured correctly? Probably wrong config.js - I've noticed that in the template config.js file there is much more configuration now... So is the config given at https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example still relevant?
Maybe also the nginx.conf is wrong?
The third option is that the jitsi-meet project was build only "partially" - I saw some "strange" errors during the make - but it finished as there was nothing seriously wrong...

Cheers,
Jernej

NGINX CONFIGURATION:

server {
        listen 80;

        server_name 194.249.1.37;

        #set the root - this should be the path to jitsi-meet app
        root /srv/194.249.1.37;

        index index.html;
        location ~ ^/([a-zA-Z0-9=\?]+)$ {
                rewrite ^/(.*)$ / break;
        }
        location / {
                ssi on;
        }

        #BOSH
        location /http-bind {
                proxy_pass http://localhost:5280/http-bind;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
        }
}

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 23:16
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

On Fri, Sep 9, 2016 at 11:00 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,
The reason why I try to do the manual install is that I want to make
a Docker container containing complete server-side of jitsi meet. The
problem is the interactive installation - I should not provide the IP
of the host during the installation but rather at container startup.
Doing easy-install at first and then calling reconfigure scripts later did not work for me.
This is why now I am trying to understand every step in the manual
installation - which will hopefully allow me to build the correct
docker file and then reconfigure all the jitsi-meet components at
container startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual
installation -
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
. From the instructions it seems like all you need to do is pull from github and edit /srv/jitsi.example.com/config.js script.

Nope this is old. You need to read the jitsi-meet readme instructions.
Basically you need to do:
- checkout
- npm install
- make
Make sure you install latest node from https://nodejs.org (6.x.x).

On the other hand in the post
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-
u buntu-14-04/ that I was following when I had issues building jicofo
(maven dependencies etc). The instructions for “Deploy Jitsi Meet”
step are much more complex than in the original documentation – i.e.
install node.js , use npm install and make (to build something that I
do not really know what it is). I followed them and got stuck with
errors when doing npm install – see the trace below (I am doing that
as root - so I have no idea why permission denied).

My question is are these steps (installin node.js , use npm to
install and then make jitsi meet etc…) really needed or not? What is
their purpose? I thought that jitsi meet is a collection of
javascript files with some configuration - and this javascript is
then opened in the browser and uses prosody, videobridge and jicofo
(that were installed in previous steps). So why do we need node.js
and then do the npm install and make… Can somebody give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to
eliminate the errors when calling the npm install?

Update node. Yes its a javascript app but it used node modules and this are all the sources, the usable javascript will be available after running the make file, which will use tools like browserify, uglify-js and so on, to produce the resulting files that can be placed on the webserver.

I am really sorry to post these questions, but I am not very
experienced in Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

For some reason your node installation is somehow broken, as you see
this permission denied error. Not familiar with docker at all to be of
any help, but using ubuntu its very easy to install it using these
steps:
https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-base
d-linux-distributions There is a docker image on their site if this is
of any help.

Regards
damencho

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js
> exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s
lib-jitsi-meet.js ]` npm ERR! Exit status 126 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node
./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the
lib-jitsi-meet package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ] npm ERR! You can get
information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node"
"/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run
version && npm run uglifyjs` npm ERR! Exit status 1 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run
browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet
package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this
project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend
using the manual install, its just there for reference. What we keep
up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs,
check whether that particular config file is read and taken into
account by jvb, further check whether the ips are correct and all
port forwarding are working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho >> <filhocf@gmail.com> >> wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej
<Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.
m d are wrong. I have some insights on this issue now and would
like to share it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop).
I tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a
internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Hi,

Hi Damian,
Changing the configuration of nginx to serve the jitsi-meet webapp using HTTPS seems to help a lot. Finally it seems that I came to a working installation :)! I setup the nginx https on port 444 - since the 443 port was already in use. I believe it is the jetty server listening on 443 - can you please tell me what is this jetty server doing - what is it's purpose and which component starts it?

So the port 443 in jetty can be configured to serve meet (here is how
you do it https://github.com/jitsi/jitsi-videobridge/blob/master/doc/http.md)
and also can be used to relay tcp traffic for restricted corporate
networks where only port 443 and 80 are allowed. By default port 4443
is used.

I would like to thank you for your great support. Manual installation of jitsi-meet without the knowledge of the system, it's components and configuration seems to be quite a challenging task. Especially if you are not very good at Linux (like me). It is very difficult to find the right information and current official installation instructions are pretty difficult to follow. Maybe I could provide a more detailed instructions based on what I have learned over last couple of weeks - what would be the right procedure to do so?

You can make a PR with updated manual installation document.
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
You need to sign the contributor agreement.
https://jitsi.org/faq#patch

Yep manual installation is not easy as it involves configuring many
components of the system, that's why we advise using the packages.

Regards
damencho

···

On Tue, Sep 13, 2016 at 9:28 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Cheers,
Jernej

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 12. september 2016 17:37
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet on Ubuntu 16.04

Hi,

http will not work. It is that wbertc works only with https. You need to change that first.

Regards
damencho

On Mon, Sep 12, 2016 at 10:27 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi Damian,

I've somehow solved the problem of building jitsi-meet webapp, however it does not work for me. I am using a simple nginx configuration file as provided below. The configuration of jitsi-meet is as given here - https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example .
When I open http://194.249.1.37 the web page opens, however when I create a room and try to join I get the following error: "Permission denied. There was an error connecting to your microphone. You have not granted to use your microphone...". I do not know about "Not granting the use of microphone" - the browser did not ask me about sharing webcam and microphone (as it should).

There must be something wrong with web app, maybe it is not configured correctly? Probably wrong config.js - I've noticed that in the template config.js file there is much more configuration now... So is the config given at https://github.com/jitsi/jitsi-meet/blob/master/doc/example-config-files/config.js.example still relevant?
Maybe also the nginx.conf is wrong?
The third option is that the jitsi-meet project was build only "partially" - I saw some "strange" errors during the make - but it finished as there was nothing seriously wrong...

Cheers,
Jernej

NGINX CONFIGURATION:

server {
        listen 80;

        server_name 194.249.1.37;

        #set the root - this should be the path to jitsi-meet app
        root /srv/194.249.1.37;

        index index.html;
        location ~ ^/([a-zA-Z0-9=\?]+)$ {
                rewrite ^/(.*)$ / break;
        }
        location / {
                ssi on;
        }

        #BOSH
        location /http-bind {
                proxy_pass http://localhost:5280/http-bind;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
        }
}

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 23:16
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

On Fri, Sep 9, 2016 at 11:00 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,
The reason why I try to do the manual install is that I want to make
a Docker container containing complete server-side of jitsi meet. The
problem is the interactive installation - I should not provide the IP
of the host during the installation but rather at container startup.
Doing easy-install at first and then calling reconfigure scripts later did not work for me.
This is why now I am trying to understand every step in the manual
installation - which will hopefully allow me to build the correct
docker file and then reconfigure all the jitsi-meet components at
container startup.

I am now stuck at the “Deploy Jitsi Meet” step in the manual
installation -
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
. From the instructions it seems like all you need to do is pull from github and edit /srv/jitsi.example.com/config.js script.

Nope this is old. You need to read the jitsi-meet readme instructions.
Basically you need to do:
- checkout
- npm install
- make
Make sure you install latest node from https://nodejs.org (6.x.x).

On the other hand in the post
https://thenumberzero.wordpress.com/2016/03/30/install-jitsi-meet-on-
u buntu-14-04/ that I was following when I had issues building jicofo
(maven dependencies etc). The instructions for “Deploy Jitsi Meet”
step are much more complex than in the original documentation – i.e.
install node.js , use npm install and make (to build something that I
do not really know what it is). I followed them and got stuck with
errors when doing npm install – see the trace below (I am doing that
as root - so I have no idea why permission denied).

My question is are these steps (installin node.js , use npm to
install and then make jitsi meet etc…) really needed or not? What is
their purpose? I thought that jitsi meet is a collection of
javascript files with some configuration - and this javascript is
then opened in the browser and uses prosody, videobridge and jicofo
(that were installed in previous steps). So why do we need node.js
and then do the npm install and make… Can somebody give me a little bit of insight?
If these steps are really needed – can somebody please tell me how to
eliminate the errors when calling the npm install?

Update node. Yes its a javascript app but it used node modules and this are all the sources, the usable javascript will be available after running the make file, which will use tools like browserify, uglify-js and so on, to produce the resulting files that can be placed on the webserver.

I am really sorry to post these questions, but I am not very
experienced in Linux unfortunately…

Thank you very much for your support!
Cheers,
Jernej

/usr/bin/env: ‘node’: Permission denied
sh: 1: node: Permission denied

For some reason your node installation is somehow broken, as you see
this permission denied error. Not familiar with docker at all to be of
any help, but using ubuntu its very easy to install it using these
steps:
https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-base
d-linux-distributions There is a docker image on their site if this is
of any help.

Regards
damencho

npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "browserify"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! lib-jitsi-meet@0.0.0 browserify: `node ./start_browserify.js
> exorcist lib-jitsi-meet.js.map > lib-jitsi-meet.js && [ -s
lib-jitsi-meet.js ]` npm ERR! Exit status 126 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 browserify script 'node
./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ]'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the
lib-jitsi-meet package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./start_browserify.js | exorcist lib-jitsi-meet.js.map >
lib-jitsi-meet.js && [ -s lib-jitsi-meet.js ] npm ERR! You can get
information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/node_modules/lib-jitsi-meet/npm-debug.log
npm ERR! Linux 4.4.0-36-generic
npm ERR! argv "/root/.nvm/versions/node/v4.4.1/bin/node"
"/root/.nvm/versions/node/v4.4.1/bin/npm" "update"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `npm run browserify && npm run
version && npm run uglifyjs` npm ERR! Exit status 1 npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'npm run
browserify && npm run version && npm run uglifyjs'.
npm ERR! This is most likely a problem with the lib-jitsi-meet
package, npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm run browserify && npm run version && npm run uglifyjs
npm ERR! You can get information on how to open an issue for this
project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /srv/194.249.1.37/npm-debug.log

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 9. september 2016 17:42
To: Jitsi Developers
Subject: Re: [jitsi-dev] stuck with manual installation of jitsi-meet
on Ubuntu 16.04

Hi,

Any help on those pages is welcome. Generally we do not recommend
using the manual install, its just there for reference. What we keep
up to date and test everyday is the automated install.
What I see in the doc is correct, you just need to dig into logs,
check whether that particular config file is read and taken into
account by jvb, further check whether the ips are correct and all
port forwarding are working.

Regards
damencho

On Fri, Sep 9, 2016 at 8:53 AM, Claudio Ferreia Filho >>> <filhocf@gmail.com> >>> wrote:

Hi

2016-09-09 7:36 GMT-03:00 Trnkoczy, Jernej
<Jernej.Trnkoczy@fgg.uni-lj.si>:

Hi,
Damian you were right - it was not Prosody - but it was me making a
stupid and hard to find typo in the Prosody configuration file.
Nevertheless - I believe the jitsi-meet manual installation
instructions at
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.
m d are wrong. I have some insights on this issue now and would
like to share it - maybe it will help somebody... So here it goes:

I can't run jitsi-meet out of my local network (or my own desktop).
I tried all tips and suggestions without success.

Could be a good idea to revise this page, including situations like
servers behind a NAT or using a server in a DMZ and the jisti in a
internal net.

Other interesting thing is to write a "troubleshoot" section, with
tools to debug, tips and general problems.

Is possible?

Regards,
Claudio Ferreira

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

The videobridge starts it and the purpose is to have the web page and
the media streams served over the same port at the same time -- so
that you won't need a separate server (or IP address) on which to
server the media streams over TCP, in cases when UDP is not available.

If you wish to use nginx, you can disable the jetty configuration and
if you have only one IP address and you want to use jetty, you can
disable the nginx -- i.e. you only need one of these setups, not both
at the same time.

···

On Tue, 13 Sep 2016 14:28:20 +0000 Trnkoczy, Jernej wrote:

Hi Damian,
Changing the configuration of nginx to serve the jitsi-meet webapp
using HTTPS seems to help a lot. Finally it seems that I came to a
working installation :)! I setup the nginx https on port 444 - since
the 443 port was already in use. I believe it is the jetty server
listening on 443 - can you please tell me what is this jetty server
doing - what is it's purpose and which component starts it?

--

Yasen Pramatarov
Lindeas Ltd. https://lindeas.com
'working on GNU/Linux ideas'
Professional Jitsi Meet services