[jitsi-dev] strange linux usb audio problem


#1

Hi All,

I've been using jitsi for a few years in various capacities and love it.
Recently, we (at my company) have been planning a wider deployment which
will incorporate videobridge, probably jitsi-meet etc.

However, we are stuck now on the most basic thing, audio breakups!

This happens on Fedora 20 with any USB audio device, but not on Centos 7.
The symptom is tons of discarded packets in the "info" panel and audio
breakups a few per second.

Verified on two (or three, counting a VM) different machines with two
different usb audio devices (in one case, only the microphone was USB audio
- from the logitech C920 camera, in the other case a plantronics headset).

We have tested with both openjdk 1.7.0.71 and oracle jvm.

It happens with portaudio and pulseaudio.

I even have a kvm virtual machine and it happens there when I pass through
the USB device the exact same way as on the bare-metal machine.

Any ideas?

···

--
Thanks,
David Mansfield
Cobite, INC.


#2

Note. This seems to be a bug/issue with pulseaudio 5.0. I've tracked it
down to the decision of whether or not to use "timer based scheduling"
(tsched) - although contrary to most anecdotal evidence on the 'net, this
problem is caused by LACK of tsched. Forcing tsched (by hacking source
code) fixes it.

Here's the bug report:

https://bugs.freedesktop.org/show_bug.cgi?id=86262

···

On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield <dmansfield@gmail.com> wrote:

Hi All,

I've been using jitsi for a few years in various capacities and love it.
Recently, we (at my company) have been planning a wider deployment which
will incorporate videobridge, probably jitsi-meet etc.

However, we are stuck now on the most basic thing, audio breakups!

This happens on Fedora 20 with any USB audio device, but not on Centos 7.
The symptom is tons of discarded packets in the "info" panel and audio
breakups a few per second.

Verified on two (or three, counting a VM) different machines with two
different usb audio devices (in one case, only the microphone was USB audio
- from the logitech C920 camera, in the other case a plantronics headset).

We have tested with both openjdk 1.7.0.71 and oracle jvm.

It happens with portaudio and pulseaudio.

I even have a kvm virtual machine and it happens there when I pass through
the USB device the exact same way as on the bare-metal machine.

Any ideas?

--
Thanks,
David Mansfield
Cobite, INC.


#3

Hi David,

Thanks for letting us know.
I'm going to keep an eye on this. As a Linux user myself, I'd like to
see it free of this kind of trouble. :slight_smile:

Danny

···

On 13-11-14 20:33, David Mansfield wrote:

Note. This seems to be a bug/issue with pulseaudio 5.0. I've tracked
it down to the decision of whether or not to use "timer based
scheduling" (tsched) - although contrary to most anecdotal evidence on
the 'net, this problem is caused by LACK of tsched. Forcing tsched
(by hacking source code) fixes it.

Here's the bug report:

https://bugs.freedesktop.org/show_bug.cgi?id=86262

On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield <dmansfield@gmail.com > <mailto:dmansfield@gmail.com>> wrote:

    Hi All,

    I've been using jitsi for a few years in various capacities and
    love it. Recently, we (at my company) have been planning a wider
    deployment which will incorporate videobridge, probably jitsi-meet
    etc.

    However, we are stuck now on the most basic thing, audio breakups!

    This happens on Fedora 20 with any USB audio device, but not on
    Centos 7. The symptom is tons of discarded packets in the "info"
    panel and audio breakups a few per second.

    Verified on two (or three, counting a VM) different machines with
    two different usb audio devices (in one case, only the microphone
    was USB audio - from the logitech C920 camera, in the other case a
    plantronics headset).

    We have tested with both openjdk 1.7.0.71 and oracle jvm.

    It happens with portaudio and pulseaudio.

    I even have a kvm virtual machine and it happens there when I pass
    through the USB device the exact same way as on the bare-metal
    machine.

    Any ideas?

    --
    Thanks,
    David Mansfield
    Cobite, INC.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

FYI, on Linux Mint with a usb soundcard, I haven't noticed any issues so
far.

···

On Fri, Nov 14, 2014 at 12:52 AM, Danny van Heumen <danny@dannyvanheumen.nl> wrote:

Hi David,

Thanks for letting us know.
I'm going to keep an eye on this. As a Linux user myself, I'd like to
see it free of this kind of trouble. :slight_smile:

Danny

On 13-11-14 20:33, David Mansfield wrote:
> Note. This seems to be a bug/issue with pulseaudio 5.0. I've tracked
> it down to the decision of whether or not to use "timer based
> scheduling" (tsched) - although contrary to most anecdotal evidence on
> the 'net, this problem is caused by LACK of tsched. Forcing tsched
> (by hacking source code) fixes it.
>
> Here's the bug report:
>
> https://bugs.freedesktop.org/show_bug.cgi?id=86262
>
>
>
> On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield <dmansfield@gmail.com > > <mailto:dmansfield@gmail.com>> wrote:
>
> Hi All,
>
> I've been using jitsi for a few years in various capacities and
> love it. Recently, we (at my company) have been planning a wider
> deployment which will incorporate videobridge, probably jitsi-meet
> etc.
>
> However, we are stuck now on the most basic thing, audio breakups!
>
> This happens on Fedora 20 with any USB audio device, but not on
> Centos 7. The symptom is tons of discarded packets in the "info"
> panel and audio breakups a few per second.
>
> Verified on two (or three, counting a VM) different machines with
> two different usb audio devices (in one case, only the microphone
> was USB audio - from the logitech C920 camera, in the other case a
> plantronics headset).
>
> We have tested with both openjdk 1.7.0.71 and oracle jvm.
>
> It happens with portaudio and pulseaudio.
>
> I even have a kvm virtual machine and it happens there when I pass
> through the USB device the exact same way as on the bare-metal
> machine.
>
> Any ideas?
>
> --
> Thanks,
> David Mansfield
> Cobite, INC.
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

Using Ubuntu 14.04 here. It uses Pulseaudio 4.0. (Not sure if the
problem exists here, though.)
It may be that the issue is introduced in Pulseaudio 5.0.

Danny

···

On 13-11-14 21:00, Ali Akhtar wrote:

FYI, on Linux Mint with a usb soundcard, I haven't noticed any issues
so far.

On Fri, Nov 14, 2014 at 12:52 AM, Danny van Heumen > <danny@dannyvanheumen.nl <mailto:danny@dannyvanheumen.nl>> wrote:

    Hi David,

    Thanks for letting us know.
    I'm going to keep an eye on this. As a Linux user myself, I'd like to
    see it free of this kind of trouble. :slight_smile:

    Danny

    On 13-11-14 20:33, David Mansfield wrote:
    > Note. This seems to be a bug/issue with pulseaudio 5.0. I've
    tracked
    > it down to the decision of whether or not to use "timer based
    > scheduling" (tsched) - although contrary to most anecdotal
    evidence on
    > the 'net, this problem is caused by LACK of tsched. Forcing tsched
    > (by hacking source code) fixes it.
    >
    > Here's the bug report:
    >
    > https://bugs.freedesktop.org/show_bug.cgi?id=86262
    >
    >
    >
    > On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield > <dmansfield@gmail.com <mailto:dmansfield@gmail.com> > > <mailto:dmansfield@gmail.com <mailto:dmansfield@gmail.com>>> wrote:
    >
    > Hi All,
    >
    > I've been using jitsi for a few years in various capacities and
    > love it. Recently, we (at my company) have been planning a
    wider
    > deployment which will incorporate videobridge, probably
    jitsi-meet
    > etc.
    >
    > However, we are stuck now on the most basic thing, audio
    breakups!
    >
    > This happens on Fedora 20 with any USB audio device, but not on
    > Centos 7. The symptom is tons of discarded packets in the
    "info"
    > panel and audio breakups a few per second.
    >
    > Verified on two (or three, counting a VM) different machines
    with
    > two different usb audio devices (in one case, only the
    microphone
    > was USB audio - from the logitech C920 camera, in the other
    case a
    > plantronics headset).
    >
    > We have tested with both openjdk 1.7.0.71 and oracle jvm.
    >
    > It happens with portaudio and pulseaudio.
    >
    > I even have a kvm virtual machine and it happens there when
    I pass
    > through the USB device the exact same way as on the bare-metal
    > machine.
    >
    > Any ideas?
    >
    > --
    > Thanks,
    > David Mansfield
    > Cobite, INC.
    >
    >
    >
    >
    > _______________________________________________
    > dev mailing list
    > dev@jitsi.org <mailto:dev@jitsi.org>
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/dev

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

I am also on pulseaudio 4.0.

···

On Fri, Nov 14, 2014 at 1:05 AM, Danny van Heumen <danny@dannyvanheumen.nl> wrote:

Hi,

Using Ubuntu 14.04 here. It uses Pulseaudio 4.0. (Not sure if the
problem exists here, though.)
It may be that the issue is introduced in Pulseaudio 5.0.

Danny

On 13-11-14 21:00, Ali Akhtar wrote:
> FYI, on Linux Mint with a usb soundcard, I haven't noticed any issues
> so far.
>
> On Fri, Nov 14, 2014 at 12:52 AM, Danny van Heumen > > <danny@dannyvanheumen.nl <mailto:danny@dannyvanheumen.nl>> wrote:
>
> Hi David,
>
> Thanks for letting us know.
> I'm going to keep an eye on this. As a Linux user myself, I'd like to
> see it free of this kind of trouble. :slight_smile:
>
> Danny
>
>
>
> On 13-11-14 20:33, David Mansfield wrote:
> > Note. This seems to be a bug/issue with pulseaudio 5.0. I've
> tracked
> > it down to the decision of whether or not to use "timer based
> > scheduling" (tsched) - although contrary to most anecdotal
> evidence on
> > the 'net, this problem is caused by LACK of tsched. Forcing tsched
> > (by hacking source code) fixes it.
> >
> > Here's the bug report:
> >
> > https://bugs.freedesktop.org/show_bug.cgi?id=86262
> >
> >
> >
> > On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield > > <dmansfield@gmail.com <mailto:dmansfield@gmail.com> > > > <mailto:dmansfield@gmail.com <mailto:dmansfield@gmail.com>>> > wrote:
> >
> > Hi All,
> >
> > I've been using jitsi for a few years in various capacities and
> > love it. Recently, we (at my company) have been planning a
> wider
> > deployment which will incorporate videobridge, probably
> jitsi-meet
> > etc.
> >
> > However, we are stuck now on the most basic thing, audio
> breakups!
> >
> > This happens on Fedora 20 with any USB audio device, but not on
> > Centos 7. The symptom is tons of discarded packets in the
> "info"
> > panel and audio breakups a few per second.
> >
> > Verified on two (or three, counting a VM) different machines
> with
> > two different usb audio devices (in one case, only the
> microphone
> > was USB audio - from the logitech C920 camera, in the other
> case a
> > plantronics headset).
> >
> > We have tested with both openjdk 1.7.0.71 and oracle jvm.
> >
> > It happens with portaudio and pulseaudio.
> >
> > I even have a kvm virtual machine and it happens there when
> I pass
> > through the USB device the exact same way as on the bare-metal
> > machine.
> >
> > Any ideas?
> >
> > --
> > Thanks,
> > David Mansfield
> > Cobite, INC.
> >
> >
> >
> >
> > _______________________________________________
> > dev mailing list
> > dev@jitsi.org <mailto:dev@jitsi.org>
> > Unsubscribe instructions and other list options:
> > http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

I'ts only a bug/issue in PA 5. Not sure if it qualifies as a bug (yet)
because I don't understand why the code was changed, only that reversing
the change fixes things for me.

···

On Thu, Nov 13, 2014 at 3:15 PM, Ali Akhtar <ali.rac200@gmail.com> wrote:

I am also on pulseaudio 4.0.

On Fri, Nov 14, 2014 at 1:05 AM, Danny van Heumen <danny@dannyvanheumen.nl > > wrote:

Hi,

Using Ubuntu 14.04 here. It uses Pulseaudio 4.0. (Not sure if the
problem exists here, though.)
It may be that the issue is introduced in Pulseaudio 5.0.

Danny

On 13-11-14 21:00, Ali Akhtar wrote:
> FYI, on Linux Mint with a usb soundcard, I haven't noticed any issues
> so far.
>
> On Fri, Nov 14, 2014 at 12:52 AM, Danny van Heumen >> > <danny@dannyvanheumen.nl <mailto:danny@dannyvanheumen.nl>> wrote:
>
> Hi David,
>
> Thanks for letting us know.
> I'm going to keep an eye on this. As a Linux user myself, I'd like
to
> see it free of this kind of trouble. :slight_smile:
>
> Danny
>
>
>
> On 13-11-14 20:33, David Mansfield wrote:
> > Note. This seems to be a bug/issue with pulseaudio 5.0. I've
> tracked
> > it down to the decision of whether or not to use "timer based
> > scheduling" (tsched) - although contrary to most anecdotal
> evidence on
> > the 'net, this problem is caused by LACK of tsched. Forcing
tsched
> > (by hacking source code) fixes it.
> >
> > Here's the bug report:
> >
> > https://bugs.freedesktop.org/show_bug.cgi?id=86262
> >
> >
> >
> > On Wed, Nov 12, 2014 at 9:52 AM, David Mansfield >> > <dmansfield@gmail.com <mailto:dmansfield@gmail.com> >> > > <mailto:dmansfield@gmail.com <mailto:dmansfield@gmail.com>>> >> wrote:
> >
> > Hi All,
> >
> > I've been using jitsi for a few years in various capacities
and
> > love it. Recently, we (at my company) have been planning a
> wider
> > deployment which will incorporate videobridge, probably
> jitsi-meet
> > etc.
> >
> > However, we are stuck now on the most basic thing, audio
> breakups!
> >
> > This happens on Fedora 20 with any USB audio device, but not
on
> > Centos 7. The symptom is tons of discarded packets in the
> "info"
> > panel and audio breakups a few per second.
> >
> > Verified on two (or three, counting a VM) different machines
> with
> > two different usb audio devices (in one case, only the
> microphone
> > was USB audio - from the logitech C920 camera, in the other
> case a
> > plantronics headset).
> >
> > We have tested with both openjdk 1.7.0.71 and oracle jvm.
> >
> > It happens with portaudio and pulseaudio.
> >
> > I even have a kvm virtual machine and it happens there when
> I pass
> > through the USB device the exact same way as on the bare-metal
> > machine.
> >
> > Any ideas?
> >
> > --
> > Thanks,
> > David Mansfield
> > Cobite, INC.
> >
> >
> >
> >
> > _______________________________________________
> > dev mailing list
> > dev@jitsi.org <mailto:dev@jitsi.org>
> > Unsubscribe instructions and other list options:
> > http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev