[jitsi-dev] Status to "Away"


#1

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and an option "Minutes to status change". Despite activation the status is always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to check for keyboard or mouse activities on Linux. Is there help?

Thank you very much
Conrad


#2

Hi,

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and an option "Minutes to status change". Despite activation the status is always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

···

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert <conrad_videokonferenz@gmx.de> wrote:

Thank you very much
Conrad


#3

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is this working for you? I set away to 2 minutes and let the machine sit idle, but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

···

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert > <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and an option "Minutes to status change". Despite activation the status is always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#4

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

···

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert > <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#5

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed instructions, I'll be happy to provice.

Best, steve

···

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert >> <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#6

Hey,

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'cd ~/Library/Application\ Support/Jitsi'). And
then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

Thanks
damencho

···

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert > <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#7

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'term'). And
then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

net.java.sip.communicator.plugin.statusupdate.enable=true
net.java.sip.communicator.plugin.statusupdate.timer=15

First off, I notice, since I set the timer to 2 mintues and the output says 15 it seems the setting is simply ignored?

My setup is rather simple. I'm having one Jabber account (jabber.org) and another jabber account (jit.si). I've set the jabber.org to "DND". The jit.si is available.
OS X 10.8.1

Best,
steve

···

Thanks
damencho

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert >> <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#8

Hi again,

can you also describe the protocols you use, the configured accounts
you have (like sip, jabber, icq, msn ... which of those you are
currently using).

Thanks
damencho

···

On Mon, Sep 17, 2012 at 4:56 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hey,

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'cd ~/Library/Application\ Support/Jitsi'). And
then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

Thanks
damencho

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert >> <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#9

Hey Steve,

can you test does build 4212 fixes the problem for you?

Thanks
damencho

···

On Mon, Sep 17, 2012 at 5:46 PM, Steve <stevebell@gulli.com> wrote:

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'term'). And

then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

net.java.sip.communicator.plugin.statusupdate.enable=true
net.java.sip.communicator.plugin.statusupdate.timer=15

First off, I notice, since I set the timer to 2 mintues and the output says
15 it seems the setting is simply ignored?

My setup is rather simple. I'm having one Jabber account (jabber.org) and
another jabber account (jit.si). I've set the jabber.org to "DND". The
jit.si is available.
OS X 10.8.1

Best,
steve

Thanks
damencho

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert > <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#10

Yippie :slight_smile:

Working great now (using latest nightly from today).

What's up with IRC? I found https://jitsi.org/index.php/Development/PluginIRC but cannot tell what the status is. Looks outdated since it's still referencing SIP-communicator.

Will IRC be supported one day? That's the missing component for me to ditch Adium and switch entirely to Jitsi...

Best,
steve

···

Am 25.09.2012 um 13:44 schrieb Damian Minkov <damencho@jitsi.org>:

Hey Steve,

can you test does build 4212 fixes the problem for you?

Thanks
damencho

On Mon, Sep 17, 2012 at 5:46 PM, Steve <stevebell@gulli.com> wrote:

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'term'). And

then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

net.java.sip.communicator.plugin.statusupdate.enable=true
net.java.sip.communicator.plugin.statusupdate.timer=15

First off, I notice, since I set the timer to 2 mintues and the output says
15 it seems the setting is simply ignored?

My setup is rather simple. I'm having one Jabber account (jabber.org) and
another jabber account (jit.si). I've set the jabber.org to "DND". The
jit.si is available.
OS X 10.8.1

Best,
steve

Thanks
damencho

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert >> <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad


#11

We disabled IRC a year or two ago. We were not happy with the lib we
were using (PircBot) and we didn't have time to switch.

If anyone is interested in working on this and then maintain and
improve it continously, then we'd be very, very, very happy to help
them out with it!

So, spread the word if you know anyone who may want to look at this.

···

On Fri, Sep 28, 2012 at 2:11 PM, Steve <stevebell@gulli.com> wrote:

Yippie :slight_smile:

Working great now (using latest nightly from today).

What's up with IRC? I found
https://jitsi.org/index.php/Development/PluginIRC but cannot tell what the
status is. Looks outdated since it's still referencing SIP-communicator.

Will IRC be supported one day? That's the missing component for me to ditch
Adium and switch entirely to Jitsi...

Best,
steve

Am 25.09.2012 um 13:44 schrieb Damian Minkov <damencho@jitsi.org>:

Hey Steve,

can you test does build 4212 fixes the problem for you?

Thanks
damencho

On Mon, Sep 17, 2012 at 5:46 PM, Steve <stevebell@gulli.com> wrote:

can you just check for a property in the configuration file, please.
Normally under macosx it is in ~/Library/Application Support/Jitsi
(in Terminal execute 'term'). And

then the following command again in the terminal: cat
sip-communicator.properties | grep statusupdate
And just send the result back here.

net.java.sip.communicator.plugin.statusupdate.enable=true
net.java.sip.communicator.plugin.statusupdate.timer=15

First off, I notice, since I set the timer to 2 mintues and the output says
15 it seems the setting is simply ignored?

My setup is rather simple. I'm having one Jabber account (jabber.org) and
another jabber account (jit.si). I've set the jabber.org to "DND". The
jit.si is available.
OS X 10.8.1

Best,
steve

Thanks
damencho

On Mon, Sep 17, 2012 at 4:46 PM, Steve <stevebell@gulli.com> wrote:

Hey Damian,

I'm on OS X 10.8.1.

What do you want me to check or provide? If you give me detailed
instructions, I'll be happy to provice.

Best, steve

Am 17.09.2012 um 15:38 schrieb Damian Minkov <damencho@jitsi.org>:

Hi Steve,

on which OS do you see the problem? Can you also check your
configuration file for all the properties containing statusupdate?
($ cat sip-communicator.properties | grep statusupdate)

Thanks
damencho

On Mon, Sep 17, 2012 at 4:29 PM, Steve <stevebell@gulli.com> wrote:

Dear Emil and all,

using 1.1-nightly.build.4203 and away status is not correctly set afaik. Is
this working for you? I set away to 2 minutes and let the machine sit idle,
but the status is staying "online". So I assume this is still broken, no?

Regards,
steve

Am 13.08.2012 um 09:00 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

On Wed, Aug 8, 2012 at 3:10 PM, Conrad Beckert > <conrad_videokonferenz@gmx.de> wrote:

Hi,

My computer is always on - and so is Jitsi. Unfortunately my status is
always "Online" unless set explicitly to "Away" and back again.

The Settings Dialog has an option "Set status automatically to Away" - and
an option "Minutes to status change". Despite activation the status is
always Online no matter how long the machine is unattended.

What's wrong? I use Ubuntu 12-04 and xfce. Probably Jitsi isn't able to
check for keyboard or mouse activities on Linux. Is there help?

Which version of jitsi do you use? We had some improvement and bug
fixing in the away status switching in the nightly builds.

Regards
damencho

Thank you very much
Conrad

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#12

Dear all,

in my contact list in jitsi I have two entries for a friend of mine. One is his FriendX@jabber.org and the other is FriendX@jit.si. Is there any option to merge those to identities to one single entry? Apple Messages is able to do that by adding both addresses to his addressbook entry.

How would I do this in Jitsi?

Best,
steve


#13

Just drag one and drop it over the other.

Emil

--sent from my mobile

···

On Sep 29, 2012 9:18 PM, "Steve" <stevebell@gulli.com> wrote:

Dear all,

in my contact list in jitsi I have two entries for a friend of mine. One
is his FriendX@jabber.org and the other is FriendX@jit.si. Is there any
option to merge those to identities to one single entry? Apple Messages is
able to do that by adding both addresses to his addressbook entry.

How would I do this in Jitsi?

Best,
steve


#14

That is simple. Should have known from adium.

Thanks emil :slight_smile:

···

Am 29.09.2012 um 21:25 schrieb Emil Ivov <emcho@jitsi.org>:

Just drag one and drop it over the other.

Emil