[jitsi-dev] sound selection file manager will not enter non-empty directories


#1

Build 4126 running on Win7 64-bit and Ubuntu 32-bit:

Tools -> Options -> Events:

1. select "Incoming Call"
2. click the "folder" icon next to the path of the default .wav file
3. File manager comes up titled "Choose a sound file"
4. attempting to navigate into a non-empty directory from within that
window results in a "busy" mouse pointer and no action. It is simply
not possible to enter non-empty folders.

Is this a known issue?

Alex


#2

Hello,

I was able to reproduce this (in r9748). This is what I see in the logs:

      [java] 06:07:29.746 SEVERE: util.UtilActivator.uncaughtException().89 An uncaught exception occurred in thread=Thread[Basic L&F File Loading Thread,6,main] and message was: org/jitsi/util/SoundFileUtils
      [java] java.lang.NoClassDefFoundError: org/jitsi/util/SoundFileUtils
      [java] at net.java.sip.communicator.plugin.notificationconfiguration.SoundFilter.accept(SoundFilter.java:80)
      [java] at javax.swing.JFileChooser.accept(JFileChooser.java:1594)
      [java] at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run0(BasicDirectoryModel.java:250)
      [java] at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run(BasicDirectoryModel.java:232)
      [java] Caused by: java.lang.ClassNotFoundException: org.jitsi.util.SoundFileUtils not found by [45]
      [java] at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:812)
      [java] at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:72)
      [java] at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1807)
      [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:266)

Looks like the Plugin Manager Notification bundle does not import the new org.jitsi.util package. I'm not sure what's the correct way to fix this, but the attached patch seems to work.

Boris

notificationconfiguration-mf.patch (696 Bytes)

···

On 07/24/12 00:20, Alexandros Papadopoulos wrote:

Build 4126 running on Win7 64-bit and Ubuntu 32-bit:

Tools -> Options -> Events:

1. select "Incoming Call"
2. click the "folder" icon next to the path of the default .wav file
3. File manager comes up titled "Choose a sound file"
4. attempting to navigate into a non-empty directory from within that
window results in a "busy" mouse pointer and no action. It is simply
not possible to enter non-empty folders.

Is this a known issue?

Alex


#3

Build 4126 running on Win7 64-bit and Ubuntu 32-bit:

Tools -> Options -> Events:

1. select "Incoming Call"
2. click the "folder" icon next to the path of the default .wav file
3. File manager comes up titled "Choose a sound file"
4. attempting to navigate into a non-empty directory from within that
window results in a "busy" mouse pointer and no action. It is simply
not possible to enter non-empty folders.

Is this a known issue?

Alex

Alex, thank you very much for the feedback! Could you please try Boris' fix in r9749?

Looks like the Plugin Manager Notification bundle does not import the new org.jitsi.util package. I'm not sure what's the correct way to fix this, but the attached patch seems to work.

Boris, thank you very much for the patch!

···

On Jul 24, 2012, at 6:14 AM, Boris Grozev wrote:

On 07/24/12 00:20, Alexandros Papadopoulos wrote:


#4

Would I need to setup a jitsi build environment? Please explain what I
would need to do.

Thanks

Alex

···

On 24 July 2012 08:24, Lyubomir Marinov <lubo@jitsi.org> wrote:

On Jul 24, 2012, at 6:14 AM, Boris Grozev wrote:

On 07/24/12 00:20, Alexandros Papadopoulos wrote:

Build 4126 running on Win7 64-bit and Ubuntu 32-bit:

Tools -> Options -> Events:

1. select "Incoming Call"
2. click the "folder" icon next to the path of the default .wav file
3. File manager comes up titled "Choose a sound file"
4. attempting to navigate into a non-empty directory from within that
window results in a "busy" mouse pointer and no action. It is simply
not possible to enter non-empty folders.

Is this a known issue?

Alex

Alex, thank you very much for the feedback! Could you please try Boris' fix in r9749?


#5

If you don't have a Jitsi build environment setup yet, we'd suggest just testing the affected feature after your Jitsi updates during your normal workflow with it then.

···

On Jul 24, 2012, at 10:37 AM, Alexandros Papadopoulos wrote:

Would I need to setup a jitsi build environment? Please explain what I
would need to do.


#6

I can confirm this works fine in build 4134 - thank you for the prompt fix!

Alex

···

On 24 July 2012 09:02, Lyubomir Marinov <lubo@jitsi.org> wrote:

On Jul 24, 2012, at 10:37 AM, Alexandros Papadopoulos wrote:

Would I need to setup a jitsi build environment? Please explain what I
would need to do.

If you don't have a Jitsi build environment setup yet, we'd suggest just testing the affected feature after your Jitsi updates during your normal workflow with it then.