[jitsi-dev] Something broken with Debian install?


#1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hey all, this is bugging me because for ages jitsi-meet was working
beautifully then a couple of updates back it broke and now I cannot get
it working again. Even if I purge the configuration completely and
re-install the packages from the repo something is broken. Basically I
cannot create conferences or invite anyone it just fails. Looking at the
log, prosody.log I see this:

- -- CUT --
Nov 06 00:11:00 portmanager info Activated service 'http' on
[::]:5280, [*]:5280
Nov 06 00:11:00 portmanager info Activated service 'https' on
[::]:5281, [*]:5281
Nov 06 00:11:04 jcp261adc0 info Incoming Jabber component connection
Nov 06 00:11:04 focus.jitmeet.domain.tld:component info External
component successfully authenticated
Nov 06 00:11:04 c2s2624de0 info Client connected
Nov 06 00:11:06 sasl warn Client is violating RFC 3920 (section
6.1, point 7).
Nov 06 00:11:06 c2s2624de0 info Authenticated as
focus@auth.jitmeet.domain.tld
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
warn Component not connected, bouncing error for: <iq id='ywhpS-5'
type='get' to='jitsi-videobridge.jitmeet.domain.tld'
from='focus@auth.jitmeet.domain.tld/focus997139972266684'>
Nov 06 00:11:06 jcp265bf60 info Incoming Jabber component connection
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
info External component successfully authenticated

- -- CUT --

What is going on here and what is violating RFC2920? What is a bouncing
error?

It is very frustrating as previously the Debian installation was super easy.

Thanks.

- --

···

==

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd


#2

Hi,

Can you also check jvb and jicofo logs?

Regards
damencho

···

On Nov 5, 2015 6:21 PM, "Don Alexander" <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hey all, this is bugging me because for ages jitsi-meet was working
beautifully then a couple of updates back it broke and now I cannot get
it working again. Even if I purge the configuration completely and
re-install the packages from the repo something is broken. Basically I
cannot create conferences or invite anyone it just fails. Looking at the
log, prosody.log I see this:

- -- CUT --
Nov 06 00:11:00 portmanager info Activated service 'http' on
[::]:5280, [*]:5280
Nov 06 00:11:00 portmanager info Activated service 'https' on
[::]:5281, [*]:5281
Nov 06 00:11:04 jcp261adc0 info Incoming Jabber component connection
Nov 06 00:11:04 focus.jitmeet.domain.tld:component info External
component successfully authenticated
Nov 06 00:11:04 c2s2624de0 info Client connected
Nov 06 00:11:06 sasl warn Client is violating RFC 3920 (section
6.1, point 7).
Nov 06 00:11:06 c2s2624de0 info Authenticated as
focus@auth.jitmeet.domain.tld
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
warn Component not connected, bouncing error for: <iq id='ywhpS-5'
type='get' to='jitsi-videobridge.jitmeet.domain.tld'
from='focus@auth.jitmeet.domain.tld/focus997139972266684'>
Nov 06 00:11:06 jcp265bf60 info Incoming Jabber component connection
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
info External component successfully authenticated

- -- CUT --

What is going on here and what is violating RFC2920? What is a bouncing
error?

It is very frustrating as previously the Debian installation was super
easy.

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlY78koACgkQuipFNInZ6evUMQCggKMuapWhsnM9/7ghLfx8G2yK
D88AnAs6PUyOKex58HBuS2S2ioYq3ZjQ
=jSSO
-----END PGP SIGNATURE-----

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

···

On 06/11/15 03:34, Damian Minkov wrote:

> Hi, > > Can you also check jvb and jicofo logs? > > Regards > damencho >

Sure.

The jvb.log and prosody logs are here :

http://pastebin.ca/3237616

There is nothing in the jicofo.log. It is empty.

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...


#4

Hi Don,

what Debian version do you use? There ware some compatibility issues
with libc in Wheezy and newer JVB versions, so you need update libc,
the simplest way is to do this just dist-upgrade to Jessie.

best,
Stan

···

2015-11-06 1:20 GMT+01:00 Don Alexander <debug@roosoft.ltd.uk>:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hey all, this is bugging me because for ages jitsi-meet was working
beautifully then a couple of updates back it broke and now I cannot get
it working again. Even if I purge the configuration completely and
re-install the packages from the repo something is broken. Basically I
cannot create conferences or invite anyone it just fails. Looking at the
log, prosody.log I see this:

- -- CUT --
Nov 06 00:11:00 portmanager info Activated service 'http' on
[::]:5280, [*]:5280
Nov 06 00:11:00 portmanager info Activated service 'https' on
[::]:5281, [*]:5281
Nov 06 00:11:04 jcp261adc0 info Incoming Jabber component connection
Nov 06 00:11:04 focus.jitmeet.domain.tld:component info External
component successfully authenticated
Nov 06 00:11:04 c2s2624de0 info Client connected
Nov 06 00:11:06 sasl warn Client is violating RFC 3920 (section
6.1, point 7).
Nov 06 00:11:06 c2s2624de0 info Authenticated as
focus@auth.jitmeet.domain.tld
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
warn Component not connected, bouncing error for: <iq id='ywhpS-5'
type='get' to='jitsi-videobridge.jitmeet.domain.tld'
from='focus@auth.jitmeet.domain.tld/focus997139972266684'>
Nov 06 00:11:06 jcp265bf60 info Incoming Jabber component connection
Nov 06 00:11:06 jitsi-videobridge.jitmeet.domain.tld:component
info External component successfully authenticated

- -- CUT --

What is going on here and what is violating RFC2920? What is a bouncing
error?

It is very frustrating as previously the Debian installation was super easy.

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlY78koACgkQuipFNInZ6evUMQCggKMuapWhsnM9/7ghLfx8G2yK
D88AnAs6PUyOKex58HBuS2S2ioYq3ZjQ
=jSSO
-----END PGP SIGNATURE-----

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

seems your component connection of videobridge had reconnected. But
empty jicofo log is not good, it seems to have connected to prosody,
at least it is seen in the logs, but it also must be printing logs.
Can you check jicofo, is there are any logs after you restart it?
What is the debian version you use? What is not working, no video
between clients? A message saying focus is not available, when
opening the room?

Regards
damencho

···

On Fri, Nov 6, 2015 at 4:13 AM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/11/15 03:34, Damian Minkov wrote:

> Hi, > > Can you also check jvb and jicofo logs? > > Regards > damencho >

Sure.

The jvb.log and prosody logs are here :

http://pastebin.ca/3237616

There is nothing in the jicofo.log. It is empty.

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlY8fWIACgkQuipFNInZ6ev81wCeI8BRgQLB1tXsrIkyiR5L+1rU
CYMAnjmU61CLWQgAl73CHRf0vAsKyigJ
=ar/k
-----END PGP SIGNATURE-----


#6

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi, > > seems your component connection of videobridge had reconnected. But
empty jicofo log is not good, it seems to have connected to prosody, >

at least it is seen in the logs, but it also must be printing logs. >
Can you check jicofo, is there are any logs after you restart it? > What
is the debian version you use? What is not working, no video > between
clients? A message saying focus is not available, when > opening the
room? > > Regards > damencho >

Yeah I am perturbed by that as well but jicofo is running but the log is
empty. This is the jicofo config and the output from systemdctl status
jicofo:

http://pastebin.ca/3238333

As to what is happening I can start a session fine and the camera and
audio works fine. But when I click to add people to the conference this
is what happens:

https://imgur.com/a/7VF7k

I have installed on a DO droplet with Debian Jessie:

- -- CUT --

cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux jessie/stable"
NAME="Debian GNU/Linux"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support/"
BUG_REPORT_URL="https://bugs.debian.org/"

- -- CUT --

Like I have said I have purged the complete installation and reinstalled
it from scratch but cannot figure out what it happening :frowning:

Thanks.

- --

···

On 06/11/15 15:25, Damian Minkov wrote:

Don Alexander

It's a tough job, but some mug has to do it..


#7

Hi,

Something strange I see in your config is that jvb is configured to
serve the web (using its internal jetty), and this should be done only
if openjdk-8 is available for installation and will work only then.
But you are running using java 1.7, which is strange.

Regards
damencho

···

On Fri, Nov 6, 2015 at 11:51 AM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/11/15 15:25, Damian Minkov wrote:

Hi, > > seems your component connection of videobridge had reconnected.
But > empty jicofo log is not good, it seems to have connected to prosody, >
at least it is seen in the logs, but it also must be printing logs. > Can
you check jicofo, is there are any logs after you restart it? > What is the
debian version you use? What is not working, no video > between clients? A
message saying focus is not available, when > opening the room? > > Regards
> damencho >

Yeah I am perturbed by that as well but jicofo is running but the log is
empty. This is the jicofo config and the output from systemdctl status
jicofo:

http://pastebin.ca/3238333

As to what is happening I can start a session fine and the camera and audio
works fine. But when I click to add people to the conference this is what
happens:

https://imgur.com/a/7VF7k

I have installed on a DO droplet with Debian Jessie:

- -- CUT --

cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux jessie/stable"
NAME="Debian GNU/Linux"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support/"
BUG_REPORT_URL="https://bugs.debian.org/"

- -- CUT --

Like I have said I have purged the complete installation and reinstalled it
from scratch but cannot figure out what it happening :frowning:

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it..

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEUEARECAAYFAlY86IwACgkQuipFNInZ6evR2ACdEtImvLXsma0p7KvCC0hgMTMt
pXIAljd8cJk6iUW3p7bQa40HGb0MuKc=
=38qi
-----END PGP SIGNATURE-----


#8

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi, > > Something strange I see in your config is that jvb is configured to
serve the web (using its internal jetty), and this should be done only
if openjdk-8 is available for installation and will work only then. >

But you are running using java 1.7, which is strange. > > Regards >
damencho >

Hmmm that does seem odd yes. I do have Java 8 installed but also others.
The default /etc/alternatives/java is pointing to 1.7 though.

- -- CUT --

dpkg --get-selections |grep jdk
openjdk-6-jre-headless:amd64 install
openjdk-6-jre-lib install
openjdk-7-jre:amd64 install
openjdk-7-jre-headless:amd64 install
openjdk-8-jre:amd64 install
openjdk-8-jre-headless:amd64 install

- -- CUT --

- -- CUT --

ls -la /etc/alternatives/java
lrwxrwxrwx 1 root root 46 Dec 3 2014 /etc/alternatives/java ->
/usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java

- -- CUT --

I've changed the alternative to jdk 1.8 and restarted everything but
still no log for jicofo and still not able to create conferences. :frowning:

Anything else I can try ? Maybe run strace on something?

Thanks.

- --

···

On 06/11/15 23:05, Damian Minkov wrote:

Don Alexander

It's a tough job, but some mug has to do it...


#9

Hi,

you can stop jicofo and try running it in the console, take the
command line to use from the ps (from your logs:
/usr/share/jicofo/jicofo.sh --host=localhost
--domain=jitmeet.domain.tld --port=5347 --secret=xxxxxxx
--user_domain=auth.jitmeet.domain.tld --user_password=yyyyyyy).
Then the logs will be printed in the console and you can check for
errors and send them to us.

Regards
damencho

···

On Fri, Nov 6, 2015 at 8:32 PM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/11/15 23:05, Damian Minkov wrote:

Hi, > > Something strange I see in your config is that jvb is configured
to > serve the web (using its internal jetty), and this should be done only
> if openjdk-8 is available for installation and will work only then. > But
you are running using java 1.7, which is strange. > > Regards > damencho >

Hmmm that does seem odd yes. I do have Java 8 installed but also others. The
default /etc/alternatives/java is pointing to 1.7 though.

- -- CUT --

dpkg --get-selections |grep jdk
openjdk-6-jre-headless:amd64 install
openjdk-6-jre-lib install
openjdk-7-jre:amd64 install
openjdk-7-jre-headless:amd64 install
openjdk-8-jre:amd64 install
openjdk-8-jre-headless:amd64 install

- -- CUT --

- -- CUT --

ls -la /etc/alternatives/java
lrwxrwxrwx 1 root root 46 Dec 3 2014 /etc/alternatives/java ->
/usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java

- -- CUT --

I've changed the alternative to jdk 1.8 and restarted everything but still
no log for jicofo and still not able to create conferences. :frowning:

Anything else I can try ? Maybe run strace on something?

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlY9YqgACgkQuipFNInZ6ev/xwCfWwCNCW7NNMvEWdWeEZvxhmcS
3HsAn1GeAbOhA6A8IO+IqaUkpN4Up6B4
=z3uM
-----END PGP SIGNATURE-----


#10

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi, > > you can stop jicofo and try running it in the console, take the >

command line to use from the ps (from your logs: >
/usr/share/jicofo/jicofo.sh --host=localhost >
--domain=jitmeet.domain.tld --port=5347 --secret=xxxxxxx >
--user_domain=auth.jitmeet.domain.tld --user_password=yyyyyyy). > Then
the logs will be printed in the console and you can check for > errors
and send them to us. > > Regards > damencho > > > On Fri, Nov 6, 2015 at
8:32 PM, Don Alexander <debug@roosoft.ltd.uk> wrote: >> >>

Well considering there is nothing in the logs there seems to be a lot of
info messages in the console. :slight_smile: but no errors :frowning:

http://pastebin.ca/3239937

That is basically it. I tried again to create a conference but nothing
appeared in the console output of jicofo. It just sits there on the last
line

"INFO: XMPP provider
Jabber:focus@auth.jitmeet.domain.tld/focus1129290377960931@localhost
connected (JID: focus@auth.jitmeet.domain.tld/focus1129290377960931)"

What bugs me is I have purged the config more than once and each time
the installation works with no errors. What am I missing here? Is this a
file config issue? Or is there something else on the system a /etc/hosts
file or something left behind from an older manual installation or
something?

Perplexed.

Thanks.

- --

···

On 07/11/15 05:30, Damian Minkov wrote:

Don Alexander

It's a tough job, but some mug has to do it...


#11

Hi,

do you open the link https://your-domain/http-bind? (It should look
like https://meet.jit.si/http-bind)

Regards
damencho

···

On Sat, Nov 7, 2015 at 7:05 AM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 07/11/15 05:30, Damian Minkov wrote:

Hi, > > you can stop jicofo and try running it in the console, take the >
command line to use from the ps (from your logs: >
/usr/share/jicofo/jicofo.sh --host=localhost > --domain=jitmeet.domain.tld
--port=5347 --secret=xxxxxxx > --user_domain=auth.jitmeet.domain.tld
--user_password=yyyyyyy). > Then the logs will be printed in the console and
you can check for > errors and send them to us. > > Regards > damencho > > >
On Fri, Nov 6, 2015 at 8:32 PM, Don Alexander <debug@roosoft.ltd.uk> wrote:
>> >>

Well considering there is nothing in the logs there seems to be a lot of
info messages in the console. :slight_smile: but no errors :frowning:

http://pastebin.ca/3239937

That is basically it. I tried again to create a conference but nothing
appeared in the console output of jicofo. It just sits there on the last
line

"INFO: XMPP provider
Jabber:focus@auth.jitmeet.domain.tld/focus1129290377960931@localhost
connected (JID: focus@auth.jitmeet.domain.tld/focus1129290377960931)"

What bugs me is I have purged the config more than once and each time the
installation works with no errors. What am I missing here? Is this a file
config issue? Or is there something else on the system a /etc/hosts file or
something left behind from an older manual installation or something?

Perplexed.

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEUEARECAAYFAlY99woACgkQuipFNInZ6esFmQCfVgs4hocOMvtIpyJJLGMIYqbo
2FsAmIJDAMN52Ei1rZKxkm541s+fVNA=
=Vy/Y
-----END PGP SIGNATURE-----


#12

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi, > > do you open the link https://your-domain/http-bind? (It should look
like https://meet.jit.si/http-bind) > > Regards > damencho >

my url is https://jitmeet.my-domain

You land on the landing page

https://imgur.com/DFHigBO

Click on the box and some random string eg.
jitmeet/MerryElephantsApproachSlightly

When I use the URL jitmeet/http-bind I get:

- -- CUT --

It works! Now point your BOSH client to this URL to connect to Prosody.

For more information see Prosody: Setting up BOSH.

- -- CUT --

Looks encouraging. So was the BOSH module not set up in prosody for the
default Debian install?

Do I need to edit /etc/prosody/conf.d/*cfg.lua ?

Thanks.

- --

···

On 09/11/15 20:45, Damian Minkov wrote:

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd


#13

Yes, the BOSH module and the proxy to it are working. Do you use that same domain in the BOSH URL defined in config.js? Please paste the logs from the client when you try to open a conference.

Boris

···

On 09/11/15 15:59, Don Alexander wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 09/11/15 20:45, Damian Minkov wrote:

Hi, > > do you open the link https://your-domain/http-bind? (It should

look > like https://meet.jit.si/http-bind) > > Regards > damencho >

my url is https://jitmeet.my-domain

You land on the landing page

https://imgur.com/DFHigBO

Click on the box and some random string eg.
jitmeet/MerryElephantsApproachSlightly

When I use the URL jitmeet/http-bind I get:

- -- CUT --

It works! Now point your BOSH client to this URL to connect to Prosody.

For more information see Prosody: Setting up BOSH.

- -- CUT --

Looks encouraging. So was the BOSH module not set up in prosody for the
default Debian install?


#14

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> Yes, the BOSH module and the proxy to it are working. Do you use that

same domain in the BOSH URL defined in config.js? Please paste the logs
from the client when you try to open a conference. > > > Boris
Yes I use only one domain because I do not set any of the config files
up by hand. I let the jitmeet debian installer do all that when it
prompts for the hostname.

So I uninstalled re-installed it once again and seems I am getting a
jicofo log now.

You can see it here

http://pastebin.ca/3245412

Plenty of errors :frowning:

For the record this is what is listening on my machine:

- -- CUT --

netstat -lap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address
State PID/Program name
tcp 0 0 0.0.0.0:nextstep 0.0.0.0:*
LISTEN 24379/sshd
tcp 0 0 0.0.0.0:xmpp-server 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 jitmeet.local:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 jitmeet.domain.:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 localhost:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 0.0.0.0:3478 0.0.0.0:*
LISTEN 565/turnserver
tcp 0 0 localhost:postgresql 0.0.0.0:*
LISTEN 16896/postgres
tcp 0 0 localhost:smtp 0.0.0.0:*
LISTEN 25873/exim4
tcp 0 0 localhost:953 0.0.0.0:*
LISTEN 678/named
tcp 0 0 0.0.0.0:10010 0.0.0.0:*
LISTEN 1152/perl
tcp 0 0 0.0.0.0:5280 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 0.0.0.0:5281 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 localhost:5347 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 0.0.0.0:xmpp-client 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 localhost:xmpp-client localhost:60841
ESTABLISHED 18299/lua5.1
tcp 0 0 localhost:5347 localhost:43279
ESTABLISHED 18299/lua5.1
tcp 0 0 localhost:5347 localhost:43277
ESTABLISHED 18299/lua5.1
tcp6 0 0 [::]:nextstep [::]:*
LISTEN 24379/sshd
tcp6 0 0 [::]:xmpp-server [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:domain [::]:*
LISTEN 678/named
tcp6 0 0 [::]:8888 [::]:*
LISTEN 18419/java
tcp6 0 0 ip6-localhost:smtp [::]:*
LISTEN 25873/exim4
tcp6 0 0 ip6-localhost:953 [::]:*
LISTEN 678/named
tcp6 0 0 [::]:https [::]:*
LISTEN 18518/java
tcp6 0 0 [::]:5280 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:5281 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 ip6-localhost:5347 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:xmpp-client [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 localhost:43279 localhost:5347
ESTABLISHED 18518/java
tcp6 0 0 localhost:60841 localhost:xmpp-client
ESTABLISHED 18419/java
tcp6 0 0 localhost:43277 localhost:5347
ESTABLISHED 18419/java
udp 0 0 0.0.0.0:mdns
0.0.0.0:* 542/avahi-daemon: r
udp 0 0 0.0.0.0:43277
0.0.0.0:* 542/avahi-daemon: r
udp 0 0 0.0.0.0:10010
0.0.0.0:* 1152/perl
udp 0 0 jitmeet.local:domain
0.0.0.0:* 678/named
udp 0 0 jitmeet.domain.:domain
0.0.0.0:* 678/named
udp 0 0 localhost:domain
0.0.0.0:* 678/named
udp 0 0 localhost:51305 localhost:51305
ESTABLISHED 16896/postgres
udp 0 0 0.0.0.0:3478
0.0.0.0:* 565/turnserver
udp6 0 0 [::]:mdns
[::]:* 542/avahi-daemon: r
udp6 0 0 [::]:6398
[::]:* 18518/java
udp6 0 0 [::]:34837
[::]:* 18419/java
udp6 0 0 [::]:domain
[::]:* 678/named
udp6 0 0 [::]:58997
[::]:* 542/avahi-daemon: r

- -- CUT --

I wonder what could be going wrong?

- --

···

On 09/11/15 22:25, Boris Grozev wrote:

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd


#15

It is strange how there is a problem with accessing localhost 5347 and
seems jicofo has stopped and 2 secs later it is started again without
that problem and it seems connected now. So the logs seem ok.
As Bobi suggested, can you send us your client logs.

···

On Mon, Nov 9, 2015 at 7:11 PM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 09/11/15 22:25, Boris Grozev wrote:

> Yes, the BOSH module and the proxy to it are working. Do you use that

same domain in the BOSH URL defined in config.js? Please paste the logs
from the client when you try to open a conference. > > > Boris
Yes I use only one domain because I do not set any of the config files
up by hand. I let the jitmeet debian installer do all that when it
prompts for the hostname.

So I uninstalled re-installed it once again and seems I am getting a
jicofo log now.

You can see it here

http://pastebin.ca/3245412

Plenty of errors :frowning:

For the record this is what is listening on my machine:

- -- CUT --

netstat -lap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address
State PID/Program name
tcp 0 0 0.0.0.0:nextstep 0.0.0.0:*
LISTEN 24379/sshd
tcp 0 0 0.0.0.0:xmpp-server 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 jitmeet.local:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 jitmeet.domain.:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 localhost:domain 0.0.0.0:*
LISTEN 678/named
tcp 0 0 0.0.0.0:3478 0.0.0.0:*
LISTEN 565/turnserver
tcp 0 0 localhost:postgresql 0.0.0.0:*
LISTEN 16896/postgres
tcp 0 0 localhost:smtp 0.0.0.0:*
LISTEN 25873/exim4
tcp 0 0 localhost:953 0.0.0.0:*
LISTEN 678/named
tcp 0 0 0.0.0.0:10010 0.0.0.0:*
LISTEN 1152/perl
tcp 0 0 0.0.0.0:5280 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 0.0.0.0:5281 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 localhost:5347 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 0.0.0.0:xmpp-client 0.0.0.0:*
LISTEN 18299/lua5.1
tcp 0 0 localhost:xmpp-client localhost:60841
ESTABLISHED 18299/lua5.1
tcp 0 0 localhost:5347 localhost:43279
ESTABLISHED 18299/lua5.1
tcp 0 0 localhost:5347 localhost:43277
ESTABLISHED 18299/lua5.1
tcp6 0 0 [::]:nextstep [::]:*
LISTEN 24379/sshd
tcp6 0 0 [::]:xmpp-server [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:domain [::]:*
LISTEN 678/named
tcp6 0 0 [::]:8888 [::]:*
LISTEN 18419/java
tcp6 0 0 ip6-localhost:smtp [::]:*
LISTEN 25873/exim4
tcp6 0 0 ip6-localhost:953 [::]:*
LISTEN 678/named
tcp6 0 0 [::]:https [::]:*
LISTEN 18518/java
tcp6 0 0 [::]:5280 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:5281 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 ip6-localhost:5347 [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 [::]:xmpp-client [::]:*
LISTEN 18299/lua5.1
tcp6 0 0 localhost:43279 localhost:5347
ESTABLISHED 18518/java
tcp6 0 0 localhost:60841 localhost:xmpp-client
ESTABLISHED 18419/java
tcp6 0 0 localhost:43277 localhost:5347
ESTABLISHED 18419/java
udp 0 0 0.0.0.0:mdns
0.0.0.0:* 542/avahi-daemon: r
udp 0 0 0.0.0.0:43277
0.0.0.0:* 542/avahi-daemon: r
udp 0 0 0.0.0.0:10010
0.0.0.0:* 1152/perl
udp 0 0 jitmeet.local:domain
0.0.0.0:* 678/named
udp 0 0 jitmeet.domain.:domain
0.0.0.0:* 678/named
udp 0 0 localhost:domain
0.0.0.0:* 678/named
udp 0 0 localhost:51305 localhost:51305
ESTABLISHED 16896/postgres
udp 0 0 0.0.0.0:3478
0.0.0.0:* 565/turnserver
udp6 0 0 [::]:mdns
[::]:* 542/avahi-daemon: r
udp6 0 0 [::]:6398
[::]:* 18518/java
udp6 0 0 [::]:34837
[::]:* 18419/java
udp6 0 0 [::]:domain
[::]:* 678/named
udp6 0 0 [::]:58997
[::]:* 542/avahi-daemon: r

- -- CUT --

I wonder what could be going wrong?

- --

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlZBRFAACgkQuipFNInZ6etPUQCfRxwCW/v4m+KW6PxzHYTUoV16
jHYAoKStL91KfVPK4AUBfnuWe/rbvMX4
=s7GL
-----END PGP SIGNATURE-----


#16

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

···

On 10/11/15 17:14, Damian Minkov wrote:

It is strange how there is a problem with accessing localhost 5347 and > seems jicofo has stopped and 2 secs later it is started again without
that problem and it seems connected now. So the logs seem ok. > As

Bobi suggested, can you send us your client logs. >

How do you mean the client log? I am accessing it via a web browser. Do
you mean the jvb.log? The prosody log? Not sure what you are referring to?

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd


#17

Yes there are logs in the browser. I'm not sure which version of
jitsi-meet you are using. Latest has the client log in the settings, a
link in left bottom corner of the settings. The older location of the
download logs button is in the left bottom corner of the large video.
Please upload the logs after there are two clients in the room.

···

On Tue, Nov 10, 2015 at 6:52 PM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 10/11/15 17:14, Damian Minkov wrote:

It is strange how there is a problem with accessing localhost 5347 and >
seems jicofo has stopped and 2 secs later it is started again without > that
problem and it seems connected now. So the logs seem ok. > As Bobi
suggested, can you send us your client logs. >

How do you mean the client log? I am accessing it via a web browser. Do you
mean the jvb.log? The prosody log? Not sure what you are referring to?

Thanks.

- --

Don Alexander

It's a tough job, but some mug has to do it...

RooSoft Ltd

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlZCkUQACgkQuipFNInZ6euOTwCfZFDZfji0efViRwsV6+pjTT0V
YF8AmwbvKtEDfiynGQAPUTbJablYYkXj
=4SgI
-----END PGP SIGNATURE-----


#18

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yes there are logs in the browser. I'm not sure which version of > jitsi-meet you are using. Latest has the client log in the settings,

a > link in left bottom corner of the settings. The older location of
the > download logs button is in the left bottom corner of the large
video. > Please upload the logs after there are two clients in the room.

Ok having a little problem doing that. I can click on the chat window
and it shows download log there which is in json. It is here
http://pastebin.ca/3250798

However as soon as the message about not being able to create a
conference appears

https://imgur.com/xWZ3SbM

I am unable to click anything to get any more logs and in fact I need to
just close the window.

So not sure how I can get a more comprehensive log. Is there some sort
of debugging I can enable on server side?

Thanks.
- --

···

On 11/11/15 01:09, Damian Minkov wrote:

Don Alexander

It's a tough job, but some mug has to do it... RooSoft Ltd


#19

Hi,

those logs are enough to confirm that you don't have a focus (jicofo
component connected). Sending an iq to focus.jitmeet.domain.tld and
the result is an error: <service-unavailable .....Component
unavailable.
You need to check that jicofo can connect to the component port of
prosody, and that it connects successfully.
You can try $telnet localhost 5347 to see whether connection is allowed.

Strange is how jicofo is restarting just after the first error and in
your logs you first see connection refused and then that it had
connected, but why then prosody report that jicofo component is not
found. Are you restarting the services by hand in the terminal or you
have some script doing it?

Regards
damencho

···

On Fri, Nov 13, 2015 at 5:41 AM, Don Alexander <debug@roosoft.ltd.uk> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/11/15 01:09, Damian Minkov wrote:

Yes there are logs in the browser. I'm not sure which version of >
jitsi-meet you are using. Latest has the client log in the settings, a >
link in left bottom corner of the settings. The older location of the >
download logs button is in the left bottom corner of the large video. >
Please upload the logs after there are two clients in the room.

Ok having a little problem doing that. I can click on the chat window and it
shows download log there which is in json. It is here
http://pastebin.ca/3250798

However as soon as the message about not being able to create a conference
appears

https://imgur.com/xWZ3SbM

I am unable to click anything to get any more logs and in fact I need to
just close the window.

So not sure how I can get a more comprehensive log. Is there some sort of
debugging I can enable on server side?

Thanks.
- --

Don Alexander

It's a tough job, but some mug has to do it... RooSoft Ltd
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlZFzF4ACgkQuipFNInZ6esXiwCgkJVpOvYvUGSXH8wrgxfMhdNP
ec0AnRNLpPlBhFI+M3hCRodnnLamsvB7
=qi2R
-----END PGP SIGNATURE-----