[jitsi-dev] Small config bug


#1

Hey there,

I mentioned this bug as part of another mail a while ago but no one
responded, so I'll write about it explicitly before I forget it.

When doing some experiments with another jitsi user we encountered some
error messages saying that resampling was not possible. We then
attempted to use Opus with a different sample rate, but the setting
never took, the call info and the STDOUT output indicated that Opus was
still using 48kHz instead of the 24kHz we configured. It looked like
the setting had no effect at all.

AFAIR we both used some post 2.4 nightly build. I did not experiment
further to see whether this problem was present with other settings as
well.

Regards,
Philipp

···

--
JID: murks@jit.si


#2

Hello, Philipp,

Hey there,

I mentioned this bug as part of another mail a while ago but no one
responded, so I'll write about it explicitly before I forget it.

When doing some experiments with another jitsi user we encountered some
error messages saying that resampling was not possible. We then
attempted to use Opus with a different sample rate, but the setting
never took, the call info and the STDOUT output indicated that Opus was
still using 48kHz instead of the 24kHz we configured. It looked like
the setting had no effect at all.

This actually sounds normal. Currently the encoder only supports 48kHz
input, the decoder only supports 48kHz
output, and over the network opus is advertised as 48kHz. So you should
see 48kHz everywhere in the logs.

The setting in the interface affects opus' internal representation. If
it's set to something other than 48kHz (or if it's set to auto and the
bandwidth is set low enough) the encoder will automatically down-sample
its input. The decoder will also automatically up-sample anything it
receives to 48kHz. But that happens transparently in the opus library,
so it won't show up in the jitsi logs.

Regards,
Boris

···

On 26/01/14 21:42, Philipp �berbacher wrote:


#3

Hello, Philipp,

Hey there,

I mentioned this bug as part of another mail a while ago but no one
responded, so I'll write about it explicitly before I forget it.

When doing some experiments with another jitsi user we encountered some
error messages saying that resampling was not possible. We then
attempted to use Opus with a different sample rate, but the setting
never took, the call info and the STDOUT output indicated that Opus was
still using 48kHz instead of the 24kHz we configured. It looked like
the setting had no effect at all.

This actually sounds normal. Currently the encoder only supports 48kHz
input, the decoder only supports 48kHz
output, and over the network opus is advertised as 48kHz. So you should
see 48kHz everywhere in the logs.

The setting in the interface affects opus' internal representation. If
it's set to something other than 48kHz (or if it's set to auto and the
bandwidth is set low enough) the encoder will automatically down-sample
its input. The decoder will also automatically up-sample anything it
receives to 48kHz. But that happens transparently in the opus library,
so it won't show up in the jitsi logs.

Regards,
Boris

···

On 26/01/14 21:42, Philipp �berbacher wrote:


#4

Thanks Boris,
this was not obvious to me, I assumed that if set to 24kHz,
downsampling to 24kHz and transmitting the result to also show up as
24kHz. I do see the problem there though, the in/out is always 48kHz.

Thanks for the clarification.
Regards,
Philipp

···

On Sun, 26 Jan 2014 23:36:05 +0100 Boris Grozev <boris@jitsi.org> wrote:

Hello, Philipp,

On 26/01/14 21:42, Philipp Überbacher wrote:
> Hey there,
>
> I mentioned this bug as part of another mail a while ago but no one
> responded, so I'll write about it explicitly before I forget it.
>
> When doing some experiments with another jitsi user we encountered
> some error messages saying that resampling was not possible. We then
> attempted to use Opus with a different sample rate, but the setting
> never took, the call info and the STDOUT output indicated that Opus
> was still using 48kHz instead of the 24kHz we configured. It looked
> like the setting had no effect at all.

This actually sounds normal. Currently the encoder only supports 48kHz
input, the decoder only supports 48kHz
output, and over the network opus is advertised as 48kHz. So you
should see 48kHz everywhere in the logs.

The setting in the interface affects opus' internal representation. If
it's set to something other than 48kHz (or if it's set to auto and the
bandwidth is set low enough) the encoder will automatically
down-sample its input. The decoder will also automatically up-sample
anything it receives to 48kHz. But that happens transparently in the
opus library, so it won't show up in the jitsi logs.

Regards,
Boris

--
JID: murks@jit.si