[jitsi-dev] SIPgate problems or possibly bug


#1

Hi,

I wanted to use Jitsi for SIP calling via sipgate.de. Unfortunately I get an error "Message too big" when I try to call my friend. This happens straight after I try to establish the call.

Strangely, he can call me without any problems. Also, I can call the sipgate echo test number 10005@sipgate.de just fine. Maybe related, he's shown offline all the time although he insists he's online (even while we're talking, and I can see his online status on other softphones).

I attached the logs. Does anyone know why this happens and how I might get it to work?

Thanks a lot, and by the way: I've only used Jitsi for a couple of days but I love it! Thanks for your work!

Kind regards
Johannes

2012-09-15@15.58.02-logs.zip (522 KB)


#2

Hey Johannes,

Hi,

I wanted to use Jitsi for SIP calling via sipgate.de. Unfortunately I
get an error "Message too big" when I try to call my friend. This
happens straight after I try to establish the call.

This response gets returned from the server so apparently, for some
reason, the sipgate servers are configured not to accept messages a
above a certain length. I am not sure what the reason for this is or why
that limit is so short. What you can do however is to try and disable
codecs that you think you won't be using. Disabling H.264 and H.263
would have a strong impact on INVITE size.

Strangely, he can call me without any problems.

In that case INVITEs would have been generated by his client and they
may well be shorter than Jitsi's (we advertise a lot of stuff in ours
and it will only get worse when we add ICE).

Also, I can call the
sipgate echo test number 10005@sipgate.de just fine.

This is strange indeed but only sipgate would be able to explain.

Maybe related,
he's shown offline all the time although he insists he's online (even
while we're talking,

Your Jitsi instance seems to be sending a number of SUBSCRIBEs and never
gets an answer from sipgate. This would explain why presence won't work.

and I can see his online status on other softphones).

Well if sipgate answer SUBSCRIBEs from other phones then there must be
something in ours that they don't like. Unfortunately here too, only
they can provide an explanation.

I attached the logs. Does anyone know why this happens and how I
might get it to work?

Thanks a lot, and by the way: I've only used Jitsi for a couple of
days but I love it! Thanks for your work!

Thank you for your kind words!

Emil

···

On 15.09.12, 17:21, Johannes Wilke wrote:

--
https://jitsi.org


#3

Hi Emil,

thanks for your quick response. You were right, calling works flawlessly when I deactivate H.264. In fact, it even works when H.264 is still activated, and only the telephone-event/8000 codec is turned off (compared to presets).

Cocerning the online status - maybe I was just carried away. I just noticed that Sipgate doesn't seem to provide the online status at all (I think). And on my other softphone I mistook my own online status for my friend's.

So two mysteries solved. Thank you very much for your help, Emil. And all the best to the community! I'm looking forward to opus und V8 in v2.0...

Kind regards
Johannes

-------- Original-Nachricht --------

···

Datum: Sat, 15 Sep 2012 19:45:50 +0200
Von: Emil Ivov <emcho@jitsi.org>
An: dev@jitsi.java.net
CC: Johannes Wilke <johannes.wilke.company@gmx.de>
Betreff: [jitsi-dev] Re: SIPgate problems or possibly bug

Hey Johannes,

On 15.09.12, 17:21, Johannes Wilke wrote:
> Hi,
>
> I wanted to use Jitsi for SIP calling via sipgate.de. Unfortunately I
> get an error "Message too big" when I try to call my friend. This
> happens straight after I try to establish the call.

This response gets returned from the server so apparently, for some
reason, the sipgate servers are configured not to accept messages a
above a certain length. I am not sure what the reason for this is or why
that limit is so short. What you can do however is to try and disable
codecs that you think you won't be using. Disabling H.264 and H.263
would have a strong impact on INVITE size.

> Strangely, he can call me without any problems.

In that case INVITEs would have been generated by his client and they
may well be shorter than Jitsi's (we advertise a lot of stuff in ours
and it will only get worse when we add ICE).

> Also, I can call the
> sipgate echo test number 10005@sipgate.de just fine.

This is strange indeed but only sipgate would be able to explain.

> Maybe related,
> he's shown offline all the time although he insists he's online (even
> while we're talking,

Your Jitsi instance seems to be sending a number of SUBSCRIBEs and never
gets an answer from sipgate. This would explain why presence won't work.

> and I can see his online status on other softphones).

Well if sipgate answer SUBSCRIBEs from other phones then there must be
something in ours that they don't like. Unfortunately here too, only
they can provide an explanation.

> I attached the logs. Does anyone know why this happens and how I
> might get it to work?
>
> Thanks a lot, and by the way: I've only used Jitsi for a couple of
> days but I love it! Thanks for your work!

Thank you for your kind words!

Emil

--
https://jitsi.org


#4

Also, a suggestion: there should be a clear information about how to
unsuscribe in the website.


#5

You mean like we do on the following?

https://jitsi.org/mailinglists

Emil

P.S. You are now ubsubscribed.

···

On 15.09.12, 22:50, Marcelo J. Ruiz wrote:

Also, a suggestion: there should be a clear information about how to
unsuscribe in the website.